summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-01-15 18:06:44 +0000
committerPacho Ramos <pacho@gentoo.org>2014-01-15 18:06:44 +0000
commit116625abb451ae8986a8b32bd6e5856ba5e3fac8 (patch)
tree62c09a53e98a0c699cd326c95773ca217576e883 /media-plugins
parentversion bump for radvd (diff)
downloadgentoo-2-116625abb451ae8986a8b32bd6e5856ba5e3fac8.tar.gz
gentoo-2-116625abb451ae8986a8b32bd6e5856ba5e3fac8.tar.bz2
gentoo-2-116625abb451ae8986a8b32bd6e5856ba5e3fac8.zip
Fix compat with latest caps-plugins (#498018 by Markus)
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsaequal/ChangeLog11
-rw-r--r--media-plugins/alsaequal/alsaequal-0.6-r2.ebuild46
-rw-r--r--media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch63
3 files changed, 117 insertions, 3 deletions
diff --git a/media-plugins/alsaequal/ChangeLog b/media-plugins/alsaequal/ChangeLog
index 66bf0884a027..3cd8485e4619 100644
--- a/media-plugins/alsaequal/ChangeLog
+++ b/media-plugins/alsaequal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/alsaequal
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/ChangeLog,v 1.6 2013/06/27 18:41:11 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/ChangeLog,v 1.7 2014/01/15 18:06:44 pacho Exp $
+
+*alsaequal-0.6-r2 (15 Jan 2014)
+
+ 15 Jan 2014; Pacho Ramos <pacho@gentoo.org> +alsaequal-0.6-r2.ebuild,
+ +files/alsaequal-0.6-eq-name.patch:
+ Fix compat with latest caps-plugins (#498018 by Markus)
*alsaequal-0.6-r1 (27 Jun 2013)
@@ -27,4 +33,3 @@
15 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> +alsaequal-0.4.ebuild:
Initial commit wrt #279790, thanks to Jude Pereira for reporting.
-
diff --git a/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild b/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild
new file mode 100644
index 000000000000..3bdac0fa2ff7
--- /dev/null
+++ b/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/alsaequal-0.6-r2.ebuild,v 1.1 2014/01/15 18:06:44 pacho Exp $
+
+EAPI=5
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="a real-time adjustable equalizer plugin for ALSA"
+HOMEPAGE="http://www.thedigitalmachine.net/alsaequal.html"
+SRC_URI="http://www.thedigitalmachine.net/tools/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ >=media-plugins/caps-plugins-0.9.11[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r3
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-eq-name.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall -fPIC -DPIC" \
+ LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ Q= \
+ SND_PCM_LIBS="-lasound" \
+ SND_CTL_LIBS="-lasound" || die
+}
+
+multilib_src_install() {
+ exeinto /usr/$(get_libdir)/alsa-lib
+ doexe *.so || die
+}
diff --git a/media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch b/media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch
new file mode 100644
index 000000000000..7317214bf914
--- /dev/null
+++ b/media-plugins/alsaequal/files/alsaequal-0.6-eq-name.patch
@@ -0,0 +1,63 @@
+Description: Fix CAPS Eq plugin name
+Origin: vendor
+Bug-Debian: http://bugs.debian.org/721355
+Forwarded: no
+Author: Alessandro Ghedini <ghedo@debian.org>
+Last-Update: 2013-08-30
+
+--- a/ctl_equal.c
++++ b/ctl_equal.c
+@@ -167,7 +167,7 @@
+ snd_ctl_equal_t *equal;
+ const char *controls = ".alsaequal.bin";
+ const char *library = "/usr/lib/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ const char *sufix = " Playback Volume";
+ int err, i, index;
+--- a/pcm_equal.c
++++ b/pcm_equal.c
+@@ -151,7 +151,7 @@
+ snd_config_t *sconf = NULL;
+ const char *controls = ".alsaequal.bin";
+ const char *library = "/usr/lib/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ int err;
+
+--- a/README
++++ b/README
+@@ -1,11 +1,11 @@
+ Alsaequal is a real-time adjustable equalizer plugin for ALSA. It can
+ be adjusted using any ALSA compatible mixer, e.g. alsamixergui.
+
+-Alsaequal uses the Eq CAPS LADSPA Plugin for audio processing, actually
++Alsaequal uses the Eq10 CAPS LADSPA Plugin for audio processing, actually
+ alsaequal is a generic LADSPA plugin interface with real-time access to
+ the LADSPA controls (the LADSPA plugin included with alsa doesn't allow
+ for real-time controls) but it was developed for and only tested with
+-Eq CAPS LADSPA plugin. You are welcome to try it with other plugins, it
++Eq10 CAPS LADSPA plugin. You are welcome to try it with other plugins, it
+ may work. Let me know how it goes, you can reach me at
+ <charles@thedigitalmachine.net>.
+
+@@ -66,7 +66,7 @@
+ library -- location of the LADSPA library, the default is
+ "/usr/lib/ladspa/caps.so"
+ module -- module name within the LADSPA library, the deafault
+- is "Eq"
++ is "Eq10"
+ channels -- number of channels, the default is 2
+ }
+
+@@ -81,7 +81,7 @@
+ library -- location of the LADSPA library, the default is
+ "/usr/lib/ladspa/caps.so"
+ module -- module name within the LADSPA library, the deafault
+- is "Eq"
++ is "Eq10"
+ channels -- number of channels, the default is 2
+ }
+