summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-17 12:52:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-17 12:52:40 +0000
commit0f9c0eb8f2a631b7a687610463761bc2a4488f0b (patch)
treee996e37e0eda715369b430b96b96fd6c625f204a /media-sound/ecasound
parentVersion bump, closing bugs #234153 and #234173. (diff)
downloadgentoo-2-0f9c0eb8f2a631b7a687610463761bc2a4488f0b.tar.gz
gentoo-2-0f9c0eb8f2a631b7a687610463761bc2a4488f0b.tar.bz2
gentoo-2-0f9c0eb8f2a631b7a687610463761bc2a4488f0b.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog8
-rw-r--r--media-sound/ecasound/ecasound-2.5.0.ebuild98
-rw-r--r--media-sound/ecasound/files/ecasound-2.5.0-gcc43.patch12
3 files changed, 117 insertions, 1 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 64c4637a449d..f263f14b7677 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.45 2008/05/29 14:26:59 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.46 2008/08/17 12:52:40 aballier Exp $
+
+*ecasound-2.5.0 (17 Aug 2008)
+
+ 17 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/ecasound-2.5.0-gcc43.patch, +ecasound-2.5.0.ebuild:
+ version bump
29 May 2008; Ali Polatel <hawking@gentoo.org> ecasound-2.4.6.1.ebuild:
python_mod_compile is ROOT aware.
diff --git a/media-sound/ecasound/ecasound-2.5.0.ebuild b/media-sound/ecasound/ecasound-2.5.0.ebuild
new file mode 100644
index 000000000000..3e128986235f
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.5.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.5.0.ebuild,v 1.1 2008/08/17 12:52:40 aballier Exp $
+
+inherit eutils multilib python
+
+DESCRIPTION="a package for multitrack audio processing"
+HOMEPAGE="http://ecasound.seul.org/ecasound"
+SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
+
+DEPEND="python? ( dev-lang/python )
+ jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ libsamplerate? ( media-libs/libsamplerate )
+ mikmod? ( media-libs/libmikmod )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )
+ sndfile? ( media-libs/libsndfile )
+ sys-libs/readline"
+
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ die "Re-emerge media-libs/alsa-lib with USE midi."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ local PYConf
+
+ if use python; then
+ python_version
+ PYConf="--enable-pyecasound=c
+ --with-python-includes=/usr/include/python${PYVER}
+ --with-python-modules=/usr/$(get_libdir)/python${PYVER}"
+ else
+ PYConf="$myconf --disable-pyecasound"
+ fi
+
+ econf $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable ncurses) \
+ $(use_enable oss) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ --enable-shared \
+ --with-largefile \
+ --enable-sys-readline \
+ ${PYConf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc BUGS NEWS README TODO Documentation/*.txt
+ use doc && dohtml Documentation/*.html
+}
+
+pkg_postinst() {
+ if use python; then
+ ebegin "Byte-compiling ${CATEGORY}/${PF} python modules"
+ python_version
+ local PYMODULE
+ for PYMODULE in ecacontrol.py pyeca.py eci.py; do
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/${PYMODULE}
+ done
+ eend $?
+ fi
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support,"
+ ewarn "this is no longer supported and will go away in"
+ ewarn "future releases."
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/media-sound/ecasound/files/ecasound-2.5.0-gcc43.patch b/media-sound/ecasound/files/ecasound-2.5.0-gcc43.patch
new file mode 100644
index 000000000000..c01d67dd59b9
--- /dev/null
+++ b/media-sound/ecasound/files/ecasound-2.5.0-gcc43.patch
@@ -0,0 +1,12 @@
+Index: ecasound-2.5.0/libecasound/eca-static-object-maps.cpp
+===================================================================
+--- ecasound-2.5.0.orig/libecasound/eca-static-object-maps.cpp
++++ ecasound-2.5.0/libecasound/eca-static-object-maps.cpp
+@@ -27,6 +27,7 @@
+ #include <cstdlib>
+ #include <iostream>
+ #include <string>
++#include <cstring>
+ #include <algorithm>
+
+ #include <dlfcn.h>