summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-01-23 17:16:02 +0000
committerChristoph Mende <angelos@gentoo.org>2010-01-23 17:16:02 +0000
commit304fdc8d1508ff9ce107519fe5fb424ac4afe6cd (patch)
treeaa4d15855602abccee9114452ac2333f98d5f7e3 /media-sound/mpdscribble
parentMask www-client/opera (bug #283430). (diff)
downloadgentoo-2-304fdc8d1508ff9ce107519fe5fb424ac4afe6cd.tar.gz
gentoo-2-304fdc8d1508ff9ce107519fe5fb424ac4afe6cd.tar.bz2
gentoo-2-304fdc8d1508ff9ce107519fe5fb424ac4afe6cd.zip
Version bump
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpdscribble')
-rw-r--r--media-sound/mpdscribble/ChangeLog10
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.19.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/media-sound/mpdscribble/ChangeLog b/media-sound/mpdscribble/ChangeLog
index 2c0bf976a18f..b4e693d1655d 100644
--- a/media-sound/mpdscribble/ChangeLog
+++ b/media-sound/mpdscribble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpdscribble
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.31 2009/10/31 21:49:48 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.32 2010/01/23 17:16:02 angelos Exp $
+
+*mpdscribble-0.19 (23 Jan 2010)
+
+ 23 Jan 2010; Christoph Mende <angelos@gentoo.org>
+ +mpdscribble-0.19.ebuild:
+ Version bump
*mpdscribble-0.18.1 (30 Oct 2009)
diff --git a/media-sound/mpdscribble/mpdscribble-0.19.ebuild b/media-sound/mpdscribble/mpdscribble-0.19.ebuild
new file mode 100644
index 000000000000..f49b2d2eeaa2
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.19.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.19.ebuild,v 1.1 2010/01/23 17:16:02 angelos Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ curl? ( net-misc/curl )
+ !curl? ( net-libs/libsoup:2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.18-ldadd_gthread.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myclient=soup
+ use curl && myclient=curl
+ econf \
+ --disable-dependency-tracking \
+ --with-http-client=${myclient}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ chmod 600 "${D}"/etc/mpdscribble.conf
+ dodoc AUTHORS NEWS README
+ rm -r -f "${D}"/usr/share/doc/${PN}
+ dodir /var/cache/mpdscribble
+}