summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-25 09:06:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-25 09:06:15 +0000
commit77a6afc3b158e432ea7e62ba16a7adb466a5a128 (patch)
tree36e4eaf57c7a87dceadac8bf0718e8ad8b6a4560 /media-sound/mpfc
parentppc64 stable wrt #326151 (diff)
downloadgentoo-2-77a6afc3b158e432ea7e62ba16a7adb466a5a128.tar.gz
gentoo-2-77a6afc3b158e432ea7e62ba16a7adb466a5a128.tar.bz2
gentoo-2-77a6afc3b158e432ea7e62ba16a7adb466a5a128.zip
Missing include limits.h, required by recent linux-headers for cdrom.h and INT_MAX. Fix installation with recent coreutils wrt #335449 by Diego E. Pettenò.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpfc')
-rw-r--r--media-sound/mpfc/ChangeLog10
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch20
-rw-r--r--media-sound/mpfc/mpfc-1.3.7-r1.ebuild38
3 files changed, 49 insertions, 19 deletions
diff --git a/media-sound/mpfc/ChangeLog b/media-sound/mpfc/ChangeLog
index 98e2935301b1..9553e176a87f 100644
--- a/media-sound/mpfc/ChangeLog
+++ b/media-sound/mpfc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpfc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/ChangeLog,v 1.26 2009/07/22 15:57:16 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/ChangeLog,v 1.27 2010/10/25 09:06:15 ssuominen Exp $
+
+ 25 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> mpfc-1.3.7-r1.ebuild,
+ +files/mpfc-1.3.7-INT_MAX.patch:
+ Missing include limits.h, required by recent linux-headers for cdrom.h and
+ INT_MAX. Fix installation with recent coreutils wrt #335449 by Diego E.
+ Pettenò.
22 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> mpfc-1.3.7-r1.ebuild:
Rename USE cdaudio to USE cdda.
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch b/media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch
new file mode 100644
index 000000000000..8bca2f380366
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch
@@ -0,0 +1,20 @@
+--- plugins/input/audiocd/audiocd.c
++++ plugins/input/audiocd/audiocd.c
+@@ -21,6 +21,7 @@
+ */
+
+ #include <stdio.h>
++#include <limits.h> /* cdrom.h and INT_MAX */
+ #include <linux/cdrom.h>
+ #include <errno.h>
+ #include <string.h>
+--- plugins/input/audiocd/audiocd.h
++++ plugins/input/audiocd/audiocd.h
+@@ -23,6 +23,7 @@
+ #ifndef __SG_MPFC_AUDIOCD_H__
+ #define __SG_MPFC_AUDIOCD_H__
+
++#include <limits.h> /* cdrom.h and INT_MAX */
+ #include <linux/cdrom.h>
+ #include "types.h"
+ #include "logger.h"
diff --git a/media-sound/mpfc/mpfc-1.3.7-r1.ebuild b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
index afb1677bf8bb..b499d593f271 100644
--- a/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
+++ b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
@@ -1,34 +1,40 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.7-r1.ebuild,v 1.8 2009/07/22 15:57:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.7-r1.ebuild,v 1.9 2010/10/25 09:06:15 ssuominen Exp $
-inherit eutils autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="Music Player For Console"
HOMEPAGE="http://mpfc.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="alsa gpm mad vorbis oss wav cdda nls"
+
RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
gpm? ( >=sys-libs/gpm-1.19.3 )
mad? ( media-libs/libmad )
vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ sed -i \
+ -e 's:../src/file.h ../src/file.h:../src/file.h:' \
+ libmpfc/Makefile.am || die #335449
- epatch "${FILESDIR}/${P}-libdir.patch"
- epatch "${FILESDIR}/${PN}-gcc4.patch"
- epatch "${FILESDIR}/${P}-mathlib.patch"
- epatch "${FILESDIR}/${P}-asneeded.patch"
+ epatch "${FILESDIR}"/${P}-libdir.patch \
+ "${FILESDIR}"/${PN}-gcc4.patch \
+ "${FILESDIR}"/${P}-mathlib.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-INT_MAX.patch
AT_M4DIR="m4" eautoreconf
}
-src_compile() {
+src_configure() {
econf \
$(use_enable alsa) \
$(use_enable gpm) \
@@ -37,16 +43,14 @@ src_compile() {
$(use_enable oss) \
$(use_enable wav) \
$(use_enable cdda audiocd) \
- $(use_enable nls) \
- || die "configure failed"
-
- emake || die "emake failed"
+ $(use_enable nls)
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
- insinto /etc; doins mpfcrc
+ insinto /etc
+ doins mpfcrc || die
dodoc AUTHORS ChangeLog NEWS README
}