summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-19 00:23:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-19 00:23:36 +0000
commit8a8ebdd8c84fc805696cc013243fb5cff6eec38c (patch)
tree1751aa426e6897c4b110788368624fb6302df1d5 /media-sound/yconsole
parentStable on alpha, bug 89277. (diff)
downloadgentoo-2-8a8ebdd8c84fc805696cc013243fb5cff6eec38c.tar.gz
gentoo-2-8a8ebdd8c84fc805696cc013243fb5cff6eec38c.tar.bz2
gentoo-2-8a8ebdd8c84fc805696cc013243fb5cff6eec38c.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/yconsole')
-rw-r--r--media-sound/yconsole/ChangeLog10
-rw-r--r--media-sound/yconsole/files/digest-yconsole-3.0.81
-rw-r--r--media-sound/yconsole/files/yconsole-3.0.8-gcc33.patch31
-rw-r--r--media-sound/yconsole/metadata.xml6
-rw-r--r--media-sound/yconsole/yconsole-3.0.8.ebuild36
5 files changed, 77 insertions, 7 deletions
diff --git a/media-sound/yconsole/ChangeLog b/media-sound/yconsole/ChangeLog
index 9eac11ef104c..79776af36056 100644
--- a/media-sound/yconsole/ChangeLog
+++ b/media-sound/yconsole/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/yconsole
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/yconsole/ChangeLog,v 1.6 2004/07/13 03:13:25 eradicator Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yconsole/ChangeLog,v 1.7 2005/04/19 00:23:36 vapier Exp $
+
+*yconsole-3.0.8 (19 Apr 2005)
+
+ 19 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/yconsole-3.0.8-gcc33.patch, metadata.xml, +yconsole-3.0.8.ebuild:
+ Version bump.
12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
yconsole-3.0.5.ebuild:
diff --git a/media-sound/yconsole/files/digest-yconsole-3.0.8 b/media-sound/yconsole/files/digest-yconsole-3.0.8
new file mode 100644
index 000000000000..934f4c375a34
--- /dev/null
+++ b/media-sound/yconsole/files/digest-yconsole-3.0.8
@@ -0,0 +1 @@
+MD5 ed5164fb82da2946451b336ea5f7c408 yconsole-3.0.8.tar.bz2 498099
diff --git a/media-sound/yconsole/files/yconsole-3.0.8-gcc33.patch b/media-sound/yconsole/files/yconsole-3.0.8-gcc33.patch
new file mode 100644
index 000000000000..16b296b86d66
--- /dev/null
+++ b/media-sound/yconsole/files/yconsole-3.0.8-gcc33.patch
@@ -0,0 +1,31 @@
+Work around a gcc-3.3.x bug where redefining prototypes with different
+__THROW / attribute(nonnull) markings throws an error:
+
+string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
+../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
+
+basically we just use the glibc strcasestr() instead of the internal one.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85780
+
+--- yconsole/string.cpp
++++ yconsole/string.cpp
+@@ -30,3 +30,5 @@
+ #endif
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle);
++#endif
+ int strpfx(const char *s, const char *pfx);
+@@ -219,3 +221,4 @@
+ */
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle)
+ {
+@@ -274,6 +277,7 @@
+
+ return(NULL);
+ }
++#endif
+
+ /*
+ * Checks if string pfx is a prefix of string s.
diff --git a/media-sound/yconsole/metadata.xml b/media-sound/yconsole/metadata.xml
index 6a359b042300..cb49de1ecbcc 100644
--- a/media-sound/yconsole/metadata.xml
+++ b/media-sound/yconsole/metadata.xml
@@ -1,11 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer>
- <email>vapier@gentoo.org</email>
- <name>Mike Frysinger</name>
-</maintainer>
+<herd>sound</herd>
<longdescription>
YConsole allows you to monitor and control
the Y server in a GUI environment, using the GTK+ toolkit.
diff --git a/media-sound/yconsole/yconsole-3.0.8.ebuild b/media-sound/yconsole/yconsole-3.0.8.ebuild
new file mode 100644
index 000000000000..de4d6955d9e3
--- /dev/null
+++ b/media-sound/yconsole/yconsole-3.0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/yconsole/yconsole-3.0.8.ebuild,v 1.1 2005/04/19 00:23:36 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="monitor and control the Y server"
+HOMEPAGE="http://wolfpack.twu.net/YIFF/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1*
+ media-libs/imlib
+ media-libs/yiff"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/3.0.5-makefile-cflags.patch
+ epatch "${FILESDIR}"/${P}-gcc33.patch
+}
+
+src_compile() {
+ cd yconsole
+ make OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ cd yconsole
+ make install PREFIX="${D}"/usr || die
+ dodoc AUTHORS README
+}