summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-07-09 17:50:01 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-07-09 17:50:01 +0000
commit23b964539e53eea1efb71e54088fe2c2985933ea (patch)
tree653d08e6efa093d74b9177e1db9a2e918986a135 /net-im/aim-transport
parentVersion bumps for kernel attribute vulnerabilities, bug #56479. (Manifest rec... (diff)
downloadgentoo-2-23b964539e53eea1efb71e54088fe2c2985933ea.tar.gz
gentoo-2-23b964539e53eea1efb71e54088fe2c2985933ea.tar.bz2
gentoo-2-23b964539e53eea1efb71e54088fe2c2985933ea.zip
better init, used the muc tecnic
Diffstat (limited to 'net-im/aim-transport')
-rw-r--r--net-im/aim-transport/ChangeLog9
-rw-r--r--net-im/aim-transport/Manifest5
-rw-r--r--net-im/aim-transport/aim-transport-20040131-r2.ebuild60
-rw-r--r--net-im/aim-transport/files/aim-transport-conf.d9
-rw-r--r--net-im/aim-transport/files/aim-transport.init24
-rw-r--r--net-im/aim-transport/files/digest-aim-transport-20040131-r21
6 files changed, 99 insertions, 9 deletions
diff --git a/net-im/aim-transport/ChangeLog b/net-im/aim-transport/ChangeLog
index 78d52dc93203..85987e892afd 100644
--- a/net-im/aim-transport/ChangeLog
+++ b/net-im/aim-transport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/aim-transport
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/ChangeLog,v 1.17 2004/07/03 11:33:54 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/ChangeLog,v 1.18 2004/07/09 17:50:01 humpback Exp $
+
+*aim-transport-20040131-r2 (09 Jul 2004)
+
+ 09 Jul 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ +files/aim-transport-conf.d, files/aim-transport.init,
+ +aim-transport-20040131-r2.ebuild:
+ New revision that installs more stable init.d script
03 Jul 2004; Gustavo Felisberto <humpback@gentoo.org>;
-aim-transport-20030314.ebuild, aim-transport-20040131-r1.ebuild,
diff --git a/net-im/aim-transport/Manifest b/net-im/aim-transport/Manifest
index ff8932a384c4..b65ed36ce6f0 100644
--- a/net-im/aim-transport/Manifest
+++ b/net-im/aim-transport/Manifest
@@ -1,8 +1,11 @@
MD5 e82bf8a8acdcb76d0b023114d68a1bb1 ChangeLog 2412
MD5 1cc5763ed63f5ce9c4dae472a289f6a6 aim-transport-20040131-r1.ebuild 1378
+MD5 d4364e92aed82c0b04819e2d40283ed2 aim-transport-20040131-r2.ebuild 1456
MD5 6816c17429d2b0f735ff6f1e5872b2a1 metadata.xml 333
MD5 fc71050bb7266ee2b89046dd30db8815 files/README.Gentoo 1460
-MD5 4c3149b5fbf415309a0985953d2e0e50 files/aim-transport.init 432
+MD5 08d9951d8f17c69652051a84e6bc1906 files/aim-transport.init 696
MD5 d34af520e9b92e7356fe2c12d1943f80 files/aimtrans.patch 419
MD5 d760ae12ea46b20acd4327c40b35a9fb files/aimtrans.xml 607
+MD5 1a472d53279cf23325b2e6fca8c079e9 files/aim-transport-conf.d 430
+MD5 cb628e08c87e98dfc8d017367231953c files/digest-aim-transport-20040131-r2 81
MD5 cb628e08c87e98dfc8d017367231953c files/digest-aim-transport-20040131-r1 81
diff --git a/net-im/aim-transport/aim-transport-20040131-r2.ebuild b/net-im/aim-transport/aim-transport-20040131-r2.ebuild
new file mode 100644
index 000000000000..0f3daf57b4c7
--- /dev/null
+++ b/net-im/aim-transport/aim-transport-20040131-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/aim-transport-20040131-r2.ebuild,v 1.1 2004/07/09 17:50:01 humpback Exp $
+
+inherit eutils
+
+MY_PN="${PN}-stable"
+S="${WORKDIR}/${MY_PN}-${PV}"
+DESCRIPTION="AOL Instant Messaging transport for jabberd"
+
+HOMEPAGE="http://aim-transport.jabberstudio.org/"
+
+SRC_URI="http://aim-transport.jabberstudio.org/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~sparc ~ppc hppa"
+
+IUSE=""
+
+DEPEND="=net-im/jabberd-1.4*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/aimtrans.patch
+}
+
+src_compile() {
+ einfo
+ einfo "Please ignore any errors/warnings"
+ einfo
+ automake
+ libtoolize --force
+ aclocal
+ autoconf
+ ./configure --with-jabberd=/usr/include/jabberd || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/jabber /usr/lib/jabberd
+ insinto /usr/lib/jabberd
+ doins src/aimtrans.so
+ insinto /etc/jabber
+ doins ${FILESDIR}/aimtrans.xml
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/aim-transport.init-r2 aim-transport
+ insinto /etc/conf.d ; newins ${FILESDIR}/aim-transport-conf.d aim-transport
+ dodoc README ${FILESDIR}/README.Gentoo TODO aim.xml
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read /usr/share/doc/${PN}-${PVR}/README.Gentoo.gz"
+ einfo "And please notice that now aim-transport comes with a init.d script"
+ einfo "dont forget to add it to your runlevel."
+ einfo
+}
diff --git a/net-im/aim-transport/files/aim-transport-conf.d b/net-im/aim-transport/files/aim-transport-conf.d
new file mode 100644
index 000000000000..7d86d8247339
--- /dev/null
+++ b/net-im/aim-transport/files/aim-transport-conf.d
@@ -0,0 +1,9 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/files/aim-transport-conf.d,v 1.1 2004/07/09 17:50:01 humpback Exp $
+
+CONFIG="/etc/jabber/aimtrans.xml"
+
+#Need to find a way to fix the "double" expansion
+#PIDFILE= grep pid ${CONFIG} | sed -e 's/<[^>]*>//g' | sed s/' '//g
+PIDFILE="/var/log/jabber/aim.pid"
diff --git a/net-im/aim-transport/files/aim-transport.init b/net-im/aim-transport/files/aim-transport.init
index cb1bc57a3c5b..a90427da5617 100644
--- a/net-im/aim-transport/files/aim-transport.init
+++ b/net-im/aim-transport/files/aim-transport.init
@@ -7,17 +7,27 @@ depend() {
start() {
ebegin "Starting AIM Jabber Transport"
- /usr/sbin/jabberd -B -c /etc/jabber/aimtrans.xml -H /var/spool/jabber >/dev/null 2>&1
+ if [ -f ${PIDFILE} ]; then
+ if [ -z $(ps ax | grep `cat ${PIDFILE}` | grep -v grep ) ]
+ then
+ rm -f ${PIDFILE}
+ fi
+ fi
+
+ /usr/sbin/jabberd -B -c ${CONFIG} -H /var/spool/jabber >/dev/null 2>&1
eend $?
}
stop() {
ebegin "Stoping AIM Jabber Transport"
- kill `cat /var/log/jabber/aim.pid`
- sleep 2
- if [ -f /var/log/jabber/aim.pid ]; then
- kill -9 `cat /var/log/jabber/aim.pid`
- rm -f /var/log/jabber/aim.pid
- fi
+ if [ -f ${PIDFILE} ]; then
+ kill `cat ${PIDFILE}`
+ fi
+ sleep 2
+ if [ -f ${PIDFILE} ]; then
+ kill -9 `cat ${PIDFILE}`
+ rm -f ${PIDFILE}
+ fi
+ rm -f ${PIDFILE}
eend $?
}
diff --git a/net-im/aim-transport/files/digest-aim-transport-20040131-r2 b/net-im/aim-transport/files/digest-aim-transport-20040131-r2
new file mode 100644
index 000000000000..42ff7a1dd8c5
--- /dev/null
+++ b/net-im/aim-transport/files/digest-aim-transport-20040131-r2
@@ -0,0 +1 @@
+MD5 2688a1f00284122d8f6e04309e75032f aim-transport-stable-20040131.tar.gz 245641