summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-01-19 21:46:04 +0000
committerBen de Groot <yngwin@gentoo.org>2009-01-19 21:46:04 +0000
commit96161c3e618662dccb6e3a2c74c560ef3e16c205 (patch)
tree29a5d100c56d19bf5e09f93a57358f34a45ffecf /net-misc/italc
parentBlock =mono-2.2 w.r.t. bug 255450. (diff)
downloadgentoo-2-96161c3e618662dccb6e3a2c74c560ef3e16c205.tar.gz
gentoo-2-96161c3e618662dccb6e3a2c74c560ef3e16c205.tar.bz2
gentoo-2-96161c3e618662dccb6e3a2c74c560ef3e16c205.zip
Make italc build with split Qt 4.4
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-hh1 i686)
Diffstat (limited to 'net-misc/italc')
-rw-r--r--net-misc/italc/ChangeLog9
-rw-r--r--net-misc/italc/italc-1.0.3-r1.ebuild109
2 files changed, 116 insertions, 2 deletions
diff --git a/net-misc/italc/ChangeLog b/net-misc/italc/ChangeLog
index e77125b4aff6..c61578d1e21e 100644
--- a/net-misc/italc/ChangeLog
+++ b/net-misc/italc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/italc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/ChangeLog,v 1.11 2008/08/25 08:15:33 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/ChangeLog,v 1.12 2009/01/19 21:46:04 yngwin Exp $
+
+*italc-1.0.3-r1 (19 Jan 2009)
+
+ 19 Jan 2009; Ben de Groot <yngwin@gentoo.org> +italc-1.0.3-r1.ebuild:
+ Make italc build with split Qt 4.4
25 Aug 2008; Markus Ullmann <jokey@gentoo.org> italc-1.0.3.ebuild:
Add missing inputproto dependency
diff --git a/net-misc/italc/italc-1.0.3-r1.ebuild b/net-misc/italc/italc-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..57bf7d8448b7
--- /dev/null
+++ b/net-misc/italc/italc-1.0.3-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/italc/italc-1.0.3-r1.ebuild,v 1.1 2009/01/19 21:46:04 yngwin Exp $
+
+EAPI=1
+
+inherit autotools qt4 eutils autotools
+
+DESCRIPTION="Intelligent Teaching And Learning with Computers (iTALC) supports working with computers in school"
+HOMEPAGE="http://italc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/italc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X v4l crypt xinerama threads fbcon"
+
+RDEPEND="dev-libs/lzo
+ sys-apps/tcp-wrappers
+ media-libs/jpeg
+ sys-libs/zlib
+ dev-libs/openssl
+ x11-libs/qt-gui:4
+ xinerama? ( x11-libs/libXinerama )
+ X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-misc/xinput )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/inputproto )"
+
+pkg_setup() {
+ enewgroup italc
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # From upstream subversion with extra modification for asneeded,
+ # both working but very likely incorrect solutions.
+ # http://italc.svn.sourceforge.net/viewvc/italc/branches/STABLE_1-0/configure.in?r1=217&r2=219
+ epatch "${FILESDIR}"/${P}-fpic-asneeded.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ "--with-qtdir=${ROOT}/usr" \
+ "--with-linux" \
+ "--with-uinput" \
+ "--without-macosx-native" \
+ $(use_with xinerama) \
+ $(use_with X x) \
+ $(use_with X xkeyboard) \
+ $(use_with X xrandr) \
+ $(use_with X xfixes) \
+ $(use_with X xdamage) \
+ $(use_with X xtrap) \
+ $(use_with X xrecord) \
+ $(use_with X dpms) \
+ $(use_with v4l) \
+ $(use_with fbcon fbdev) \
+ $(use_with fbcon fbpm) \
+ $(use_with threads pthread) \
+ $(use_with crypt) \
+ || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ rm -r "${D}/usr/share/italc"
+ dodoc TODO README AUTHORS INSTALL ChangeLog
+
+ # -- disabled per 2007-04-04 as the icon is missing in upstream file
+ # -- joke
+ # Install server logo
+ #newicon ima/resources/client_manager.png ${PN}.png
+ #make_desktop_entry "${PN}" "iTALC Master" "${PN}.png" "Qt;KDE;Education"
+}
+
+pkg_postinst() {
+ elog "On the master, please run "
+ elog "# emerge --config =${CATEGORY}/${PF}"
+
+ elog "Please add the logins of master users (teachers) to the italc group by running"
+ elog "# usermod -a -G italc <loginname>"
+
+ elog ""
+}
+
+pkg_config() {
+ if [ ! -d /etc/italc/keys ] ; then
+ einfo "Creating public and private keys for italc in /etc/italc/keys."
+ /usr/bin/ica -role teacher -createkeypair > /dev/null
+ eend $?
+ einfo "Setting chmod 640 on private keys."
+ chgrp -R italc /etc/italc
+ chmod -R o-rwx /etc/italc/keys/private
+ else
+ einfo "Not creating new keypair, as /etc/italc/keys already exists"
+ fi
+}