summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-09-11 21:28:05 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-09-11 21:28:05 +0000
commit812c5c1637b352bf922ce448cd6aee94ba9a7b0e (patch)
tree7ca250ec133e997aacae287a28c273f31afaa93a /net-misc
parentSecurity bump (bug #440942). (diff)
downloadgentoo-2-812c5c1637b352bf922ce448cd6aee94ba9a7b0e.tar.gz
gentoo-2-812c5c1637b352bf922ce448cd6aee94ba9a7b0e.tar.bz2
gentoo-2-812c5c1637b352bf922ce448cd6aee94ba9a7b0e.zip
Add build-time fix for uclibc for bug #522158, thanks to David Flogeras for the patch; Roy suggested that I should use this one for 6.4.3 instead of what he has added to upstream.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.4.3.ebuild3
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-6.4.3-uclibc-fix.patch11
3 files changed, 20 insertions, 2 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index f41cbbbf6abe..e59e848131d6 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.417 2014/08/01 21:12:57 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.418 2014/09/11 21:28:05 williamh Exp $
+
+ 11 Sep 2014; William Hubbs <williamh@gentoo.org>
+ +files/dhcpcd-6.4.3-uclibc-fix.patch, dhcpcd-6.4.3.ebuild:
+ Add build-time fix for uclibc for bug #522158, thanks to David Flogeras for
+ the patch; Roy suggested that I should use this one for 6.4.3 instead of what
+ he has added to upstream.
01 Aug 2014; William Hubbs <williamh@gentoo.org> -dhcpcd-5.6.4.ebuild,
-dhcpcd-6.2.0-r1.ebuild, -files/dhcpcd-6.2.0-dynamic-init.patch,
diff --git a/net-misc/dhcpcd/dhcpcd-6.4.3.ebuild b/net-misc/dhcpcd/dhcpcd-6.4.3.ebuild
index 7deabeb53c59..d251326ffc5e 100644
--- a/net-misc/dhcpcd/dhcpcd-6.4.3.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-6.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.4.3.ebuild,v 1.9 2014/08/01 20:13:21 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.4.3.ebuild,v 1.10 2014/09/11 21:28:05 williamh Exp $
EAPI=5
@@ -52,6 +52,7 @@ fi
src_prepare()
{
+ epatch "${FILESDIR}"/${P}-uclibc-fix.patch
epatch_user
}
diff --git a/net-misc/dhcpcd/files/dhcpcd-6.4.3-uclibc-fix.patch b/net-misc/dhcpcd/files/dhcpcd-6.4.3-uclibc-fix.patch
new file mode 100644
index 000000000000..aa9078be17c3
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-6.4.3-uclibc-fix.patch
@@ -0,0 +1,11 @@
+diff -Naur a/dhcpcd-6.4.3/configure b/dhcpcd-6.4.3/configure
+--- a/dhcpcd-6.4.3/configure 2014-07-30 12:13:12.000000000 -0300
++++ b/dhcpcd-6.4.3/configure 2014-09-04 16:37:06.604044374 -0300
+@@ -493,6 +493,7 @@
+ #include <stdlib.h>
+ int main(void) {
+ arc4random();
++ arc4random_uniform();
+ return 0;
+ }
+ EOF