summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2006-10-10 12:01:13 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2006-10-10 12:01:13 +0000
commit68f15f3af23d0ad7f6b14ee08a567cf5a581e7ee (patch)
treef639bb5d1a1d395b2781a3479d167c616566efa3 /net-nntp
parentRemoved orphan patch for version 0.9.3_pre2. (diff)
downloadgentoo-2-68f15f3af23d0ad7f6b14ee08a567cf5a581e7ee.tar.gz
gentoo-2-68f15f3af23d0ad7f6b14ee08a567cf5a581e7ee.tar.bz2
gentoo-2-68f15f3af23d0ad7f6b14ee08a567cf5a581e7ee.zip
Fixed bug #150696. Thanks to impulze at impulze dot org for reporting it.
(Portage version: 2.1.1)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/klibido/ChangeLog6
-rw-r--r--net-nntp/klibido/files/klibido-0.2.5-gcc4.1.diff28
-rw-r--r--net-nntp/klibido/klibido-0.2.5.ebuild3
3 files changed, 35 insertions, 2 deletions
diff --git a/net-nntp/klibido/ChangeLog b/net-nntp/klibido/ChangeLog
index 3b8211bf2796..f4a3498bfa5b 100644
--- a/net-nntp/klibido/ChangeLog
+++ b/net-nntp/klibido/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/klibido
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.18 2006/08/23 19:15:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.19 2006/10/10 12:01:13 deathwing00 Exp $
+
+ 10 Oct 2006; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +files/klibido-0.2.5-gcc4.1.diff, klibido-0.2.5.ebuild:
+ Added a patch that Fixes version 0.2.5 so that it can be compiled with gcc 4.1.
*klibido-0.2.5 (23 Aug 2006)
diff --git a/net-nntp/klibido/files/klibido-0.2.5-gcc4.1.diff b/net-nntp/klibido/files/klibido-0.2.5-gcc4.1.diff
new file mode 100644
index 000000000000..1d023fcd85cd
--- /dev/null
+++ b/net-nntp/klibido/files/klibido-0.2.5-gcc4.1.diff
@@ -0,0 +1,28 @@
+diff -U 4 -H -b -w -B -E -d -i -r klibido-0.2.5-orig/src/nntpthreadsocket.h klibido-0.2.5/src/nntpthreadsocket.h
+--- klibido-0.2.5-orig/src/nntpthreadsocket.h 2006-10-10 13:43:13.000000000 +0200
++++ klibido-0.2.5/src/nntpthreadsocket.h 2006-10-10 13:44:52.000000000 +0200
+@@ -233,9 +233,9 @@
+ bool getBody(QString group, int artnum); //Unimplemented
+ bool getHead(QString group, int artnum); //Unimplemented
+ int m_getError() {return error;}
+ const char *m_getErrorDesc() {return (const char *) errorString;}
+- char * NntpThreadSocket::m_findEndLine( char * start, char * end );
++ char * m_findEndLine( char * start, char * end );
+ void setHost(NntpHost *nh);
+ bool m_sendCmd( QString& cmd, int response );
+ QTime prevTime, currentTime;
+
+diff -U 4 -H -b -w -B -E -d -i -r klibido-0.2.5-orig/src/yydecoder.h klibido-0.2.5/src/yydecoder.h
+--- klibido-0.2.5-orig/src/yydecoder.h 2006-10-10 13:43:13.000000000 +0200
++++ klibido-0.2.5/src/yydecoder.h 2006-10-10 13:46:02.000000000 +0200
+@@ -86,9 +86,9 @@
+ void crcInit();
+
+ private:
+
+- inline void yyDecoder::charCRC(const unsigned char *c);
++ inline void charCRC(const unsigned char *c);
+
+ QStringList m_fileParts;
+ QStringList::Iterator fileIterator;
+
diff --git a/net-nntp/klibido/klibido-0.2.5.ebuild b/net-nntp/klibido/klibido-0.2.5.ebuild
index bc6ebf9620c7..3fafe059344e 100644
--- a/net-nntp/klibido/klibido-0.2.5.ebuild
+++ b/net-nntp/klibido/klibido-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/klibido-0.2.5.ebuild,v 1.1 2006/08/23 19:15:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/klibido-0.2.5.ebuild,v 1.2 2006/10/10 12:01:13 deathwing00 Exp $
inherit kde db-use
@@ -32,6 +32,7 @@ src_unpack() {
sed -i \
-e "s,-I/usr/include/db4,-I${dbincldir}," \
"${S}"/src/Makefile.{am,in}
+ epatch "${FILESDIR}/${P}-gcc4.1.diff"
}
src_compile() {