summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2011-12-06 18:27:43 +0000
committerRaúl Porcel <armin76@gentoo.org>2011-12-06 18:27:43 +0000
commit1fcd0dc1c4a1da607137064bedc8097a83ef2019 (patch)
tree7e5b9828bb3c5f60335eed8864ad898f5b382908 /net-p2p
parentAdd myself as maintainer behind Christian. (diff)
downloadgentoo-2-1fcd0dc1c4a1da607137064bedc8097a83ef2019.tar.gz
gentoo-2-1fcd0dc1c4a1da607137064bedc8097a83ef2019.tar.bz2
gentoo-2-1fcd0dc1c4a1da607137064bedc8097a83ef2019.zip
Version bump wrt bug #393197, rename gtk USE-flag to X wrt bug #258479, enable X USE-flag by default wrt bug #254758, some fixes to the ebuild wrt bug #362781 by Raphaël Droz <gibboris at gmail dot com>
(Portage version: 2.1.10.38/cvs/Linux ia64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog9
-rw-r--r--net-p2p/amule/amule-2.3.1.ebuild102
2 files changed, 110 insertions, 1 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index faf6b0ad7237..58b41d0380a4 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/amule
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.157 2011/05/08 18:24:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.158 2011/12/06 18:27:43 armin76 Exp $
+
+*amule-2.3.1 (06 Dec 2011)
+
+ 06 Dec 2011; Raúl Porcel <armin76@gentoo.org> +amule-2.3.1.ebuild:
+ Version bump wrt bug #393197, rename gtk USE-flag to X wrt bug #258479,
+ enable X USE-flag by default wrt bug #254758, some fixes to the ebuild wrt
+ bug #362781 by Raphaël Droz <gibboris at gmail dot com>
08 May 2011; Raúl Porcel <armin76@gentoo.org> amule-2.2.6.ebuild,
+files/amule-2.2.6-gcc45.patch:
diff --git a/net-p2p/amule/amule-2.3.1.ebuild b/net-p2p/amule/amule-2.3.1.ebuild
new file mode 100644
index 000000000000..92b3f995b4df
--- /dev/null
+++ b/net-p2p/amule/amule-2.3.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.3.1.ebuild,v 1.1 2011/12/06 18:27:43 armin76 Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic wxwidgets
+
+MY_P=${PN/m/M}-${PV}
+S="${WORKDIR}"/${MY_P}
+
+DESCRIPTION="aMule, the all-platform eMule p2p client"
+HOMEPAGE="http://www.amule.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="daemon debug geoip nls remote stats unicode upnp +X"
+
+DEPEND=">=x11-libs/wxGTK-2.8.12
+ >=dev-libs/crypto++-5
+ >=sys-libs/zlib-1.2.1
+ stats? ( >=media-libs/gd-2.0.26[jpeg] )
+ geoip? ( dev-libs/geoip )
+ upnp? ( >=net-libs/libupnp-1.6.6 )
+ remote? ( >=media-libs/libpng-1.2.0
+ unicode? ( >=media-libs/gd-2.0.26 ) )"
+
+pkg_setup() {
+ if use stats && ! use X; then
+ einfo "Note: You would need both the X and stats USE flags"
+ einfo "to compile aMule Statistics GUI."
+ einfo "I will now compile console versions only."
+ fi
+}
+
+pkg_preinst() {
+ if use daemon || use remote; then
+ enewgroup p2p
+ enewuser p2p -1 -1 /home/p2p p2p
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.6-fallocate.diff
+}
+
+src_configure() {
+ local myconf
+
+ WX_GTK_VER="2.8"
+
+ if use X; then
+ einfo "wxGTK with X support will be used"
+ need-wxwidgets unicode
+ else
+ einfo "wxGTK without X support will be used"
+ need-wxwidgets base-unicode
+ fi
+
+ if use X ; then
+ use stats && myconf="${myconf}
+ --enable-wxcas
+ --enable-alc"
+ use remote && myconf="${myconf}
+ --enable-amule-gui"
+ else
+ myconf="
+ --disable-monolithic
+ --disable-amule-gui
+ --disable-wxcas
+ --disable-alc"
+ fi
+
+ econf \
+ --with-wx-config=${WX_CONFIG} \
+ --enable-amulecmd \
+ $(use_enable debug) \
+ $(use_enable !debug optimize) \
+ $(use_enable daemon amule-daemon) \
+ $(use_enable geoip) \
+ $(use_enable nls) \
+ $(use_enable remote webserver) \
+ $(use_enable stats cas) \
+ $(use_enable stats alcc) \
+ $(use_enable upnp) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use daemon; then
+ newconfd "${FILESDIR}"/amuled.confd amuled
+ newinitd "${FILESDIR}"/amuled.initd amuled
+ fi
+ if use remote; then
+ newconfd "${FILESDIR}"/amuleweb.confd amuleweb
+ newinitd "${FILESDIR}"/amuleweb.initd amuleweb
+ fi
+}