summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-04-25 12:21:09 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-04-25 12:21:09 +0000
commit3ae27df6f6653b69b5b03d6dab507153c51a1eb6 (patch)
tree6ab11acba334d6cd87f97b573eac2efed71afbfa /net-p2p
parentStable on ppc64; bug #175465 (diff)
downloadgentoo-2-3ae27df6f6653b69b5b03d6dab507153c51a1eb6.tar.gz
gentoo-2-3ae27df6f6653b69b5b03d6dab507153c51a1eb6.tar.bz2
gentoo-2-3ae27df6f6653b69b5b03d6dab507153c51a1eb6.zip
add 2.1.4
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog7
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.1.43
-rw-r--r--net-p2p/ktorrent/ktorrent-2.1.4.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index fc2a5f5f5996..0cdda5775435 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.46 2007/04/09 19:28:02 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.47 2007/04/25 12:21:09 hkbst Exp $
+
+*ktorrent-2.1.4 (25 Apr 2007)
+
+ 25 Apr 2007; Marijn Schouten <hkBst@gentoo.org> +ktorrent-2.1.4.ebuild:
+ add 2.1.4
09 Apr 2007; Marcus D. Hanwell <cryos@gentoo.org> ktorrent-2.1.3.ebuild:
Stable on amd64, bug 170303.
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.1.4 b/net-p2p/ktorrent/files/digest-ktorrent-2.1.4
new file mode 100644
index 000000000000..993324092289
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.1.4
@@ -0,0 +1,3 @@
+MD5 69d3d7df6200710181594da19ab8c248 ktorrent-2.1.4.tar.gz 3631999
+RMD160 8286012e5fbc0bd827d5cb70c7895e5460f21a0b ktorrent-2.1.4.tar.gz 3631999
+SHA256 d492f75801c180202e99ca9c9cdff0b54e2f5d8e4ae2dddccbf1aac218276c48 ktorrent-2.1.4.tar.gz 3631999
diff --git a/net-p2p/ktorrent/ktorrent-2.1.4.ebuild b/net-p2p/ktorrent/ktorrent-2.1.4.ebuild
new file mode 100644
index 000000000000..158da94f2d5e
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.1.4.ebuild,v 1.1 2007/04/25 12:21:09 hkbst Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="bg br ca cs cy da de el en_GB es et eu fr ga gl hu it ja km lt
+mk ms nb nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}