summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-09-07 19:13:38 +0000
committerThomas Sachau <tommy@gentoo.org>2013-09-07 19:13:38 +0000
commit9a794b9981301e7ee8b849876273355e754a4f24 (patch)
treea286c8365f37d77b8debbd5e7b96034d08d5c85d /net-p2p
parentStable for amd64, wrt bug #484014 (diff)
downloadgentoo-2-9a794b9981301e7ee8b849876273355e754a4f24.tar.gz
gentoo-2-9a794b9981301e7ee8b849876273355e754a4f24.tar.bz2
gentoo-2-9a794b9981301e7ee8b849876273355e754a4f24.zip
Version bump
(Portage version: 2.2.1-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/fms/ChangeLog10
-rw-r--r--net-p2p/fms/fms-0.3.71.ebuild71
2 files changed, 78 insertions, 3 deletions
diff --git a/net-p2p/fms/ChangeLog b/net-p2p/fms/ChangeLog
index 46a6dc23777c..18fbf548dece 100644
--- a/net-p2p/fms/ChangeLog
+++ b/net-p2p/fms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/fms
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.32 2012/12/21 10:27:03 tommy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.33 2013/09/07 19:13:38 tommy Exp $
+
+*fms-0.3.71 (07 Sep 2013)
+
+ 07 Sep 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +fms-0.3.71.ebuild:
+ Version bump
21 Dec 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> -fms-0.3.66.ebuild,
-fms-0.3.67.ebuild, -fms-0.3.69.ebuild:
@@ -190,4 +195,3 @@
+fms-0.3.29.ebuild:
Initial commit. Fixes bug 240087. Thanks to Dennis Nezic for the initial
ebuild.
-
diff --git a/net-p2p/fms/fms-0.3.71.ebuild b/net-p2p/fms/fms-0.3.71.ebuild
new file mode 100644
index 000000000000..9da93d5a2f3e
--- /dev/null
+++ b/net-p2p/fms/fms-0.3.71.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.71.ebuild,v 1.1 2013/09/07 19:13:38 tommy Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A spam-resistant message board application for Freenet"
+HOMEPAGE="http://freenetproject.org/tools.html"
+SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="frost"
+
+RDEPEND="virtual/libiconv
+ frost? ( net-libs/polarssl )
+ >=dev-libs/poco-1.4.3_p1
+ >=dev-db/sqlite-3.6.15"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup freenet
+ enewuser freenet -1 -1 /var/freenet freenet
+}
+
+src_prepare() {
+ edos2unix src/http/pages/showfilepage.cpp
+ epatch "${FILESDIR}"/${PN}-use-system-libs2.patch
+}
+
+src_configure() {
+ local mycmakeargs="-DI_HAVE_READ_THE_README=ON \
+ -DUSE_BUNDLED_SQLITE=OFF \
+ -DDO_CHARSET_CONVERSION=ON \
+ $(cmake-utils_use frost FROST_SUPPORT)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ insinto /var/freenet/fms
+ dobin "${CMAKE_BUILD_DIR}"/fms || die
+ doins *.htm || die "doinstall failed"
+ doins -r fonts images styles translations || die
+ fperms -R o-rwx /var/freenet/fms/ /usr/bin/fms
+ fowners -R freenet:freenet /var/freenet/fms/ /usr/bin/fms
+ doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
+ dodoc readme.txt || die "installing doc failed"
+}
+
+pkg_postinst() {
+ if ! has_version 'net-p2p/freenet' ; then
+ ewarn "FMS needs a freenet node to up-/download #ssages."
+ ewarn "Please make sure to have a node you can connect to"
+ ewarn "or install net-p2p/freenet to get FMS working."
+ fi
+ elog "By default, the FMS NNTP server will listen on port 1119,"
+ elog "and the web configuration interface will be running at"
+ elog "http://localhost:8080. For more information, read"
+ elog "${ROOT}usr/share/doc/${PF}/readme.txt.bz2"
+ if use frost; then
+ elog " "
+ elog "You need to enable frost on the config page"
+ elog "and restart fms for frost support."
+ fi
+}