summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-11-15 01:31:48 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-11-15 01:31:48 +0000
commitff3317ccd27737352cb908da2dbb85bd59343f6d (patch)
tree7f8ac366fbb18979b3db5cd2ae95927d1b3afc0a /net-p2p
parentVersion bump for dev channel release. (diff)
downloadgentoo-2-ff3317ccd27737352cb908da2dbb85bd59343f6d.tar.gz
gentoo-2-ff3317ccd27737352cb908da2dbb85bd59343f6d.tar.bz2
gentoo-2-ff3317ccd27737352cb908da2dbb85bd59343f6d.zip
Restore latest stable 4.4 ebuild. Remove 5.2.2-r1 for bug #336166 (removal of 5.x series).
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild (renamed from net-p2p/bittorrent/bittorrent-5.2.2-r1.ebuild)39
2 files changed, 27 insertions, 19 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 945500ed6e48..6a2947c9607d 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.142 2011/09/29 10:28:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.143 2011/11/15 01:31:46 dirtyepic Exp $
+
+ 15 Nov 2011; Ryan Hill <dirtyepic@gentoo.org> +bittorrent-4.4.0-r1.ebuild,
+ -bittorrent-5.2.2-r1.ebuild:
+ Restore latest stable 4.4 ebuild. Remove 5.2.2-r1 for bug #336166 (removal of
+ 5.x series).
15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
-bittorrent-4.4.0-r1.ebuild, -bittorrent-5.0.9-r1.ebuild,
diff --git a/net-p2p/bittorrent/bittorrent-5.2.2-r1.ebuild b/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild
index ac0ec33c6cec..7360d839dc19 100644
--- a/net-p2p/bittorrent/bittorrent-5.2.2-r1.ebuild
+++ b/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.2.2-r1.ebuild,v 1.1 2011/09/15 07:35:25 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild,v 1.7 2011/11/15 01:31:48 dirtyepic Exp $
+
+EAPI=3
-EAPI="3"
PYTHON_DEPEND="2"
-PYTHON_USE_WITH="threads"
inherit distutils fdo-mime eutils
@@ -14,34 +14,42 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="tool for distributing files via a distributed network of nodes"
HOMEPAGE="http://www.bittorrent.com/"
-SRC_URI="http://download.bittorrent.com/dl/archive/${MY_P}.tar.gz"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
LICENSE="BitTorrent"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 s390 sh sparc x86"
+IUSE="gtk"
-RDEPEND=">=dev-python/pycrypto-2.0
- >=dev-python/twisted-2
- dev-python/twisted-web
- net-zope/zope-interface"
+RDEPEND="gtk? (
+ >=x11-libs/gtk+-2.6:2
+ >=dev-python/pygtk-2.6
+ )
+ >=dev-python/pycrypto-2.0"
DEPEND="${RDEPEND}
app-arch/gzip
>=sys-apps/sed-4.0.5
dev-python/dnspython"
-DOCS="README.txt TRACKERLESS.txt public.key"
+DOCS="TRACKERLESS.txt public.key credits.txt"
PYTHON_MODNAME="BitTorrent"
src_prepare() {
# path for documentation is in lowercase #109743
sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
- distutils_src_prepare
}
src_install() {
distutils_src_install
- rm -f "${D}"/usr/bin/bittorrent
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+ dohtml redirdonate.html
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.ico "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
@@ -51,11 +59,6 @@ pkg_postinst() {
einfo "Remember that BitTorrent has changed file naming scheme"
einfo "To run BitTorrent just execute /usr/bin/bittorrent"
einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
- elog
- elog "If you are upgrading from bittorrent-4.4.0 you must remove "
- elog "the ~/.bittorrent dir to make this version work. Remember to "
- elog "do a backup first!"
- elog
distutils_pkg_postinst
fdo-mime_desktop_database_update
}