summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2005-06-02 06:33:24 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2005-06-02 06:33:24 +0000
commit1d2038461122b956d46b36d853a728de44d91de3 (patch)
treeb8346b9fb42439adea51669b5a7c76ef0a339a75 /net-proxy/http-replicator/http-replicator-3.0.ebuild
parentmark ~ppc (diff)
downloadgentoo-2-1d2038461122b956d46b36d853a728de44d91de3.tar.gz
gentoo-2-1d2038461122b956d46b36d853a728de44d91de3.tar.bz2
gentoo-2-1d2038461122b956d46b36d853a728de44d91de3.zip
Initial import of http-replicator
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-proxy/http-replicator/http-replicator-3.0.ebuild')
-rw-r--r--net-proxy/http-replicator/http-replicator-3.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-proxy/http-replicator/http-replicator-3.0.ebuild b/net-proxy/http-replicator/http-replicator-3.0.ebuild
new file mode 100644
index 000000000000..9c0044153c8b
--- /dev/null
+++ b/net-proxy/http-replicator/http-replicator-3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-3.0.ebuild,v 1.1 2005/06/02 06:33:24 griffon26 Exp $
+
+DESCRIPTION="Proxy cache for Gentoo packages"
+HOMEPAGE="http://gertjan.freezope.org/"
+SRC_URI="http://gertjan.freezope.org/replicator/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+
+src_compile() {
+ einfo "No compilation necessary"
+}
+
+src_install(){
+ # Daemon and repcacheman into /usr/bin
+ exeinto /usr/bin
+ doexe http-replicator
+ newexe ${FILESDIR}/http-replicator-3.0-callrepcacheman-0.1 repcacheman
+ if has_version '>=sys-apps/portage-2.0.51'; then
+ newexe ${FILESDIR}/http-replicator-3.0-repcacheman-0.33 repcacheman.py
+ else
+ newexe ${FILESDIR}/http-replicator-3.0-repcacheman-0.21 repcacheman.py
+ fi
+
+ # Config file into /etc/conf.d
+ insinto /etc/conf.d
+ newins ${FILESDIR}/http-replicator-3.0.conf http-replicator
+
+ # Docs
+ dodoc README debian/changelog
+
+ # init.d scripts
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/http-replicator-3.0.init http-replicator
+
+ # Man Page - Not Gentooified yet
+ doman http-replicator.1
+
+ insinto /etc/logrotate.d
+ newins debian/logrotate http-replicator
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Before starting http-replicator, please follow the next few steps:"
+ einfo "- modify /etc/conf.d/http-replicator if required"
+ einfo "- run /usr/bin/repcacheman to set up the cache"
+ einfo "- add http_proxy=\"http://serveraddress:8080\" to make.conf on"
+ einfo " the server as well as on the client machines"
+ einfo "- make sure GENTOO_MIRRORS in /etc/make.conf starts with several"
+ einfo " good http mirrors"
+ einfo
+ einfo "For more information please refer to the following forum thread:"
+ einfo " http://forums.gentoo.org/viewtopic-t-173226.html"
+ einfo
+}