summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-05-24 14:16:54 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-05-24 14:16:54 +0000
commit5d0a5c6724f43b257f6054cda1870a999e7590e5 (patch)
treeee43ad9314f0142d2fcd0fa3be1d6d7bd418b9c1 /perl-core/CGI
parentAdding perl-core (diff)
downloadgentoo-2-5d0a5c6724f43b257f6054cda1870a999e7590e5.tar.gz
gentoo-2-5d0a5c6724f43b257f6054cda1870a999e7590e5.tar.bz2
gentoo-2-5d0a5c6724f43b257f6054cda1870a999e7590e5.zip
Category Migration
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'perl-core/CGI')
-rw-r--r--perl-core/CGI/CGI-3.05.ebuild17
-rw-r--r--perl-core/CGI/CGI-3.07.ebuild18
-rw-r--r--perl-core/CGI/CGI-3.09.ebuild18
-rw-r--r--perl-core/CGI/CGI-3.10.ebuild18
-rw-r--r--perl-core/CGI/ChangeLog195
-rw-r--r--perl-core/CGI/Manifest20
-rw-r--r--perl-core/CGI/files/digest-CGI-3.051
-rw-r--r--perl-core/CGI/files/digest-CGI-3.071
-rw-r--r--perl-core/CGI/files/digest-CGI-3.091
-rw-r--r--perl-core/CGI/files/digest-CGI-3.101
-rw-r--r--perl-core/CGI/metadata.xml10
11 files changed, 300 insertions, 0 deletions
diff --git a/perl-core/CGI/CGI-3.05.ebuild b/perl-core/CGI/CGI-3.05.ebuild
new file mode 100644
index 000000000000..2cee90c10210
--- /dev/null
+++ b/perl-core/CGI/CGI-3.05.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/CGI-3.05.ebuild,v 1.1 2005/05/24 14:16:54 mcummings Exp $
+
+inherit perl-module
+
+myconf="INSTALLDIRS=vendor"
+MY_P=${PN}.pm-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The Perl CGI Module"
+SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${MY_P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/L/LD/LDS/CGI.pm-${PV}/"
+IUSE=""
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="x86 amd64 ppc sparc alpha mips ia64 ppc64"
+DEPEND=">=dev-lang/perl-5.8.0-r12"
diff --git a/perl-core/CGI/CGI-3.07.ebuild b/perl-core/CGI/CGI-3.07.ebuild
new file mode 100644
index 000000000000..fcb6b3091422
--- /dev/null
+++ b/perl-core/CGI/CGI-3.07.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/CGI-3.07.ebuild,v 1.1 2005/05/24 14:16:54 mcummings Exp $
+
+inherit perl-module
+
+myconf="INSTALLDIRS=vendor"
+MY_P=${PN}.pm-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Simple Common Gateway Interface Class"
+SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${MY_P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/L/LD/LDS/CGI.pm-${PV}/"
+IUSE=""
+SLOT="0"
+SRC_TEST="do"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~ia64 ~ppc64"
+DEPEND=">=dev-lang/perl-5.8.0-r12"
diff --git a/perl-core/CGI/CGI-3.09.ebuild b/perl-core/CGI/CGI-3.09.ebuild
new file mode 100644
index 000000000000..c28058f279dd
--- /dev/null
+++ b/perl-core/CGI/CGI-3.09.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/CGI-3.09.ebuild,v 1.1 2005/05/24 14:16:54 mcummings Exp $
+
+inherit perl-module
+
+myconf="INSTALLDIRS=vendor"
+MY_P=${PN}.pm-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Simple Common Gateway Interface Class"
+SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${MY_P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/L/LD/LDS/CGI.pm-${PV}/"
+IUSE=""
+SLOT="0"
+SRC_TEST="do"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~ia64 ~ppc64"
+DEPEND=">=dev-lang/perl-5.8.0-r12"
diff --git a/perl-core/CGI/CGI-3.10.ebuild b/perl-core/CGI/CGI-3.10.ebuild
new file mode 100644
index 000000000000..91cbfdc3b332
--- /dev/null
+++ b/perl-core/CGI/CGI-3.10.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/CGI-3.10.ebuild,v 1.1 2005/05/24 14:16:54 mcummings Exp $
+
+inherit perl-module
+
+myconf="INSTALLDIRS=vendor"
+MY_P=${PN}.pm-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Simple Common Gateway Interface Class"
+SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${MY_P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/L/LD/LDS/CGI.pm-${PV}/"
+IUSE=""
+SLOT="0"
+SRC_TEST="do"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~ia64 ~ppc64"
+DEPEND=">=dev-lang/perl-5.8.0-r12"
diff --git a/perl-core/CGI/ChangeLog b/perl-core/CGI/ChangeLog
new file mode 100644
index 000000000000..47746d2c1d92
--- /dev/null
+++ b/perl-core/CGI/ChangeLog
@@ -0,0 +1,195 @@
+# ChangeLog for dev-perl/CGI
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/ChangeLog,v 1.1 2005/05/24 14:16:54 mcummings Exp $
+
+*CGI-3.05 (24 May 2005)
+
+ 24 May 2005; Michael Cummings <mcummings@gentoo.org> +metadata.xml,
+ +CGI-3.05.ebuild, +CGI-3.07.ebuild, +CGI-3.09.ebuild, +CGI-3.10.ebuild:
+ Category migration from dev-perl to perl-core
+
+*CGI-3.10 (17 May 2005)
+
+ 17 May 2005; Michael Cummings <mcummings@gentoo.org> +CGI-3.10.ebuild:
+ New version, bug 92948, mod_perl2 fixes
+
+*CGI-3.09 (09 May 2005)
+
+ 09 May 2005; Elfyn McBratney <beu@gentoo.org> +CGI-3.09.ebuild:
+ Version bump.
+
+ 02 Apr 2005; Michael Cummings <mcummings@gentoo.org> CGI-3.00.ebuild,
+ CGI-3.04.ebuild:
+ Fixing perl deps to reflect bundled versions
+
+ 02 Apr 2005; Michael Cummings <mcummings@gentoo.org> -CGI-2.81.ebuild,
+ -CGI-2.93.ebuild, -CGI-2.97.ebuild, -CGI-2.98.ebuild, -CGI-2.99.ebuild:
+ Cleaning out old versions. Perl 5.8.2, our bottom base, came with CGI-3.00 -
+ any ebuilds for older versions are therefor suspect.
+
+ 01 Apr 2005; Aron Griffis <agriffis@gentoo.org> CGI-3.05.ebuild:
+ stable on ia64
+
+ 24 Mar 2005; Joseph Jezak <josejx@gentoo.org> CGI-3.05.ebuild:
+ Marked ppc stable for bug #86405.
+
+*CGI-3.07 (23 Mar 2005)
+
+ 23 Mar 2005; Michael Cummings <mcummings@gentoo.org> +CGI-3.07.ebuild:
+ New version on cpan
+
+ 09 Mar 2005; Markus Rothe <corsair@gentoo.org> CGI-3.05.ebuild:
+ Stable on ppc64
+
+ 29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
+ Change encoding to UTF-8 for GLEP 31 compliance
+
+ 24 Dec 2004; Yuta SATOH <nigoro@gentoo.org> CGI-3.05.ebuild:
+ added ~ppc64
+
+ 07 Nov 2004; Joshua Kinard <kumba@gentoo.org> CGI-3.05.ebuild:
+ Marked stable on mips.
+
+ 19 Oct 2004; Dylan Carlson <absinthe@gentoo.org> CGI-3.05.ebuild:
+ Stable on amd64.
+
+ 06 Oct 2004; Bryan Østergaard <kloeri@gentoo.org> CGI-3.05.ebuild:
+ Stable on alpha.
+
+ 27 Sep 2004; Gustavo Zacarias <gustavoz@gentoo.org> CGI-3.05.ebuild:
+ Stable on sparc
+
+ 27 Sep 2004; Michael Cummings <mcummings@gentoo.org> CGI-3.05.ebuild:
+ No bugs in 106 days, marking stable on x86
+
+ 26 Jun 2004; Danny van Dyk <kugelfang@gentoo.org> CGI-3.00.ebuild:
+ Marked stable on amd64.
+
+*CGI-3.05 (13 Jun 2004)
+
+ 13 Jun 2004; Michael Cummings <mcummings@gentoo.org> CGI-3.05.ebuild:
+ new version on cpan, closes bug 50599
+
+ 16 Apr 2004; Michael Cummings <mcummings@gentoo.org> CGI-2.97.ebuild,
+ CGI-2.98.ebuild, CGI-2.99.ebuild, CGI-3.00.ebuild, CGI-3.04.ebuild:
+ Syntax fix for newdepend, bug 29064
+
+ 19 Mar 2004; Eric Sammer <esammer@gentoo.org> :
+ Fixed category-less dependencies as per bug #45110.
+
+ 18 Feb 2004; Aron Griffis <agriffis@gentoo.org> CGI-3.04.ebuild:
+ stable on alpha and ia64
+
+*CGI-3.04 (07 Feb 2004)
+
+ 07 Feb 2004; Eric Sammer <esammer@gentoo.org> CGI-2.81.ebuild,
+ CGI-2.93.ebuild, CGI-2.97.ebuild, CGI-2.99.ebuild, CGI-3.04.ebuild:
+ Bumped revision. Closes bug #40706. Fixed headers in older ebuilds.
+
+ 18 Jan 2004; <gustavoz@gentoo.org> CGI-3.00.ebuild:
+ stable on sparc
+
+ 09 Jan 2004; Aron Griffis <agriffis@gentoo.org> CGI-2.98.ebuild:
+ stable on alpha
+
+ 28 Dec 2003; Joshua Kinard <kumba@gentoo.org> CGI-3.00.ebuild:
+ Move to mips stable (~mips -> mips)
+
+ 09 Nov 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.98.ebuild:
+ 2.99 is unmasked for x86 already - just following suit
+
+ 15 Oct 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.99.ebuild:
+ No changes in 73 days, marked stable
+
+*CGI-3.00 (20 Aug 2003)
+
+ 20 Aug 2003; Michael Cummings <mcummings@gentoo.org> CGI-3.00.ebuild:
+ SECURITY UPDATE. fix bug introduced by cross-site scripting vulnerability
+ "fix."
+
+ 13 Aug 2003; <rac@gentoo.org> CGI-2.97.ebuild, CGI-2.98.ebuild,
+ CGI-2.99.ebuild:
+ Add mips keywords, allow >=perl-5.8.0-r12 to fulfill file-spec dep in 2.97
+
+*CGI-2.99 (01 Aug 2003)
+
+ 01 Aug 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.99.ebuild:
+ CPAN Version bump
+
+*CGI-2.98 (23 Jul 2003)
+
+ 23 Jul 2003; <rac@gentoo.org> CGI-2.98.ebuild:
+ Upstream version bump, install into vendordir
+
+ 23 Jul 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.97.ebuild:
+ Had confirmation from arch's that this is fine to release. See
+ http://www.securityfocus.com/bid/8231 for security bulletin
+ regarding bug in
+ cross-site scripting vulnerability in CGI.pm
+
+
+ 23 Jul 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.97.ebuild:
+ Unmasking for x86. There is a security fix for cross site scripting included.
+
+*CGI-2.97 (16 Jul 2003)
+
+ 16 Jul 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.97.ebuild:
+ CPAN Version bump
+
+ 31 May 2003; Michael Cummings <mcummings@gentoo.org> CGI-2.81.ebuild,
+ CGI-2.93.ebuild:
+ Added missing DEPEND for File-Spec
+
+*CGI-2.93 (01 May 2003)
+
+ 01 May 2003; <rac@gentoo.org> CGI-2.91.ebuild, CGI-2.91.ebuild,
+ CGI-2.93.ebuild:
+ Upstream version bump, required to enable make test in mod_perl
+
+*CGI-2.81 (26 Mar 2003)
+
+ 26 Mar 2003; <rac@gentoo.org> CGI-2.81.ebuild, CGI-2.91.ebuild:
+ We had a situation (bug #18150) where the version of dev-perl/CGI was
+ between that in the perl 5.6.1 and the 5.8.0 core. After discussions
+ with dragon, avenj, carpaski, and lostlogic, it seemed most prudent to
+ bring the stable standalone CGI.pm version to 2.81 (same as in the
+ 5.8.0 core).
+
+*CGI-2.78-r3 (26 Mar 2003)
+
+ 26 Mar 2003; <rac@gentoo.org> CGI-2.78-r3.ebuild:
+ temporary back out #18150 fix until can fix properly
+
+ 26 Mar 2003; <rac@gentoo.org> CGI-2.78-r3.ebuild:
+ Change perl dependency to <=5.6.1, so as not to overwrite the newer version in
+ 5.8.0. Due to some technical problems with that, currently using =5.6.1*.
+ Thanks to Michael Cummings <mcummings@gentoo.org> in bug #18150.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
+*CGI-2.78-r2 (5 May 2002)
+
+ 30 Jul 2002; Calum Selkirk <cselkirk@gentoo.org> CGI-2.78-r2.ebuild :
+
+ Added ppc to KEYWORDS.
+
+ 5 May 2002; Seemant Kulleen <seemant@gentoo.org> CGI-2.78-r2.ebuild
+ files/digest-CGI-2.78-r2 :
+
+ Changed to using the perl-module.eclass
+
+*CGI-2.78-r1 (3 May 2002)
+
+ 3 May 2002; Donny Davies <woodchip@gentoo.org> :
+
+ Added LICENSE, SLOT.
+
+*CGI-2.78 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/perl-core/CGI/Manifest b/perl-core/CGI/Manifest
new file mode 100644
index 000000000000..20d1d606f00b
--- /dev/null
+++ b/perl-core/CGI/Manifest
@@ -0,0 +1,20 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 cf9b7a6fd227d05363144dfe81b58207 CGI-3.10.ebuild 638
+MD5 bd7e830a5920f337e9693b3dd89c5ee6 CGI-3.09.ebuild 632
+MD5 969aaae1c8add533f1217f8abc08e0d7 CGI-3.05.ebuild 598
+MD5 797eafe906da5a1ccce64a1e21b10ad4 ChangeLog 6440
+MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 4c755456f1d58b9eb8fec751656527e5 CGI-3.07.ebuild 638
+MD5 d636390da4b89f77f8d5459b1b863405 files/digest-CGI-3.07 63
+MD5 d656932fa84869904712f20b547ad76d files/digest-CGI-3.10 63
+MD5 95947d372e3976e31909b70bc1cb3053 files/digest-CGI-3.09 63
+MD5 e1cdd0f4a93e8a20503212fda36e4912 files/digest-CGI-3.05 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCijGJtG5z4I8BtQoRAv6gAJ0SrimUZa1YHHGyjWzMwXguwZw5BgCfYRUd
+GcEUmyVnAS0opeENIigYd2U=
+=XuXw
+-----END PGP SIGNATURE-----
diff --git a/perl-core/CGI/files/digest-CGI-3.05 b/perl-core/CGI/files/digest-CGI-3.05
new file mode 100644
index 000000000000..61efa324d3ea
--- /dev/null
+++ b/perl-core/CGI/files/digest-CGI-3.05
@@ -0,0 +1 @@
+MD5 4e1e2288369089e56e8a115aade93ea4 CGI.pm-3.05.tar.gz 206163
diff --git a/perl-core/CGI/files/digest-CGI-3.07 b/perl-core/CGI/files/digest-CGI-3.07
new file mode 100644
index 000000000000..550acba99d97
--- /dev/null
+++ b/perl-core/CGI/files/digest-CGI-3.07
@@ -0,0 +1 @@
+MD5 5f9c1ec38a08bde0bdf92916e0eacb43 CGI.pm-3.07.tar.gz 225451
diff --git a/perl-core/CGI/files/digest-CGI-3.09 b/perl-core/CGI/files/digest-CGI-3.09
new file mode 100644
index 000000000000..1e60d1829974
--- /dev/null
+++ b/perl-core/CGI/files/digest-CGI-3.09
@@ -0,0 +1 @@
+MD5 952f2806020b92b586f7be6bd12da6c6 CGI.pm-3.09.tar.gz 225687
diff --git a/perl-core/CGI/files/digest-CGI-3.10 b/perl-core/CGI/files/digest-CGI-3.10
new file mode 100644
index 000000000000..40788070cdba
--- /dev/null
+++ b/perl-core/CGI/files/digest-CGI-3.10
@@ -0,0 +1 @@
+MD5 63dc6621ebee69ec241cd5d86875714f CGI.pm-3.10.tar.gz 225718
diff --git a/perl-core/CGI/metadata.xml b/perl-core/CGI/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/perl-core/CGI/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>