summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2009-01-02 19:58:25 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2009-01-02 19:58:25 +0000
commit652805f7bb31a29ebc31a7e8036a53ff2f9d5308 (patch)
treec9c6b373c5c4996dabeffea2bc47226fde7ffbeb /sci-chemistry/molden
parent- work around gcc-4 lack of ssp by default support while +hardened is enabled (diff)
downloadgentoo-2-652805f7bb31a29ebc31a7e8036a53ff2f9d5308.tar.gz
gentoo-2-652805f7bb31a29ebc31a7e8036a53ff2f9d5308.tar.bz2
gentoo-2-652805f7bb31a29ebc31a7e8036a53ff2f9d5308.zip
Version bump.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'sci-chemistry/molden')
-rw-r--r--sci-chemistry/molden/ChangeLog9
-rw-r--r--sci-chemistry/molden/molden-4.7.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sci-chemistry/molden/ChangeLog b/sci-chemistry/molden/ChangeLog
index 9f50d97023c8..ae1e70d3cf5a 100644
--- a/sci-chemistry/molden/ChangeLog
+++ b/sci-chemistry/molden/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/molden
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/ChangeLog,v 1.26 2007/12/31 15:49:31 je_fro Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/ChangeLog,v 1.27 2009/01/02 19:58:25 cryos Exp $
+
+*molden-4.7 (02 Jan 2009)
+
+ 02 Jan 2009; Marcus D. Hanwell <cryos@gentoo.org> +molden-4.7.ebuild:
+ Version bump.
31 Dec 2007; Jeff Gardner <je_fro@gentoo.org> ChangeLog:
Fixing my email address
diff --git a/sci-chemistry/molden/molden-4.7.ebuild b/sci-chemistry/molden/molden-4.7.ebuild
new file mode 100644
index 000000000000..310462e5684a
--- /dev/null
+++ b/sci-chemistry/molden/molden-4.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-4.7.ebuild,v 1.1 2009/01/02 19:58:25 cryos Exp $
+
+inherit eutils toolchain-funcs flag-o-matic fortran
+
+MY_P="${PN}${PV}"
+DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
+HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
+SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="opengl"
+
+RDEPEND="opengl? ( virtual/glut
+ virtual/opengl )
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/libc"
+
+S="${WORKDIR}/${MY_P}"
+
+FORTRAN="g77 gfortran"
+
+src_compile() {
+ # Use -mieee on alpha, according to the Makefile
+ use alpha && append-flags -mieee
+
+ # Honor CC, CFLAGS, FC, and FFLAGS from environment;
+ # unfortunately a bash bug prevents us from doing typeset and
+ # assignment on the same line.
+ typeset -a args
+ args=( CC="$(tc-getCC) ${CFLAGS}" \
+ FC="${FORTRANC}" LDR="${FORTRANC}" FFLAGS="${FFLAGS}" )
+
+ einfo "Building Molden..."
+ emake -j1 "${args[@]}" || die "molden emake failed"
+ if use opengl ; then
+ einfo "Building Molden OpenGL helper..."
+ emake -j1 "${args[@]}" moldenogl || die "moldenogl emake failed"
+ fi
+}
+
+src_install() {
+ dobin molden || die "failed to install molden executable."
+ if use opengl ; then
+ dobin moldenogl || die "failed to install moldenogl."
+ fi
+
+ dodoc HISTORY README REGISTER || die "failed to install docs."
+ cd doc
+ uncompress * && dodoc * || die "failed to install docs."
+}