summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 17:50:26 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 17:50:26 +0000
commitc88045090a4d20ccf0e3c1c6584a2e1ca3cb2b2f (patch)
treecdc51eb6ed278f50ebfe3492b3bc58c5f1d15dba /sci-chemistry
parentversion bump, cleanup (diff)
downloadgentoo-2-c88045090a4d20ccf0e3c1c6584a2e1ca3cb2b2f.tar.gz
gentoo-2-c88045090a4d20ccf0e3c1c6584a2e1ca3cb2b2f.tar.bz2
gentoo-2-c88045090a4d20ccf0e3c1c6584a2e1ca3cb2b2f.zip
sci-chemistry/wxmacmolplt: Version BUmp, #439438; thanks Reinis Danne <rei4dan@gmail.com> for the ebuild
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog8
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch12
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.5.ebuild46
3 files changed, 65 insertions, 1 deletions
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
index 1abc046b1909..a17a8abd3ac0 100644
--- a/sci-chemistry/wxmacmolplt/ChangeLog
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/wxmacmolplt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.11 2014/01/06 09:27:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.12 2014/01/06 17:50:26 jlec Exp $
+
+*wxmacmolplt-7.5 (06 Jan 2014)
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> +wxmacmolplt-7.5.ebuild,
+ +files/wxmacmolplt-7.5-glew.patch:
+ Version BUmp, #439438; thanks Reinis Danne <rei4dan@gmail.com> for the ebuild
06 Jan 2014; Justin Lecher <jlec@gentoo.org> wxmacmolplt-7.4.2.ebuild,
metadata.xml:
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
new file mode 100644
index 000000000000..08986db5bff2
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
@@ -0,0 +1,12 @@
+diff -urN wxmacmolplt-7.4.2.orig/configure.ac wxmacmolplt-7.4.2/configure.ac
+--- wxmacmolplt-7.4.2.orig/configure.ac 2010-12-05 02:48:29.000000000 +0300
++++ wxmacmolplt-7.4.2/configure.ac 2010-12-06 19:30:24.000000000 +0300
+@@ -20,7 +20,7 @@
+ ;;
+ *)
+ HOST=LINUX
+- LIBGL="-lGL -lGLU"
++ LIBGL=`pkg-config --libs glu glew`
+ ;;
+ esac
+ AM_CONDITIONAL(HOST_IS_MSW, [test "x$HOST" == xMSW])
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5.ebuild
new file mode 100644
index 000000000000..20e03321edcb
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5.ebuild,v 1.1 2014/01/06 17:50:26 jlec Exp $
+
+EAPI=5
+
+WX_GTK_VER=2.9
+
+inherit autotools eutils wxwidgets
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
+SRC_URI="http://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="flash"
+
+RDEPEND="
+ media-libs/glew
+ media-libs/mesa
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ flash? ( media-libs/ming )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glew.patch
+ sed \
+ -e "/^dist_doc_DATA/d" \
+ -i Makefile.am || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-glew \
+ $(use_with flash ming)
+}
+
+src_install() {
+ default
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
+}