summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2006-05-09 21:50:47 +0000
committerDenis Dupeyron <calchan@gentoo.org>2006-05-09 21:50:47 +0000
commitfac6623c0b7e2455b40ae04e5a93c583c105e768 (patch)
tree1fa72e06d9001a526269a3df92eafb2add1567a0 /sci-electronics
parentmark stable on x86, #131971 (diff)
downloadgentoo-2-fac6623c0b7e2455b40ae04e5a93c583c105e768.tar.gz
gentoo-2-fac6623c0b7e2455b40ae04e5a93c583c105e768.tar.bz2
gentoo-2-fac6623c0b7e2455b40ae04e5a93c583c105e768.zip
Revision bump.
(Portage version: 2203-svn)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/ChangeLog7
-rw-r--r--sci-electronics/kicad/Manifest2
-rw-r--r--sci-electronics/kicad/files/digest-kicad-200604242
-rw-r--r--sci-electronics/kicad/kicad-20060424.ebuild100
4 files changed, 110 insertions, 1 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 52a665299965..9d96131ede64 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.3 2006/04/22 20:15:19 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.4 2006/05/09 21:50:47 calchan Exp $
+
+*kicad-20060424 (09 May 2006)
+
+ 09 May 2006; Denis Dupeyron <calchan@gentoo.org> +kicad-20060424.ebuild:
+ Revision bump.
22 Apr 2006; Denis Dupeyron <calchan@gentoo.org> kicad-20060328.ebuild:
Fix GNUisms ('cp -a' -> 'cp -pPR').
diff --git a/sci-electronics/kicad/Manifest b/sci-electronics/kicad/Manifest
index 20b391f8465f..1b44485a085d 100644
--- a/sci-electronics/kicad/Manifest
+++ b/sci-electronics/kicad/Manifest
@@ -1,4 +1,6 @@
MD5 bedede10e093234f94631c7e7f75d81e ChangeLog 573
MD5 9f1db0d56ee2a97c75ce18ab5def97fc files/digest-kicad-20060328 135
+MD5 01db8419debfa5c6b5ed47a511aaa30a files/digest-kicad-20060424 135
MD5 5c66a7ef6777548de356ef6aad26b486 kicad-20060328.ebuild 3423
+MD5 8af89c9bee247bb36c51a253de0db422 kicad-20060424.ebuild 3317
MD5 cefa75b0a06053277ea938f4e4fdd6e5 metadata.xml 219
diff --git a/sci-electronics/kicad/files/digest-kicad-20060424 b/sci-electronics/kicad/files/digest-kicad-20060424
new file mode 100644
index 000000000000..ab3c8acd3d80
--- /dev/null
+++ b/sci-electronics/kicad/files/digest-kicad-20060424
@@ -0,0 +1,2 @@
+MD5 c0073b57e6420934ad8846965f967524 kicad-2006-04-24.tgz 56566245
+MD5 85c627149f3574e9163e33598c87f537 kicad-20060424.tar.bz2 9579336
diff --git a/sci-electronics/kicad/kicad-20060424.ebuild b/sci-electronics/kicad/kicad-20060424.ebuild
new file mode 100644
index 000000000000..1c8a1f4147e1
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20060424.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20060424.ebuild,v 1.1 2006/05/09 21:50:47 calchan Exp $
+
+inherit eutils wxwidgets
+
+UPSTREAM_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+DESCRIPTION="Electronic schematic and PCB design tools."
+HOMEPAGE="http://www.lis.inpg.fr/realise_au_lis/kicad/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ !minimal? ( ftp://iut-tice.ujf-grenoble.fr/cao/${PN}-${UPSTREAM_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="unicode doc examples minimal"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ media-gfx/wings"
+
+pkg_setup() {
+ # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
+ WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+
+ # Check for proper wxGTK USE flags.
+ if use unicode; then
+ need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
+ else
+ need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
+ fi
+ built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+}
+
+src_unpack() {
+ unpack ${A} || die "Unpack failed"
+
+ # Use the chosen wx-config executable
+ sed -i -e "s:wx-config:${WX_CONFIG}:" ${S}/libs.*
+ sed -i -e "s:wx-config:${WX_CONFIG}:" ${S}/*/makefile.*
+}
+
+src_compile() {
+ # Build the main executables
+ emake -f makefile.gtk || die "make failed (main)"
+
+ # Minizip needs to be built independently
+ cd kicad/minizip
+ emake -f makefile.unx || die "make failed (minizip)"
+}
+
+src_install() {
+ # kicad doesn't use the autotools yet
+ exeinto /usr/lib/${PN}/linux
+ doexe eeschema/eeschema
+ doexe pcbnew/pcbnew
+ doexe cvpcb/cvpcb
+ doexe kicad/kicad
+ doexe kicad/minizip/minizip
+ doexe gerbview/gerbview
+ exeinto /usr/lib/${PN}/linux/plugins
+ doexe eeschema/plugins/netlist_form_pads-pcb
+ newicon kicad_icon.png kicad.png
+ make_wrapper kicad "/usr/lib/${PN}/linux/kicad"
+ make_desktop_entry kicad Kicad kicad.png Electronics
+
+ # kicad requires everything to be in the same place
+ cp -pPR library ${D}/usr/lib/${PN}
+ cp -pPR internat ${D}/usr/lib/${PN}
+ cp -pPR template ${D}/usr/lib/${PN}
+ cp -pPR help ${D}/usr/lib/${PN}
+ if ! use minimal ; then
+ cp -pPR ${WORKDIR}/kicad/library ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/modules ${D}/usr/lib/${PN}
+ cp -pPR ${WORKDIR}/kicad/template ${D}/usr/lib/${PN}
+ if use doc ; then
+ cp -pPR ${WORKDIR}/kicad/help ${D}/usr/lib/${PN}
+ fi
+ if use examples ; then
+ cp -pPR ${WORKDIR}/kicad/demos ${D}/usr/lib/${PN}
+ fi
+ fi
+ dodoc author.txt copyright.txt news.txt contrib.txt version.txt
+}
+
+pkg_postinst() {
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you open old projects,"
+ ewarn "you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ else
+ einfo "Please note that the PDF datasheets that can be linked to components from the default libraries"
+ einfo "cannot be mirrored by Gentoo for legal reasons."
+ einfo "If you want them, you need to download them yourself from :"
+ einfo "${HOMEPAGE}"
+ einfo "and install them manually."
+ fi
+}