summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-16 23:33:43 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-16 23:33:43 +0000
commit9c814ea7a682c18051d18a7a28c6f1b1727ac65c (patch)
tree2ec319f7e1d2ed34aafa6d525c4e6f50972e7a10 /sci-mathematics
parentCleanup (diff)
downloadgentoo-2-9c814ea7a682c18051d18a7a28c6f1b1727ac65c.tar.gz
gentoo-2-9c814ea7a682c18051d18a7a28c6f1b1727ac65c.tar.bz2
gentoo-2-9c814ea7a682c18051d18a7a28c6f1b1727ac65c.zip
bump to 2.9.9, remove 2.9.8. Fixes a build failure that Luigi Malago found.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/polymake/ChangeLog10
-rw-r--r--sci-mathematics/polymake/files/2.9.9-gentoo-binutils.patch22
-rw-r--r--sci-mathematics/polymake/polymake-2.9.9.ebuild (renamed from sci-mathematics/polymake/polymake-2.9.8.ebuild)39
3 files changed, 43 insertions, 28 deletions
diff --git a/sci-mathematics/polymake/ChangeLog b/sci-mathematics/polymake/ChangeLog
index 2d66657e65a4..a12476d8e511 100644
--- a/sci-mathematics/polymake/ChangeLog
+++ b/sci-mathematics/polymake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/polymake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.1 2010/11/03 08:39:25 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.2 2010/11/16 23:33:43 tomka Exp $
+
+*polymake-2.9.9 (16 Nov 2010)
+
+ 16 Nov 2010; Thomas Kahle <tomka@gentoo.org>
+ +files/2.9.9-gentoo-binutils.patch, -polymake-2.9.8.ebuild,
+ +polymake-2.9.9.ebuild:
+ bump to 2.9.9, remove 2.9.8. Fixes a build failure that Luigi Malago
+ found.
*polymake-2.9.8 (03 Nov 2010)
diff --git a/sci-mathematics/polymake/files/2.9.9-gentoo-binutils.patch b/sci-mathematics/polymake/files/2.9.9-gentoo-binutils.patch
new file mode 100644
index 000000000000..f65f15ae32b0
--- /dev/null
+++ b/sci-mathematics/polymake/files/2.9.9-gentoo-binutils.patch
@@ -0,0 +1,22 @@
+diff -U 3 -dHrN polymake-2.9.9.orig/perllib/Polymake/Core/CPlusPlus_config.pm polymake-2.9.9/perllib/Polymake/Core/CPlusPlus_config.pm
+--- polymake-2.9.9.orig/perllib/Polymake/Core/CPlusPlus_config.pm 2010-11-17 00:09:21.000000000 +0100
++++ polymake-2.9.9/perllib/Polymake/Core/CPlusPlus_config.pm 2010-11-17 00:10:49.000000000 +0100
+@@ -83,7 +83,7 @@
+ open my $nm, "$nm_util $file.exe |" or die "can't run nm utility: $!\n";
+ my %mangled;
+ while (<$nm>) {
+- if (my ($mangled)=/\s[TW]\s+(\S*PolymakeTest\S*)/) {
++ if (my ($mangled)=/\s[TWV]\s+(\S*PolymakeTest\S*)/) {
+ my $case= $mangled =~ /TestWrap/ ? 3 : $mangled =~ /TestNam/ ? 2 : $mangled =~ /TestGlob/ ? 1 : 0;
+ next if exists $mangled{$case};
+ dbg_print( "nm extracted global name $mangled" ) if $DebugLevel;
+@@ -109,7 +109,8 @@
+ to proper utility paths and optional flags if necessary
+ .
+ }
+- if ($demangled =~ ($case<=2 ? $constructor_re : $wrapped_constructor_re)) {
++ declare $wr_con_re=qr{.*}xo;
++ if ($demangled =~ ($case<=2 ? $constructor_re : $wr_con_re)) {
+ $mangled{$case}=$mangled;
+ } else {
+ dbg_print( "c++filt returned '$demangled',\n",
diff --git a/sci-mathematics/polymake/polymake-2.9.8.ebuild b/sci-mathematics/polymake/polymake-2.9.9.ebuild
index 940a86bf059c..50e0556382e6 100644
--- a/sci-mathematics/polymake/polymake-2.9.8.ebuild
+++ b/sci-mathematics/polymake/polymake-2.9.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.9.8.ebuild,v 1.1 2010/11/03 08:39:25 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.9.9.ebuild,v 1.1 2010/11/16 23:33:43 tomka Exp $
EAPI=2
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="research tool for polyhedral geometry and combinatorics"
SRC_URI="http://www.opt.tu-darmstadt.de/polymake/lib/exe/fetch.php/download/${P}.tar.bz2"
@@ -17,6 +17,7 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
+# TODO: Drop java.
DEPEND="dev-libs/gmp
dev-libs/libxml2
dev-perl/XML-LibXML
@@ -27,35 +28,20 @@ DEPEND="dev-libs/gmp
>=virtual/jdk-1.5.0"
RDEPEND="${DEPEND}"
-src_compile(){
- # Fixing makefile to not use escaped characters
- sed -i 's/uname -p/uname -i/' support/locate_build_dir
- # Remove stripping from install.pl
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gentoo-binutils.patch"
sed -i '/system "strip $to"/d' support/install.pl
- # Configure is asking questions
- # First accept defaults
- touch defaults || die "Cannot touch file"
- emake configure < defaults
- rm defaults
-
- OFLAG=`get-flag -O`
-
- # Now inject our answers
- cd "${S}/build.`uname -i`"
- sed -i 's,InstallTop=.*$,InstallTop=/usr/share/polymake,' conf.make
- sed -i 's,InstallArch=.*$,InstallArch=/usr/lib/polymake,' conf.make
- sed -i 's,InstallBin=.*$,InstallBin=/usr/bin,' conf.make
- sed -i 's,InstallDoc=.*$,InstallDoc=/usr/share/doc/${PF},' conf.make
- sed -i "s,CXXOPT=.*$,CXXOPT=${OFLAG}," conf.make
- cd "${S}"
- # The makefile respects CXXFLAGS and friends from the environment
-
einfo "During compile this package uses up to"
einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
einfo "you run into trouble."
+}
- emake || die "emake failed"
+src_configure () {
+ export CXXOPT=$(get-flag -O)
+ # Configure does not accept --host, therefore econf cannot be used
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir)
}
src_install(){
@@ -64,8 +50,7 @@ src_install(){
pkg_postinst(){
elog "Polymake uses Perl Modules compiled during install."
- elog "If something does not work after an upgrade of Perl"
- elog "please re-emerge polymake"
+ elog "You have to reinstall polymake after an upgrade of Perl."
elog " "
elog "This version of polymake does not ship docs. Sorry."
elog "Help can be found on http://www.opt.tu-darmstadt.de/polymake_doku/ "