summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2005-03-31 15:58:08 +0000
committerTom Gall <tgall@gentoo.org>2005-03-31 15:58:08 +0000
commit2b3d576b1bfc25aa3850d1765a415909a81cf396 (patch)
treeb1cd08fd56bde58a23ecea755bb0a395f2aec954 /sys-apps/baselayout
parentFixed BUG #87280 (multilib-strict). (diff)
downloadgentoo-2-2b3d576b1bfc25aa3850d1765a415909a81cf396.tar.gz
gentoo-2-2b3d576b1bfc25aa3850d1765a415909a81cf396.tar.bz2
gentoo-2-2b3d576b1bfc25aa3850d1765a415909a81cf396.zip
add hvc support for ppc64 partitioned systems
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/ChangeLog5
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r6.ebuild3
-rw-r--r--sys-apps/baselayout/files/rc-scripts-1.4.16-livecd-hvc.patch38
3 files changed, 44 insertions, 2 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index d6cc7cf0e67f..d4654454b736 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.224 2005/03/30 05:45:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.225 2005/03/31 15:58:08 tgall Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 31 Mar 2005; Tom Gall <tgall@gentoo.org> +rc-scripts-1.4.16-livecd-hvc.patch
+ add support for hvc (ppc64 console on partitioned systems)
+
*baselayout-1.11.10-r5 (30 Mar 2005)
30 Mar 2005; Mike Frysinger <vapier@gentoo.org>
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild
index c6e1fc0acd03..fd74c487a96c 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild,v 1.5 2005/03/01 22:01:23 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r6.ebuild,v 1.6 2005/03/31 15:58:08 tgall Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -46,6 +46,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/rc-scripts-1.4.16-splash.patch
epatch ${FILESDIR}/rc-scripts-1.4.16-livecd.patch
+ epatch ${FILESDIR}/rc-scripts-1.4.16-livecd-hvc.patch
#
# Baselayout setup
diff --git a/sys-apps/baselayout/files/rc-scripts-1.4.16-livecd-hvc.patch b/sys-apps/baselayout/files/rc-scripts-1.4.16-livecd-hvc.patch
new file mode 100644
index 000000000000..781a0acf30e2
--- /dev/null
+++ b/sys-apps/baselayout/files/rc-scripts-1.4.16-livecd-hvc.patch
@@ -0,0 +1,38 @@
+--- rc-scripts-1.4.16/sbin/livecd-functions.sh.orig 2005-03-22 20:40:25.912265336 -0600
++++ rc-scripts-1.4.16/sbin/livecd-functions.sh 2005-03-22 20:43:08.497311240 -0600
+@@ -150,7 +150,7 @@
+ sed -i -e '/^c[0-9]/ s/^/#/' /etc/inittab
+
+ # SPARC & HPPA console magic
+- if [ "${HOSTTYPE}" = "sparc" -o "${HOSTTYPE}" = "hppa" ]
++ if [ "${HOSTTYPE}" = "sparc" -o "${HOSTTYPE}" = "hppa" -o "${HOSTTYPE}" = "ppc64" ]
+ then
+ # Mount openprom tree for user debugging purposes
+ if [ "${HOSTTYPE}" = "sparc" ]
+@@ -179,6 +179,11 @@
+ echo "c${x}:12345:respawn:/sbin/mingetty --noclear --autologin root tty${x}" >> /etc/inittab
+ done
+ fi
++ if [ -c "/dev/hvc/0" ]
++ then
++ ln -s /dev/hvc/0 /dev/hvc0
++ echo "c0:12345:respawn:/sbin/agetty -nl /bin/bashlogin 9600 hvc0 vt320" >> /etc/inittab
++ fi
+ # The rest...
+ else
+ if [ "${LIVECD_CONSOLE}" = "tty0" -o "${LIVECD_CONSOLE}" = "" ]
+@@ -188,7 +193,13 @@
+ echo "c${x}:12345:respawn:/sbin/agetty -nl /bin/bashlogin 38400 tty${x} linux" >> /etc/inittab
+ done
+ else
+- echo "c1:12345:respawn:/sbin/agetty -nl /bin/bashlogin ${LIVECD_CONSOLE_BAUD} ${LIVECD_CONSOLE} vt100" >> /etc/inittab
++ if [ -c "/dev/hvc/0" ]
++ then
++ ln -s /dev/hvc/0 /dev/hvc0
++ echo "c1:12345:respawn:/sbin/agetty -nl /bin/bashlogin 9600 hvc0 vt320" >> /etc/inittab
++ else
++ echo "c1:12345:respawn:/sbin/agetty -nl /bin/bashlogin ${LIVECD_CONSOLE_BAUD} ${LIVECD_CONSOLE} vt100" >> /etc/inittab
++ fi
+ fi
+ fi
+ return 0