summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-04 17:30:31 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-04 17:30:31 +0000
commitf2fe64842f81fed4787718f78fdce49ce1de05f9 (patch)
treec80e518251e9463d7337c1a63c749789f3fcdcb4 /sys-apps/less
parentStable for amd64 wrt bug #464384 (diff)
downloadgentoo-2-f2fe64842f81fed4787718f78fdce49ce1de05f9.tar.gz
gentoo-2-f2fe64842f81fed4787718f78fdce49ce1de05f9.tar.bz2
gentoo-2-f2fe64842f81fed4787718f78fdce49ce1de05f9.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/ChangeLog7
-rw-r--r--sys-apps/less/less-458.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/less/ChangeLog b/sys-apps/less/ChangeLog
index d0288d0f0ada..a8525bc59c86 100644
--- a/sys-apps/less/ChangeLog
+++ b/sys-apps/less/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/less
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/ChangeLog,v 1.171 2013/03/24 05:01:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/ChangeLog,v 1.172 2013/04/04 17:30:31 vapier Exp $
+
+*less-458 (04 Apr 2013)
+
+ 04 Apr 2013; Mike Frysinger <vapier@gentoo.org> +less-458.ebuild:
+ Version bump.
24 Mar 2013; Mike Frysinger <vapier@gentoo.org> files/lesspipe.sh:
Add lzo support, and xz compressed man pages.
diff --git a/sys-apps/less/less-458.ebuild b/sys-apps/less/less-458.ebuild
new file mode 100644
index 000000000000..528a23ee8bc8
--- /dev/null
+++ b/sys-apps/less/less-458.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/less-458.ebuild,v 1.1 2013/04/04 17:30:31 vapier Exp $
+
+EAPI="4"
+
+inherit eutils
+
+CODE2COLOR_PV="0.2"
+CODE2COLOR_P="code2color-${CODE2COLOR_PV}"
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz
+ http://www-zeuthen.desy.de/~friebel/unix/less/code2color -> ${CODE2COLOR_P}"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}"/${CODE2COLOR_P} "${S}"/code2color || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${CODE2COLOR_P}.patch
+}
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ econf \
+ --with-regex=$(usex pcre pcre posix) \
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+}
+
+src_install() {
+ default
+
+ dobin code2color
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ dosym lesspipe /usr/bin/lesspipe.sh
+ newenvd "${FILESDIR}"/less.envd 70less
+
+ dodoc "${FILESDIR}"/README.Gentoo
+}
+
+pkg_postinst() {
+ einfo "lesspipe offers colorization options. Run 'lesspipe -h' for info."
+}