summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-05-23 18:46:56 +0000
committerMike Gilbert <floppym@gentoo.org>2015-05-23 18:46:56 +0000
commitab3453e875820f184d291ff348f1436b87d54894 (patch)
tree107ec2f05482be38aef9c2da096b5d2f95500406 /sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild
parentamd64 stable wrt bug #550214 (diff)
downloadgentoo-2-ab3453e875820f184d291ff348f1436b87d54894.tar.gz
gentoo-2-ab3453e875820f184d291ff348f1436b87d54894.tar.bz2
gentoo-2-ab3453e875820f184d291ff348f1436b87d54894.zip
Version bumps. Ebuilds by Arfrever.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild')
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild
new file mode 100644
index 000000000000..36d393dd7086
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-4.0.4.ebuild,v 1.1 2015/05/23 18:46:56 floppym Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="6"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://tuxonice.nigelcunningham.com.au/ https://github.com/NigelCunningham/tuxonice-kernel"
+
+TUXONICE_PV="4.0.2"
+TUXONICE_DATE="2015-05-11"
+
+TUXONICE_PATCH="tuxonice-for-linux-${TUXONICE_PV}-${TUXONICE_DATE}.patch.bz2"
+TUXONICE_URI="http://tuxonice.nigelcunningham.com.au/downloads/all/${TUXONICE_PATCH}"
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_PATCH}"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"