summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2004-08-23 11:54:09 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2004-08-23 11:54:09 +0000
commit0e7a3861e43acd59b43919c9f5dd19fe84a47a17 (patch)
treec4bb48c551f5f2364e3750d37d79aecaf25dcaba /sys-libs/db
parentAdd a function to the db.eclass that clears out the symlinks that are shared ... (diff)
downloadgentoo-2-0e7a3861e43acd59b43919c9f5dd19fe84a47a17.tar.gz
gentoo-2-0e7a3861e43acd59b43919c9f5dd19fe84a47a17.tar.bz2
gentoo-2-0e7a3861e43acd59b43919c9f5dd19fe84a47a17.zip
Clean out the -r9 release
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog8
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild4
-rw-r--r--sys-libs/db/db-3.2.9-r9.ebuild140
-rw-r--r--sys-libs/db/db-3.3.11.ebuild3
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r91
5 files changed, 11 insertions, 145 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 5958de34bfa4..d7fb46a3c963 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/db
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.96 2004/08/12 00:51:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.97 2004/08/23 11:54:09 pauldv Exp $
+
+ 23 Aug 2004; <pauldv@gentoo.org> db-3.3.11.ebuild:
+ Add IUSE
+
+ 23 Aug 2004; <pauldv@gentoo.org> db-3.2.9-r10.ebuild, -db-3.2.9-r9.ebuild:
+ Clean out the -r9 release
11 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> db-3.2.9-r10.ebuild:
gnuconfig_update in src_unpack
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
index 348a2d930cff..295774f638a2 100644
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.11 2004/08/12 00:51:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.12 2004/08/23 11:54:09 pauldv Exp $
inherit gnuconfig libtool eutils db
@@ -12,7 +12,7 @@ LICENSE="DB"
SLOT="3"
# This ebuild is to be the compatibility ebuild for when db4 is put
# in the tree.
-KEYWORDS="~x86 ~ppc ~sparc ~mips alpha arm ~hppa ia64 ppc64 s390"
+KEYWORDS="x86 ~ppc ~sparc ~mips alpha arm ~hppa ia64 ppc64 s390"
IUSE="doc java"
RDEPEND="virtual/libc"
diff --git a/sys-libs/db/db-3.2.9-r9.ebuild b/sys-libs/db/db-3.2.9-r9.ebuild
deleted file mode 100644
index 44f650d52354..000000000000
--- a/sys-libs/db/db-3.2.9-r9.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r9.ebuild,v 1.14 2004/07/02 08:44:40 eradicator Exp $
-
-IUSE="doc"
-
-inherit libtool eutils db
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Berkeley DB for transaction support in MySQL"
-SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
-HOMEPAGE="http://www.sleepycat.com/"
-
-SLOT="3"
-LICENSE="DB"
-# This ebuild is to be the compatibility ebuild for when db4 is put
-# in the tree.
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~mips ~hppa ia64"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- =sys-libs/db-1.85-r1
- sys-devel/libtool
- sys-devel/m4"
-# We need m4 too else build fails without config.guess
-
-# This doesn't build without exceptions
-export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
-
-src_unpack() {
- unpack ${A}
-
- chmod -R ug+w *
-
- cd ${WORKDIR}/${P}
- epatch ${FILESDIR}/patch.3.2.9.1
- epatch ${FILESDIR}/patch.3.2.9.2
-
- # Get db to link libdb* to correct dependencies ... for example if we use
- # NPTL or NGPT, db detects usable mutexes, and should link against
- # libpthread, but does not do so ...
- # <azarah@gentoo.org> (23 Feb 2003)
- epatch ${FILESDIR}/${P}-fix-dep-link.patch
-
- # We should get dump185 to link against system db1 ..
- # <azarah@gentoo.org> (23 Feb 2003)
- mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
- sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
- -e 's:DB185LIB=:DB185LIB= -ldb1:' \
- ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
-
- # Fix invalid .la files
- cd ${WORKDIR}/${P}/dist
- rm -f ltversion.sh
- # remove config.guess else we have problems with gcc-3.2
- rm -f config.guess
- sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
-}
-
-src_compile() {
- local conf=
-
- conf="--host=${CHOST} \
- --build=${CHOST} \
- --enable-cxx \
- --enable-compat185 \
- --enable-dump185 \
- --prefix=/usr"
- # --enable-rpc aparently does not work .. should verify this
- # at some stage ...
-
- # NOTE: we should not build both shared and static versions
- # of the libraries in the same build root!
-
- einfo "Configuring ${P} (static)..."
- mkdir -p ${S}/build-static
- cd ${S}/build-static
- ../dist/configure ${conf} \
- --enable-static || die
-
- einfo "Configuring ${P} (shared)..."
- mkdir -p ${S}/build-shared
- cd ${S}/build-shared
- ../dist/configure ${conf} \
- --enable-shared || die
-
- # Parallel make does not work
- MAKEOPTS="${MAKEOPTS} -j1"
- einfo "Building ${P} (static)..."
- cd ${S}/build-static
- emake || die "Static build failed"
- einfo "Building ${P} (shared)..."
- cd ${S}/build-shared
- emake || die "Shared build failed"
-}
-
-src_install () {
- cd ${S}/build-shared
- make libdb=libdb-3.2.a \
- libcxx=libcxx_3.2.a \
- prefix=${D}/usr \
- install || die
-
- cd ${S}/build-static
- cp libdb.a libdb-3.2.a
- cp libdb_cxx.a libdb_cxx-3.2.a
- dolib.a libdb-3.2.a libdb_cxx-3.2.a
-
- db_src_install_headerslot
-
- # this is now done in the db eclass, function db_fix_so and db_src_install_usrlibcleanup
- #cd ${D}/usr/lib
- #ln -s libdb-3.2.so libdb.so.3
-
- # For some reason, db.so's are *not* readable by group or others,
- # resulting in no one but root being able to use them!!!
- # This fixes it -- DR 15 Jun 2001
- cd ${D}/usr/lib
- chmod go+rx *.so
- # The .la's aren't readable either
- chmod go+r *.la
-
- cd ${S}
- dodoc README LICENSE
-
- db_src_install_doc
-
- db_src_install_usrbinslot
-
- db_src_install_usrlibcleanup
-}
-
-pkg_postinst () {
- db_fix_so
-}
-
-pkg_postrm () {
- db_fix_so
-}
-
diff --git a/sys-libs/db/db-3.3.11.ebuild b/sys-libs/db/db-3.3.11.ebuild
index c58dcab36f9d..e0d695e04ae9 100644
--- a/sys-libs/db/db-3.3.11.ebuild
+++ b/sys-libs/db/db-3.3.11.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.3.11.ebuild,v 1.22 2004/07/02 08:44:40 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.3.11.ebuild,v 1.23 2004/08/23 11:54:09 pauldv Exp $
S=${WORKDIR}/${P}/build_unix
DESCRIPTION="Berkeley DB for transaction support in MySQL"
SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
HOMEPAGE="http://www.sleepycat.com/"
+IUSE=""
SLOT="3"
LICENSE="DB"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ia64 s390"
diff --git a/sys-libs/db/files/digest-db-3.2.9-r9 b/sys-libs/db/files/digest-db-3.2.9-r9
deleted file mode 100644
index cc0f167ea09b..000000000000
--- a/sys-libs/db/files/digest-db-3.2.9-r9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238