summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-18 15:44:14 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-18 15:44:14 +0000
commit311ed86590a1705495d4cc36e2437da3067269da (patch)
tree5983af0056e67034ac3e81261998b68b9d3ad21c /x11-libs/gtk+
parentFix underlink. Bug #369113 (diff)
downloadgentoo-2-311ed86590a1705495d4cc36e2437da3067269da.tar.gz
gentoo-2-311ed86590a1705495d4cc36e2437da3067269da.tar.bz2
gentoo-2-311ed86590a1705495d4cc36e2437da3067269da.zip
Revert commit that is causing major gnome-panel problems, bug #372147. Remove broken version.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/gtk+-2.24.5-background-repaint.patch55
-rw-r--r--x11-libs/gtk+/gtk+-2.24.5-r1.ebuild (renamed from x11-libs/gtk+/gtk+-2.24.5.ebuild)5
3 files changed, 67 insertions, 2 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index e7f713265e85..49de57e0bf6e 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.515 2011/06/16 11:33:22 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.516 2011/06/18 15:44:14 pacho Exp $
+
+*gtk+-2.24.5-r1 (18 Jun 2011)
+
+ 18 Jun 2011; Pacho Ramos <pacho@gentoo.org> -gtk+-2.24.5.ebuild,
+ +gtk+-2.24.5-r1.ebuild, +files/gtk+-2.24.5-background-repaint.patch:
+ Revert commit that is causing major gnome-panel problems, bug #372147. Remove
+ broken version.
16 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gtk+-2.24.4.ebuild,
gtk+-2.24.5.ebuild:
diff --git a/x11-libs/gtk+/files/gtk+-2.24.5-background-repaint.patch b/x11-libs/gtk+/files/gtk+-2.24.5-background-repaint.patch
new file mode 100644
index 000000000000..40aa187e6ce7
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.24.5-background-repaint.patch
@@ -0,0 +1,55 @@
+From 254b9a4c540e3dff1dcd17db2ceea6a9fa5df973 Mon Sep 17 00:00:00 2001
+From: Benjamin Otte <otte@redhat.com>
+Date: Thu, 09 Jun 2011 04:29:45 +0000
+Subject: gdk: Make background changes queue a repaint
+
+For client-side windows, we need to queue a repaint when the background
+changes. For native windows, the windowing system does take care of it,
+but client-side windows are our own, so we gotta do it manually.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=652102
+---
+diff --git a/gdk/gdkwindow.c b/gdk/gdkwindow.c
+index f058570..10d83ab 100644
+--- a/gdk/gdkwindow.c
++++ b/gdk/gdkwindow.c
+@@ -8004,11 +8004,15 @@ gdk_window_set_background (GdkWindow *window,
+ }
+
+ if (!GDK_WINDOW_DESTROYED (window) &&
+- gdk_window_has_impl (private) &&
+ !private->input_only)
+ {
+- impl_iface = GDK_WINDOW_IMPL_GET_IFACE (private->impl);
+- impl_iface->set_background (window, &private->bg_color);
++ if (gdk_window_has_impl (private))
++ {
++ impl_iface = GDK_WINDOW_IMPL_GET_IFACE (private->impl);
++ impl_iface->set_background (window, &private->bg_color);
++ }
++ else
++ gdk_window_invalidate_rect_full (window, NULL, TRUE, CLEAR_BG_ALL);
+ }
+ }
+
+@@ -8077,11 +8081,15 @@ gdk_window_set_back_pixmap (GdkWindow *window,
+ private->bg_pixmap = GDK_NO_BG;
+
+ if (!GDK_WINDOW_DESTROYED (window) &&
+- gdk_window_has_impl (private) &&
+ !private->input_only)
+ {
+- impl_iface = GDK_WINDOW_IMPL_GET_IFACE (private->impl);
+- impl_iface->set_back_pixmap (window, private->bg_pixmap);
++ if (gdk_window_has_impl (private))
++ {
++ impl_iface = GDK_WINDOW_IMPL_GET_IFACE (private->impl);
++ impl_iface->set_back_pixmap (window, private->bg_pixmap);
++ }
++ else
++ gdk_window_invalidate_rect_full (window, NULL, TRUE, CLEAR_BG_ALL);
+ }
+ }
+
+--
+cgit v0.9
diff --git a/x11-libs/gtk+/gtk+-2.24.5.ebuild b/x11-libs/gtk+/gtk+-2.24.5-r1.ebuild
index f442f7404c90..f6b43e5a1eef 100644
--- a/x11-libs/gtk+/gtk+-2.24.5.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.5.ebuild,v 1.3 2011/06/16 11:33:22 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.5-r1.ebuild,v 1.1 2011/06/18 15:44:14 pacho Exp $
EAPI="3"
GNOME2_LA_PUNT="yes"
@@ -92,6 +92,9 @@ src_prepare() {
# Create symlinks to old icons until apps are ported, bug #339319
epatch "${FILESDIR}/${PN}-2.24.4-old-icons.patch"
+ # Revert this commit as it causes gnome-panel problems, bug #372147
+ EPATCH_OPTS="-R" epatch "${FILESDIR}/${P}-background-repaint.patch"
+
# Stop trying to build unmaintained docs, bug #349754
strip_builddir SUBDIRS tutorial docs/Makefile.am docs/Makefile.in
strip_builddir SUBDIRS faq docs/Makefile.am docs/Makefile.in