summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-08-17 11:51:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-08-17 11:51:24 +0000
commitbdcd2f17f1536e9a460617d01651cdd6f8ac67a4 (patch)
tree242dcf95d10f1dc7cca7d9d436005e08419fffa8 /x11-libs/libfm
parentrevbump, added py3 support on testing importability (diff)
downloadgentoo-2-bdcd2f17f1536e9a460617d01651cdd6f8ac67a4.tar.gz
gentoo-2-bdcd2f17f1536e9a460617d01651cdd6f8ac67a4.tar.bz2
gentoo-2-bdcd2f17f1536e9a460617d01651cdd6f8ac67a4.zip
Version bump
(Portage version: 2.1.13.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'x11-libs/libfm')
-rw-r--r--x11-libs/libfm/ChangeLog7
-rw-r--r--x11-libs/libfm/libfm-1.1.2.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index 196006ef1536..dc33fdf64951 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.85 2013/04/28 18:12:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.86 2013/08/17 11:51:24 hwoarang Exp $
+
+*libfm-1.1.2 (17 Aug 2013)
+
+ 17 Aug 2013; Markos Chandras <hwoarang@gentoo.org> +libfm-1.1.2.ebuild:
+ Version bump
*libfm-1.1.0-r1 (28 Apr 2013)
diff --git a/x11-libs/libfm/libfm-1.1.2.ebuild b/x11-libs/libfm/libfm-1.1.2.ebuild
new file mode 100644
index 000000000000..cb2c227fc6fc
--- /dev/null
+++ b/x11-libs/libfm/libfm-1.1.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-1.1.2.ebuild,v 1.1 2013/08/17 11:51:24 hwoarang Exp $
+
+EAPI=5
+
+inherit autotools fdo-mime vala
+
+MY_PV=${PV/_/}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+SLOT="0/4.3.1" #copy ABI_VERSION because it seems upstream change it randomly
+IUSE="debug doc examples vala"
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ >=lxde-base/menu-cache-0.3.2"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ || ( gnome-base/gvfs[udev,udisks] gnome-base/gvfs[udev,gdu] )"
+DEPEND="${COMMON_DEPEND}
+ vala? ( $(vala_depend) )
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ sed -ie '/SUBDIRS=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
+ fi
+ sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
+ configure.ac || die "sed failed"
+ #Remove -Werror for automake-1.12. Bug #421101
+ sed -i "s:-Werror::" configure.ac || die
+
+ # subslot sanity check
+ local sub_slot=${SLOT#*/}
+ local libfm_major_abi=$(sed -rne '/ABI_VERSION/s:.*=::p' src/Makefile.am | tr ':' '.')
+
+ if [[ ${sub_slot} != ${libfm_major_abi} ]]; then
+ eerror "Ebuild sub-slot (${sub_slot}) does not match ABI_VERSION(${libfm_major_abi})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${libfm_major_abi}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+ eautoreconf
+ use vala && export VALAC="$(type -p valac-$(vala_best_api_version))"
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc" \
+ --disable-dependency-tracking \
+ --disable-static \
+ --disable-udisks \
+ $(use_enable examples demo) \
+ $(use_enable debug) \
+ $(use_enable vala actions) \
+ $(use_enable doc gtk-doc)
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+ # Remove broken symlink #439570
+ # Sometimes a directory is created instead of a symlink. No idea why...
+ # It is wrong anyway. We expect a libfm-1.0 directory and then a libfm
+ # symlink to it.
+ if [[ -h ${D}/usr/include/${PN} || -d ${D}/usr/include/${PN} ]]; then
+ rm -r "${D}"/usr/include/${PN}
+ fi
+}
+
+pkg_preinst() {
+ # Resolve the symlink mess. Bug #439570
+ [[ -d "${ROOT}"/usr/include/${PN} ]] && \
+ rm -rf "${ROOT}"/usr/include/${PN}
+ if [[ -d "${D}"/usr/include/${PN}-1.0 ]]; then
+ cd "${D}"/usr/include
+ ln -s --force ${PN}-1.0 ${PN}
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}