summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-11-07 19:50:11 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-11-07 19:50:11 +0000
commit3d1fe1e3db58788663c87d45344b13d34c7ac72d (patch)
treec155e7b89058ee38f7903808acc9f17937a756e4 /x11-misc/lineakd
parentargh, removing the doubled entry in changelog (Manifest recommit) (diff)
downloadgentoo-2-3d1fe1e3db58788663c87d45344b13d34c7ac72d.tar.gz
gentoo-2-3d1fe1e3db58788663c87d45344b13d34c7ac72d.tar.bz2
gentoo-2-3d1fe1e3db58788663c87d45344b13d34c7ac72d.zip
Bugfix for amd64. See bug #63378.
Diffstat (limited to 'x11-misc/lineakd')
-rw-r--r--x11-misc/lineakd/ChangeLog6
-rw-r--r--x11-misc/lineakd/files/lkey-cast.patch12
-rw-r--r--x11-misc/lineakd/lineakd-0.7.2.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/x11-misc/lineakd/ChangeLog b/x11-misc/lineakd/ChangeLog
index 4a3368494ccd..ef35b951e69b 100644
--- a/x11-misc/lineakd/ChangeLog
+++ b/x11-misc/lineakd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/lineakd
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/ChangeLog,v 1.11 2004/06/24 22:27:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/ChangeLog,v 1.12 2004/11/07 19:50:11 pyrania Exp $
+
+ 07 Nov 2004; <pyrania@gentoo.org> +files/lkey-cast.patch,
+ lineakd-0.7.2.ebuild:
+ Bugfix for amd64. See bug #63378.
24 Apr 2004; Ian Leitch <port001@gentoo.org> lineakd-0.6.1.ebuild,
lineakd-0.7.2.ebuild, lineakd-0.7.ebuild:
diff --git a/x11-misc/lineakd/files/lkey-cast.patch b/x11-misc/lineakd/files/lkey-cast.patch
new file mode 100644
index 000000000000..0779451f3754
--- /dev/null
+++ b/x11-misc/lineakd/files/lkey-cast.patch
@@ -0,0 +1,12 @@
+diff -Naur lineakd-0.7.2_/lineakd/lkey.cpp lineakd-0.7.2/lineakd/lkey.cpp
+--- lineakd-0.7.2_/lineakd/lkey.cpp 2004-11-07 20:35:27.436720920 +0100
++++ lineakd-0.7.2/lineakd/lkey.cpp 2004-11-07 20:35:40.906673176 +0100
+@@ -39,7 +39,7 @@
+ name1|name2|name3 */
+ string key = keyname;
+ int index;
+- while (((unsigned int)(index = key.find('|'))) != string::npos) {
++ while (((index = key.find('|'))) != string::npos) {
+ toggle = true;
+ dtoggle = true;
+ string tmp = key.substr(0,index);
diff --git a/x11-misc/lineakd/lineakd-0.7.2.ebuild b/x11-misc/lineakd/lineakd-0.7.2.ebuild
index 53a998ab9096..e916d4120f97 100644
--- a/x11-misc/lineakd/lineakd-0.7.2.ebuild
+++ b/x11-misc/lineakd/lineakd-0.7.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.7.2.ebuild,v 1.4 2004/06/24 22:27:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.7.2.ebuild,v 1.5 2004/11/07 19:50:11 pyrania Exp $
+
+inherit eutils
IUSE="xosd"
@@ -15,6 +17,12 @@ KEYWORDS="x86"
DEPEND="virtual/x11
xosd? ( x11-libs/xosd )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/lkey-cast.patch || die "epatch failed."
+}
+
src_compile() {
econf `use_with xosd` --with-x || die
emake || die