summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 18:59:07 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 18:59:07 +0000
commited4f62f8aa28a66477438dc622ba47836261d114 (patch)
tree1e253b20ecf52310b843ef1d01badffb0e8dadd8 /x11-misc/wayv
parentVersion bump, drop old. (diff)
downloadgentoo-2-ed4f62f8aa28a66477438dc622ba47836261d114.tar.gz
gentoo-2-ed4f62f8aa28a66477438dc622ba47836261d114.tar.bz2
gentoo-2-ed4f62f8aa28a66477438dc622ba47836261d114.zip
Respect CC, CFLAGS (bug #241546).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'x11-misc/wayv')
-rw-r--r--x11-misc/wayv/ChangeLog9
-rw-r--r--x11-misc/wayv/wayv-0.3-r2.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/x11-misc/wayv/ChangeLog b/x11-misc/wayv/ChangeLog
index 9a459961d1b2..b2324dc14532 100644
--- a/x11-misc/wayv/ChangeLog
+++ b/x11-misc/wayv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/wayv
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wayv/ChangeLog,v 1.15 2008/06/17 12:31:06 nelchael Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wayv/ChangeLog,v 1.16 2010/02/08 18:59:07 jer Exp $
+
+*wayv-0.3-r2 (08 Feb 2010)
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> +wayv-0.3-r2.ebuild:
+ Respect CC, CFLAGS (bug #241546).
17 Jun 2008; Krzysiek Pawlik <nelchael@gentoo.org> wayv-0.3-r1.ebuild:
Add missing x11-proto/inputproto to DEPEND, bug #227751.
diff --git a/x11-misc/wayv/wayv-0.3-r2.ebuild b/x11-misc/wayv/wayv-0.3-r2.ebuild
new file mode 100644
index 000000000000..992e392e193c
--- /dev/null
+++ b/x11-misc/wayv/wayv-0.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wayv/wayv-0.3-r2.ebuild,v 1.1 2010/02/08 18:59:07 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Wayv is hand-writing/gesturing recognition software for X"
+HOMEPAGE="http://www.stressbunny.com/wayv"
+SRC_URI="http://www.stressbunny.com/gimme/wayv/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i src/Makefile* \
+ -e 's| = -Wall -O2| += |g' || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf || die "econf failed"
+}
+
+src_install() {
+ einstall || die
+ cd doc
+ einstall || die
+ dodoc HOWTO*
+}