summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2014-01-11 00:35:06 +0000
committerMatthew Marlowe <mattm@gentoo.org>2014-01-11 00:35:06 +0000
commit9053913c590191c2e3a1976947aab6665a52ce4d (patch)
treecbbbd5576f4a49791787043c17f5c0c3cbea5254 /x11-misc
parentstable on amd64 based on testing by pacho, bug 496770 (diff)
downloadgentoo-2-9053913c590191c2e3a1976947aab6665a52ce4d.tar.gz
gentoo-2-9053913c590191c2e3a1976947aab6665a52ce4d.tar.bz2
gentoo-2-9053913c590191c2e3a1976947aab6665a52ce4d.zip
Bump for version 1.7.3
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 786037A7)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rednotebook/ChangeLog7
-rw-r--r--x11-misc/rednotebook/rednotebook-1.7.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 30e29ae53f28..095b70f2605c 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.70 2014/01/07 22:28:10 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.71 2014/01/11 00:35:06 mattm Exp $
+
+*rednotebook-1.7.3 (11 Jan 2014)
+
+ 11 Jan 2014; Matthew Marlowe <mattm@gentoo.org> +rednotebook-1.7.3.ebuild:
+ Bump for version 1.7.3
*rednotebook-1.8.0 (07 Jan 2014)
*rednotebook-1.6.6-r1 (07 Jan 2014)
diff --git a/x11-misc/rednotebook/rednotebook-1.7.3.ebuild b/x11-misc/rednotebook/rednotebook-1.7.3.ebuild
new file mode 100644
index 000000000000..ff3603317844
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.7.3.ebuild,v 1.1 2014/01/11 00:35:06 mattm Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 eutils distutils-r1
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="libyaml spell"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/chardet
+ spell? ( dev-python/gtkspell-python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${PN}-1.6.5-disable-spell.patch"
+ distutils_src_prepare
+}