summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2005-09-13 15:49:31 +0000
committerBrandon Low <lostlogic@gentoo.org>2005-09-13 15:49:31 +0000
commitb2e0cefa74dc34606de0acf4f34afd5b25da4ea7 (patch)
tree996c83372e36b9088f5e51127e345a3525878d27 /x11-wm/openbox/openbox-3.3_rc2.ebuild
parentMark 0.92.8 stable on alpha (diff)
downloadgentoo-2-b2e0cefa74dc34606de0acf4f34afd5b25da4ea7.tar.gz
gentoo-2-b2e0cefa74dc34606de0acf4f34afd5b25da4ea7.tar.bz2
gentoo-2-b2e0cefa74dc34606de0acf4f34afd5b25da4ea7.zip
Bump
(Portage version: 1.589-cvs)
Diffstat (limited to 'x11-wm/openbox/openbox-3.3_rc2.ebuild')
-rw-r--r--x11-wm/openbox/openbox-3.3_rc2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/x11-wm/openbox/openbox-3.3_rc2.ebuild b/x11-wm/openbox/openbox-3.3_rc2.ebuild
new file mode 100644
index 000000000000..315710fa019b
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.3_rc2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.3_rc2.ebuild,v 1.1 2005/09/13 15:49:31 lostlogic Exp $
+
+inherit eutils
+
+DESCRIPTION="Openbox is a standards compliant, fast, light-weight, extensible window manager."
+HOMEPAGE="http://icculus.org/openbox/"
+SRC_URI="http://icculus.org/openbox/releases/${P/_/-}.tar.gz
+ mirror://gentoo/ob-themes-usability.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+IUSE="pango nls startup-notification"
+
+RDEPEND="virtual/xft
+ virtual/x11
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2
+ >=dev-libs/libxml2-2.0"
+DEPEND="${RDEPEND}
+ pango? ( x11-libs/pango )
+ startup-notification? ( x11-libs/startup-notification )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P/_/-}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ if use pango ; then
+ myconf="--enable-pango"
+ else
+ myconf=""
+ fi
+ econf `use_enable nls` ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ fperms a+x /etc/X11/Sessions/openbox
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/${PN}.desktop
+
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS CHANGELOG COMPLIANCE COPYING README
+
+ # Extra styles from http://home.clara.co.uk/dpb/openbox.htm
+ # These are included due to the poor usability of the default themes
+ # for users with limited vision. These are based on Jimmac's
+ # Gorilla and Industrial themes for Metacity.
+
+ insinto /usr/share/themes
+ #cp -pPR ${WORKDIR}/ob-themes-usability/* ${D}/usr/share/themes
+ doins -r ${WORKDIR}/ob-themes-usability/*
+}