summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:41:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:41:44 +0000
commit4c2abc3fe9d9d4c1ddc099022ba2323036aaea7e (patch)
tree45ef47a91fb65bfcdf2104a69a1653491db1836c /x11-wm
parentNew version for GNOME 2.28. (diff)
downloadgentoo-2-4c2abc3fe9d9d4c1ddc099022ba2323036aaea7e.tar.gz
gentoo-2-4c2abc3fe9d9d4c1ddc099022ba2323036aaea7e.tar.bz2
gentoo-2-4c2abc3fe9d9d4c1ddc099022ba2323036aaea7e.zip
New version for GNOME 2.28. Clean up old revisions.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/ChangeLog9
-rw-r--r--x11-wm/metacity/files/metacity-2.28.0-restartstylehint-when-replace.patch139
-rw-r--r--x11-wm/metacity/metacity-2.28.0.ebuild (renamed from x11-wm/metacity/metacity-2.26.0.ebuild)16
3 files changed, 162 insertions, 2 deletions
diff --git a/x11-wm/metacity/ChangeLog b/x11-wm/metacity/ChangeLog
index 4d6f2838985d..4b95dc5c66d5 100644
--- a/x11-wm/metacity/ChangeLog
+++ b/x11-wm/metacity/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/metacity
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.237 2009/10/24 16:30:20 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.238 2009/10/29 22:41:43 eva Exp $
+
+*metacity-2.28.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -metacity-2.26.0.ebuild, +metacity-2.28.0.ebuild,
+ +files/metacity-2.28.0-restartstylehint-when-replace.patch:
+ New version for GNOME 2.28. Clean up old revisions.
24 Oct 2009; nixnut <nixnut@gentoo.org> metacity-2.26.0-r1.ebuild:
ppc stable #281427
diff --git a/x11-wm/metacity/files/metacity-2.28.0-restartstylehint-when-replace.patch b/x11-wm/metacity/files/metacity-2.28.0-restartstylehint-when-replace.patch
new file mode 100644
index 000000000000..54dd79e02198
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.28.0-restartstylehint-when-replace.patch
@@ -0,0 +1,139 @@
+From a3de65d5d1861f755ced7cad291fbbd4f1b8ef51 Mon Sep 17 00:00:00 2001
+From: Owen W. Taylor <otaylor@fishsoup.net>
+Date: Sat, 22 Aug 2009 15:00:57 -0400
+Subject: [PATCH] Should set RestartStyleHint to RestartIfRunning when replaced
+
+This reverts most of commit abbd057eb967e6ab462ffe305f41b2b04d417b25;
+
+ - It's fine to call meta_session_shutdown() after the display
+ is closed, since it's talking over the ICE connection
+ - We should not call warn_about_lame_clients_and_finish_interact()
+ unless we are interacting with the window manager in a session
+ save.
+
+However, the part of abbd057 that fixed accessing freed memory was
+fixing a real problem; this patches does the same thing in a simpler
+way by fixing an obvious type in meta_display_close() where it was
+NULL'ing out the local variable 'display' rather than the global
+variable 'the_display' and adding keeping the check in meta_finalize()
+that was added in abbd057.
+
+The order of calling meta_session_shutdown() and
+calling meta_display_close() is reverted back to the old order to
+make it clear that it's OK if the display way already closed previously.
+
+http://bugzilla.gnome.org/show_bug.cgi?id=588119
+---
+ src/core/display-private.h | 2 +-
+ src/core/display.c | 16 ++++------------
+ src/core/main.c | 5 ++---
+ src/core/session.c | 8 --------
+ 4 files changed, 7 insertions(+), 24 deletions(-)
+
+diff --git a/src/core/display-private.h b/src/core/display-private.h
+index 19287f3..9c8ebc6 100644
+--- a/src/core/display-private.h
++++ b/src/core/display-private.h
+@@ -329,7 +329,7 @@ MetaScreen* meta_display_screen_for_xwindow (MetaDisplay *display,
+ void meta_display_grab (MetaDisplay *display);
+ void meta_display_ungrab (MetaDisplay *display);
+
+-void meta_display_unmanage_screen (MetaDisplay **display,
++void meta_display_unmanage_screen (MetaDisplay *display,
+ MetaScreen *screen,
+ guint32 timestamp);
+
+diff --git a/src/core/display.c b/src/core/display.c
+index 55c374a..8e35a35 100644
+--- a/src/core/display.c
++++ b/src/core/display.c
+@@ -926,7 +926,7 @@ meta_display_close (MetaDisplay *display,
+ meta_compositor_destroy (display->compositor);
+
+ g_free (display);
+- display = NULL;
++ the_display = NULL;
+
+ meta_quit (META_EXIT_SUCCESS);
+ }
+@@ -4762,13 +4762,10 @@ process_selection_clear (MetaDisplay *display,
+ meta_verbose ("Got selection clear for screen %d on display %s\n",
+ screen->number, display->name);
+
+- meta_display_unmanage_screen (&display,
++ meta_display_unmanage_screen (display,
+ screen,
+ event->xselectionclear.time);
+
+- if (!display)
+- the_display = NULL;
+-
+ /* display and screen may both be invalid memory... */
+
+ return;
+@@ -4790,12 +4787,10 @@ process_selection_clear (MetaDisplay *display,
+ }
+
+ void
+-meta_display_unmanage_screen (MetaDisplay **displayp,
++meta_display_unmanage_screen (MetaDisplay *display,
+ MetaScreen *screen,
+ guint32 timestamp)
+ {
+- MetaDisplay *display = *displayp;
+-
+ meta_verbose ("Unmanaging screen %d on display %s\n",
+ screen->number, display->name);
+
+@@ -4805,10 +4800,7 @@ meta_display_unmanage_screen (MetaDisplay **displayp,
+ display->screens = g_slist_remove (display->screens, screen);
+
+ if (display->screens == NULL)
+- {
+- meta_display_close (display, timestamp);
+- *displayp = NULL;
+- }
++ meta_display_close (display, timestamp);
+ }
+
+ void
+diff --git a/src/core/main.c b/src/core/main.c
+index a36a396..44d317e 100644
+--- a/src/core/main.c
++++ b/src/core/main.c
+@@ -361,12 +361,11 @@ static void
+ meta_finalize (void)
+ {
+ MetaDisplay *display = meta_get_display();
+-
+- meta_session_shutdown ();
+-
+ if (display)
+ meta_display_close (display,
+ CurrentTime); /* I doubt correct timestamps matter here */
++
++ meta_session_shutdown ();
+ }
+
+ static void
+diff --git a/src/core/session.c b/src/core/session.c
+index 7e3b389..0d69350 100644
+--- a/src/core/session.c
++++ b/src/core/session.c
+@@ -376,14 +376,6 @@ meta_session_shutdown (void)
+ SmProp *props[1];
+ char hint = SmRestartIfRunning;
+
+- if (!meta_get_display ())
+- {
+- meta_verbose ("Cannot close session because there is no display");
+- return;
+- }
+-
+- warn_about_lame_clients_and_finish_interact (FALSE);
+-
+ if (session_connection == NULL)
+ return;
+
+--
+1.6.4 \ No newline at end of file
diff --git a/x11-wm/metacity/metacity-2.26.0.ebuild b/x11-wm/metacity/metacity-2.28.0.ebuild
index fce90794c229..fa180c41e28d 100644
--- a/x11-wm/metacity/metacity-2.26.0.ebuild
+++ b/x11-wm/metacity/metacity-2.28.0.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.26.0.ebuild,v 1.1 2009/05/04 22:46:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.28.0.ebuild,v 1.1 2009/10/29 22:41:43 eva Exp $
EAPI="2"
+# debug only changes CFLAGS
+GCONF_DEBUG="no"
inherit eutils gnome2
@@ -14,6 +16,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="test xinerama"
+# XXX: libgtop is automagic, hard-enabled instead
RDEPEND=">=x11-libs/gtk+-2.10
>=x11-libs/pango-1.2[X]
>=gnome-base/gconf-2
@@ -30,6 +33,8 @@ RDEPEND=">=x11-libs/gtk+-2.10
x11-libs/libXrandr
x11-libs/libSM
x11-libs/libICE
+ media-libs/libcanberra[gtk]
+ gnome-base/libgtop
gnome-extra/zenity
!x11-misc/expocity"
DEPEND="${RDEPEND}
@@ -59,6 +64,15 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+
# Remove stupid CFLAGS, bug #259179
sed "s:-Werror::g" -i configure.in configure || die "sed failed"
+ # Should set RestartStyleHint to RestartIfRunning when replaced,
+ # this fix a strange issue with gnome-session (100% of the CPU,
+ # and try to restart metacity infinitively when compiz is started)
+ # patch import from upstream bug #588119.
+ epatch "${FILESDIR}/${P}-restartstylehint-when-replace.patch"
}