summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/squid/ChangeLog5
-rw-r--r--net-www/squid/squid-2.5.6.ebuild21
2 files changed, 7 insertions, 19 deletions
diff --git a/net-www/squid/ChangeLog b/net-www/squid/ChangeLog
index 606f2aaa8778..44f139f53b89 100644
--- a/net-www/squid/ChangeLog
+++ b/net-www/squid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/squid
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/squid/ChangeLog,v 1.57 2004/07/15 18:32:33 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/squid/ChangeLog,v 1.58 2004/07/15 23:15:45 cyfred Exp $
+
+ 16 Jul 2004; Andrew Bevitt <cyfred@gentoo.org>; squid-2.5.6.ebuild:
+ SASL V 1/2 is now supported natively
15 Jul 2004; Tom Gall <tgall@gentoo.org> squid-2.5.5-r2.ebuild:
stable on ppc64, bug #55406
diff --git a/net-www/squid/squid-2.5.6.ebuild b/net-www/squid/squid-2.5.6.ebuild
index d0bb4efd835a..b90d203cc8d9 100644
--- a/net-www/squid/squid-2.5.6.ebuild
+++ b/net-www/squid/squid-2.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/squid/squid-2.5.6.ebuild,v 1.1 2004/07/15 05:04:40 cyfred Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/squid/squid-2.5.6.ebuild,v 1.2 2004/07/15 23:15:45 cyfred Exp $
inherit eutils
@@ -59,23 +59,8 @@ src_compile() {
local basic_modules="getpwnam,YP,NCSA,SMB,MSNT,multi-domain-NTLM,winbind"
use ldap && basic_modules="LDAP,${basic_modules}"
use pam && basic_modules="PAM,${basic_modules}"
- if use sasl; then
- basic_modules="SASL,${basic_modules}"
- #support for cyrus-sasl-1.x and 2.x; thanks Raker!
- if [ -f /usr/include/sasl/sasl.h ]; then
- cd ${S}/helpers/basic_auth/SASL/
- cp sasl_auth.c sasl_auth.c.orig
- sed \
- -e "s:sasl.h:sasl/sasl.h:" \
- -e "s:NULL, NULL, NULL:NULL, NULL, NULL, NULL, NULL:" \
- -e "s:strlen(password), \&errstr:strlen(password):" \
- < sasl_auth.c.orig > sasl_auth.c
- cp Makefile.in Makefile.in.orig
- sed -e "s:-lsasl:-lsasl2:" \
- < Makefile.in.orig > Makefile.in
- cd ${S}
- fi
- fi
+ use sasl && basic_modules="SASL,${basic_modules}"
+ # SASL 1 / 2 Supported Natively
local ext_helpers="ip_user,unix_group,wbinfo_group,winbind_group"
use ldap && ext_helpers="ldap_group,${ext_helpers}"