summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask-script/ChangeLog9
-rw-r--r--dev-python/flask-script/flask-script-0.3.1.ebuild50
-rw-r--r--dev-python/flask-script/flask-script-0.3.3.ebuild50
-rw-r--r--dev-python/flask-script/flask-script-0.5.1.ebuild50
-rw-r--r--dev-python/flask-script/flask-script-0.5.3.ebuild45
5 files changed, 7 insertions, 197 deletions
diff --git a/dev-python/flask-script/ChangeLog b/dev-python/flask-script/ChangeLog
index a8e6fed0ba45..ff7776ae0e9e 100644
--- a/dev-python/flask-script/ChangeLog
+++ b/dev-python/flask-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-script
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.12 2013/12/10 03:20:51 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.13 2014/01/21 04:07:58 patrick Exp $
+
+ 21 Jan 2014; Patrick Lauer <patrick@gentoo.org> -flask-script-0.3.1.ebuild,
+ -flask-script-0.3.3.ebuild, -flask-script-0.5.1.ebuild,
+ -flask-script-0.5.3.ebuild:
+ Remove old
*flask-script-0.6.6 (10 Dec 2013)
diff --git a/dev-python/flask-script/flask-script-0.3.1.ebuild b/dev-python/flask-script/flask-script-0.3.1.ebuild
deleted file mode 100644
index ddafca404c1c..000000000000
--- a/dev-python/flask-script/flask-script-0.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.3.1.ebuild,v 1.5 2012/10/29 16:33:04 mgorny Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Flask-Script"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask support for writing external scripts."
-HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/flask
- virtual/python-argparse"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="flaskext/script.py"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/flask-script/flask-script-0.3.3.ebuild b/dev-python/flask-script/flask-script-0.3.3.ebuild
deleted file mode 100644
index 64dbb69abd71..000000000000
--- a/dev-python/flask-script/flask-script-0.3.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.3.3.ebuild,v 1.2 2012/10/29 16:33:04 mgorny Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Flask-Script"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask support for writing external scripts."
-HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/flask
- virtual/python-argparse"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="flaskext/script.py"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/flask-script/flask-script-0.5.1.ebuild b/dev-python/flask-script/flask-script-0.5.1.ebuild
deleted file mode 100644
index 3dda98d45f15..000000000000
--- a/dev-python/flask-script/flask-script-0.5.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.5.1.ebuild,v 1.2 2012/11/17 21:46:16 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Flask-Script"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask support for writing external scripts."
-HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/flask
- virtual/python-argparse"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="flask_script.py"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/flask-script/flask-script-0.5.3.ebuild b/dev-python/flask-script/flask-script-0.5.3.ebuild
deleted file mode 100644
index dea646713c10..000000000000
--- a/dev-python/flask-script/flask-script-0.5.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.5.3.ebuild,v 1.3 2013/08/19 13:41:08 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="Flask-Script"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask support for writing external scripts."
-HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask
- virtual/python-argparse[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation by" ${PYTHON}
- PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
- fi
-}
-
-python_test() {
- nosetests -v || die
-}
-
-python_install_all() {
- use doc && dohtml -r docs/_build/html/
- dodoc README.rst
-}