summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/logjam/ChangeLog7
-rw-r--r--net-misc/logjam/files/digest-logjam-3.0.4-r11
-rw-r--r--net-misc/logjam/logjam-3.0.4-r1.ebuild44
3 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/logjam/ChangeLog b/net-misc/logjam/ChangeLog
new file mode 100644
index 000000000000..c3f8efbf18c5
--- /dev/null
+++ b/net-misc/logjam/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-misc/logjam
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/ChangeLog,v 1.1 2002/05/31 04:53:11 edolnx Exp $
+
+*logjam-3.0.4-r1 (30 MAY 2002)
+
+ 30 MAY 2002; edolnx <edolnx@gentoo.org> Initial ebuild created.
diff --git a/net-misc/logjam/files/digest-logjam-3.0.4-r1 b/net-misc/logjam/files/digest-logjam-3.0.4-r1
new file mode 100644
index 000000000000..000623c83017
--- /dev/null
+++ b/net-misc/logjam/files/digest-logjam-3.0.4-r1
@@ -0,0 +1 @@
+MD5 0259029e23ca6a280c6cb6ff83603ac9 logjam-3.0.4.tar.gz 142048
diff --git a/net-misc/logjam/logjam-3.0.4-r1.ebuild b/net-misc/logjam/logjam-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..5f4d57b820c4
--- /dev/null
+++ b/net-misc/logjam/logjam-3.0.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-3.0.4-r1.ebuild,v 1.1 2002/05/31 04:53:11 edolnx Exp $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+DESCRIPTION="A GTK+ LiveJournal Client"
+HOMEPAGE="http://logjam.danga.com"
+LICENSE="GPL-2"
+DEPEND=">=net-ftp/curl-7.9.3
+ >=x11-libs/gtk+-1.2.10-r7
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.6 )
+ xmms? ( >=media-sound/xmms-1.2.7-r4 )"
+SRC_URI="http://logjam.danga.com/download/${P}.tar.gz"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ local myconf
+
+ use gnome && myconf="--with-gnome "
+ use xmms && myconf="$myconf --with-xmms "
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ ${myconf} \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}