summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cook/cook-2.24.ebuild20
-rw-r--r--xfce-base/xffm/xffm-4.2.1.ebuild6
-rw-r--r--xfce-base/xffm/xffm-4.2.2.ebuild7
3 files changed, 17 insertions, 16 deletions
diff --git a/dev-util/cook/cook-2.24.ebuild b/dev-util/cook/cook-2.24.ebuild
index 9eee434131d9..513096ba7370 100644
--- a/dev-util/cook/cook-2.24.ebuild
+++ b/dev-util/cook/cook-2.24.ebuild
@@ -1,32 +1,34 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.24.ebuild,v 1.5 2005/11/05 19:40:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.24.ebuild,v 1.6 2005/11/10 05:58:13 vapier Exp $
+
+inherit eutils
DESCRIPTION="tool for constructing files; a drop in replacement for make"
-SRC_URI="http://www.canb.auug.org.au/~millerp/cook/${P}.tar.gz"
HOMEPAGE="http://www.canb.auug.org.au/~millerp/cook/cook.html"
+SRC_URI="http://www.canb.auug.org.au/~millerp/cook/${P}.tar.gz"
-inherit eutils
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~ppc ~ppc-macos ~sparc ~x86"
IUSE=""
DEPEND="sys-devel/bison"
src_unpack() {
- unpack "${A}"
- epatch "${FILESDIR}/${P}"-gcc4.patch
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
}
src_compile() {
econf || die "./configure failed"
- make || die # doesn't seem to like emake
+ # doesn't seem to like parallel
+ emake -j1 || die
}
src_install() {
# we'll hijack the RPM_BUILD_ROOT variable which is intended for a
# similiar purpose anyway
- make RPM_BUILD_ROOT=${D} install || die
+ make RPM_BUILD_ROOT="${D}" install || die
}
diff --git a/xfce-base/xffm/xffm-4.2.1.ebuild b/xfce-base/xffm/xffm-4.2.1.ebuild
index 7f8ab3945aab..123f914edfc9 100644
--- a/xfce-base/xffm/xffm-4.2.1.ebuild
+++ b/xfce-base/xffm/xffm-4.2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xffm/xffm-4.2.1.ebuild,v 1.3 2005/07/07 02:56:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xffm/xffm-4.2.1.ebuild,v 1.4 2005/11/10 05:59:50 vapier Exp $
+
+inherit xfce4 eutils
DESCRIPTION="Xfce 4 file manager"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -10,8 +12,6 @@ RDEPEND="~xfce-base/xfce-mcs-manager-${PV}
samba? ( net-fs/samba )"
XFCE_CONFIG="--enable-all"
-inherit xfce4 eutils
-
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/xfce-base/xffm/xffm-4.2.2.ebuild b/xfce-base/xffm/xffm-4.2.2.ebuild
index 2c67039ee1bb..27cb2c1df65f 100644
--- a/xfce-base/xffm/xffm-4.2.2.ebuild
+++ b/xfce-base/xffm/xffm-4.2.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xffm/xffm-4.2.2.ebuild,v 1.9 2005/07/12 12:45:54 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xffm/xffm-4.2.2.ebuild,v 1.10 2005/11/10 05:59:50 vapier Exp $
+
+inherit xfce4 eutils
DESCRIPTION="Xfce 4 file manager"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
@@ -9,9 +11,6 @@ IUSE="samba"
RDEPEND="~xfce-base/xfce-mcs-manager-${PV}
samba? ( net-fs/samba )"
XFCE_CONFIG="--enable-all"
-
-inherit xfce4 eutils
-
#src_unpack() {
# unpack ${A}
# cd ${S}