summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/at-spi2-core')
-rw-r--r--app-accessibility/at-spi2-core/ChangeLog10
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild45
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.2.1-org.a11y.Bus.IsEnabled-property.patch27
3 files changed, 81 insertions, 1 deletions
diff --git a/app-accessibility/at-spi2-core/ChangeLog b/app-accessibility/at-spi2-core/ChangeLog
index 70eae166ee0d..613dd235aa00 100644
--- a/app-accessibility/at-spi2-core/ChangeLog
+++ b/app-accessibility/at-spi2-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-accessibility/at-spi2-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.1 2011/08/14 14:16:52 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.2 2011/11/05 04:50:26 tetromino Exp $
+
+*at-spi2-core-2.2.1-r1 (05 Nov 2011)
+
+ 05 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +at-spi2-core-2.2.1-r1.ebuild,
+ +files/at-spi2-core-2.2.1-org.a11y.Bus.IsEnabled-property.patch:
+ Bump to 2.2.1 from the gnome overlay. Notable changes: many stability
+ improvements.
*at-spi2-core-2.0.2-r1 (14 Aug 2011)
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..e89e705bc5af
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.2.1-r1.ebuild,v 1.1 2011/11/05 04:50:26 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ G2CONF="${G2CONF} --disable-xevie"
+}
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+ # Upstream patch to fix org.a11y.Bus.IsEnabled, will be in next release
+ epatch "${FILESDIR}/${P}-org.a11y.Bus.IsEnabled-property.patch"
+
+ gnome2_src_prepare
+}
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.2.1-org.a11y.Bus.IsEnabled-property.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.2.1-org.a11y.Bus.IsEnabled-property.patch
new file mode 100644
index 000000000000..50d188868350
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/at-spi2-core-2.2.1-org.a11y.Bus.IsEnabled-property.patch
@@ -0,0 +1,27 @@
+From 166209e13b1eae0b6b239c868ae532702032831f Mon Sep 17 00:00:00 2001
+From: Mike Gorse <mgorse@novell.com>
+Date: Fri, 21 Oct 2011 14:25:30 -0500
+Subject: [PATCH] Fix return type of org.a11y.Bus.IsEnabled property
+
+org.a11y.Bus.Enabled was returning a variant struct with a bool, where
+it should directly be returning a bool in the variant.
+---
+ bus/at-spi-bus-launcher.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/bus/at-spi-bus-launcher.c b/bus/at-spi-bus-launcher.c
+index 3133a39..290ccbd 100644
+--- a/bus/at-spi-bus-launcher.c
++++ b/bus/at-spi-bus-launcher.c
+@@ -247,7 +247,7 @@ handle_get_property (GDBusConnection *connection,
+
+ if (g_strcmp0 (property_name, "IsEnabled") == 0)
+ {
+- return g_variant_new ("(b)", app->a11y_enabled);
++ return g_variant_new ("b", app->a11y_enabled);
+ }
+ else
+ return NULL;
+--
+1.7.7.2
+