summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/amanda')
-rw-r--r--app-backup/amanda/ChangeLog16
-rw-r--r--app-backup/amanda/amanda-2.5.1_p3-r1.ebuild394
-rw-r--r--app-backup/amanda/files/amanda-2.5.1_p3-displayunit.patch17
-rw-r--r--app-backup/amanda/files/amanda-amandahosts-client-2.5.1_p3-r18
-rw-r--r--app-backup/amanda/files/amanda-amandahosts-server-2.5.1_p3-r18
-rw-r--r--app-backup/amanda/files/amanda-inetd.amanda.sample-2.5.1_p3-r13
-rw-r--r--app-backup/amanda/files/amanda-xinetd-2.5.1_p3-r149
-rw-r--r--app-backup/amanda/files/digest-amanda-2.5.1_p3-r13
-rw-r--r--app-backup/amanda/files/example_disklist-2.5.1_p3-r14
9 files changed, 501 insertions, 1 deletions
diff --git a/app-backup/amanda/ChangeLog b/app-backup/amanda/ChangeLog
index 181059a81395..aa314a2ecce5 100644
--- a/app-backup/amanda/ChangeLog
+++ b/app-backup/amanda/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-backup/amanda
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/ChangeLog,v 1.19 2007/03/05 15:23:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/ChangeLog,v 1.20 2007/03/07 18:46:54 robbat2 Exp $
+
+*amanda-2.5.1_p3-r1 (07 Mar 2007)
+
+ 07 Mar 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/amanda-amandahosts-client-2.5.1_p3-r1,
+ +files/amanda-amandahosts-server-2.5.1_p3-r1,
+ +files/amanda-inetd.amanda.sample-2.5.1_p3-r1,
+ +files/amanda-xinetd-2.5.1_p3-r1, +files/example_disklist-2.5.1_p3-r1,
+ +files/amanda-2.5.1_p3-displayunit.patch, +amanda-2.5.1_p3-r1.ebuild:
+ Add proper p3 changes from upstream developer Stefan G. Weichinger
+ (monitor@oops.co.at). This moves the builds to using the new Amanda auth
+ system. If you use localhost in your disklist you should replace it with the
+ actual hostname! Please also see the syntax changes to amandahosts. We also
+ support USE=minimal now to build clients.
*amanda-2.5.1_p3 (05 Mar 2007)
diff --git a/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild b/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild
new file mode 100644
index 000000000000..2a151abcd507
--- /dev/null
+++ b/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild
@@ -0,0 +1,394 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild,v 1.1 2007/03/07 18:46:54 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
+HOMEPAGE="http://www.amanda.org/"
+SRC_URI="mirror://sourceforge/amanda/${P/_/}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+RDEPEND="sys-libs/readline
+ virtual/inetd
+ sys-apps/gawk
+ app-arch/tar
+ dev-lang/perl
+ app-arch/dump
+ samba? ( net-fs/samba )
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !sparc? ( xfs? ( sys-fs/xfsdump ) )
+ >=sys-apps/portage-2.0.51-r3
+ !minimal? ( virtual/mailx
+ app-arch/mt-st
+ sys-block/mtx
+ sci-visualization/gnuplot
+ app-crypt/aespipe
+ app-crypt/gnupg )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake"
+
+IUSE="berkdb debug gdbm minimal samba xfs"
+
+S="${WORKDIR}/${P/_/}"
+MYFILESDIR="${WORKDIR}/files"
+MYTMPDIR="${WORKDIR}/tmp"
+MYINSTTMPDIR="/usr/share/amanda"
+ENVDIR="/etc/env.d"
+ENVDFILE="97amanda"
+TMPENVFILE="${MYTMPDIR}/${ENVDFILE}"
+TMPINSTENVFILE="${MYINSTTMPDIR}/tmpenv-${ENVDFILE}"
+
+amanda_variable_setup() {
+
+ # Setting vars
+ local currentamanda
+
+ # Grab the current settings
+ currentamanda="$(set | egrep "^AMANDA_" | xargs)"
+ use debug && einfo "Current settings: ${currentamanda}"
+ #for i in ${currentamanda}; do
+ # eval `eval echo ${i}`
+ # echo "Setting: ${i}"
+ #done;
+
+ # First we set the defaults
+ [ -z "${AMANDA_GROUP_GID}" ] && AMANDA_GROUP_GID=87
+ [ -z "${AMANDA_GROUP_NAME}" ] && AMANDA_GROUP_NAME=amanda
+ [ -z "${AMANDA_USER_NAME}" ] && AMANDA_USER_NAME=amanda
+ [ -z "${AMANDA_USER_UID}" ] && AMANDA_USER_UID=87
+ [ -z "${AMANDA_USER_SH}" ] && AMANDA_USER_SH=-1
+ [ -z "${AMANDA_USER_HOMEDIR}" ] && AMANDA_USER_HOMEDIR=/var/spool/amanda
+ [ -z "${AMANDA_USER_GROUPS}" ] && AMANDA_USER_GROUPS="${AMANDA_GROUP_NAME}"
+
+ # This installs Amanda, with the server. However, it could be a client,
+ # just specify an alternate server name in AMANDA_SERVER.
+ [ -z "${AMANDA_SERVER}" ] && AMANDA_SERVER="${HOSTNAME}"
+ [ -z "${AMANDA_SERVER_TAPE}" ] && AMANDA_SERVER_TAPE="${AMANDA_SERVER}"
+ [ -z "${AMANDA_SERVER_INDEX}" ] && AMANDA_SERVER_INDEX="${AMANDA_SERVER}"
+ [ -z "${AMANDA_TAR_LISTDIR}" ] && AMANDA_TAR_LISTDIR=${AMANDA_USER_HOMEDIR}/tar-lists
+ [ -z "${AMANDA_CONFIG_NAME}" ] && AMANDA_CONFIG_NAME=DailySet1
+ [ -z "${AMANDA_TMPDIR}" ] && AMANDA_TMPDIR=/var/tmp/amanda
+ [ -z "${AMANDA_DBGDIR}" ] && AMANDA_DBGDIR="$AMANDA_TMPDIR"
+ # These are left empty by default
+ [ -z "${AMANDA_PORTS_UDP}" ] && AMANDA_PORTS_UDP=
+ [ -z "${AMANDA_PORTS_TCP}" ] && AMANDA_PORTS_TCP=
+ [ -z "${AMANDA_PORTS_BOTH}" ] && AMANDA_PORTS_BOTH=
+ [ -z "${AMANDA_PORTS}" ] && AMANDA_PORTS=
+
+ # This one is a little more complicated
+ # The priority list is this:
+ # 1. 'Berkely DB style' (only if USE="berkdb")
+ # 2. 'GDBM style' (only if USE="gdbm")
+ # 3. 'Text style'
+ [ -z "${AMANDA_DBMODE}" ] && use berkdb && AMANDA_DBMODE=db
+ [ -z "${AMANDA_DBMODE}" ] && use gdbm && AMANDA_DBMODE=gdbm
+ [ -z "${AMANDA_DBMODE}" ] && AMANDA_DBMODE=text
+
+ # Now pull in the old stuff
+ if [ -f "${ENVDIR}/${ENVDFILE}" ]; then
+ # We don't just source it as we don't want everything in there.
+ eval $(egrep "^AMANDA_" ${ENVDIR}/${ENVDFILE})
+ fi
+
+ # Re-apply the new settings if any
+ [ -n "${currentamanda}" ] && eval `echo "${currentamanda}"`
+
+}
+
+pkg_setup() {
+ # Now add users if needed
+ amanda_variable_setup
+ enewgroup "${AMANDA_GROUP_NAME}" "${AMANDA_GROUP_GID}"
+ enewuser "${AMANDA_USER_NAME}" "${AMANDA_USER_UID}" "${AMANDA_USER_SH}" "${AMANDA_USER_HOMEDIR}" "${AMANDA_USER_GROUPS}"
+}
+
+src_unpack() {
+ unpack "${A}"
+ # Fix glitch with recognizing tar-1.14.90
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/patch-tar-1.14.90 || die "Failed to add tar support patch"
+ # Fix tar 1.16 changes
+ # ( http://cvs.savannah.gnu.org/viewcvs/tar/NEWS?rev=1.125&root=tar )
+ # commented by sgw, but not yet removed:
+ # the patch is in the upstream source already
+ #EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/${P}-tar-1.16.patch || die "Failed to add tar 1.16 patch"
+
+ # Fix broken display of chunks with parameter displayunit.
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-displayunit.patch || die "Failed to add amstatus-patch"
+
+ # now the real fun
+ amanda_variable_setup
+ # places for us to work in
+ mkdir -p "${MYFILESDIR}" "${MYTMPDIR}"
+ # Now we store the settings we just created
+ set | egrep "^AMANDA_" > "${TMPENVFILE}"
+}
+
+src_compile() {
+ # fix bug #36316
+ addpredict /var/cache/samba/gencache.tdb
+
+ [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
+ source "${TMPENVFILE}"
+ local myconf
+ cd ${S}
+
+ einfo "Using '${AMANDA_DBMODE}' style database"
+ myconf="${myconf} --with-db=${AMANDA_DBMODE}"
+ einfo "Using ${AMANDA_SERVER_TAPE} for tape server."
+ myconf="${myconf} --with-tape-server=${AMANDA_SERVER_TAPE}"
+ einfo "Using ${AMANDA_SERVER_INDEX} for index server."
+ myconf="${myconf} --with-index-server=${AMANDA_SERVER_INDEX}"
+ einfo "Using ${AMANDA_USER_NAME} for amanda user."
+ myconf="${myconf} --with-user=${AMANDA_USER_NAME}"
+ einfo "Using ${AMANDA_GROUP_NAME} for amanda group."
+ myconf="${myconf} --with-group=${AMANDA_GROUP_NAME}"
+ einfo "Using ${AMANDA_TAR_LISTDIR} as tar listdir."
+ myconf="${myconf} --with-gnutar-listdir=${AMANDA_TAR_LISTDIR}"
+ einfo "Using ${AMANDA_CONFIG_NAME} as default config name."
+ myconf="${myconf} --with-config=${AMANDA_CONFIG_NAME}"
+ einfo "Using ${AMANDA_TMPDIR} as Amanda temporary directory."
+ myconf="${myconf} --with-tmpdir=${AMANDA_TMPDIR}"
+
+ if [ -n "${AMANDA_PORTS_UDP}" ] && [ -n "${AMANDA_PORTS_TCP}" ] && [ -z "${AMANDA_PORTS_BOTH}" ] ; then
+ eerror "If you want _both_ UDP and TCP ports, please use only the"
+ eerror "AMANDA_PORTS environment variable for identical ports, or set"
+ eerror "AMANDA_PORTS_BOTH."
+ die "Bad port setup!"
+ fi
+ if [ -n "${AMANDA_PORTS_UDP}" ]; then
+ einfo "Using UDP ports ${AMANDA_PORTS_UDP/,/-}"
+ myconf="${myconf} --with-udpportrange=${AMANDA_PORTS_UDP}"
+ fi
+ if [ -n "${AMANDA_PORTS_TCP}" ]; then
+ einfo "Using TCP ports ${AMANDA_PORTS_TCP/,/-}"
+ myconf="${myconf} --with-tcpportrange=${AMANDA_PORTS_TCP}"
+ fi
+ if [ -n "${AMANDA_PORTS}" ]; then
+ einfo "Using ports ${AMANDA_PORTS/,/-}"
+ myconf="${myconf} --with-portrange=${AMANDA_PORTS}"
+ fi
+
+ # Extras
+ # Speed option
+ myconf="${myconf} --with-buffered-dump"
+ # Debug
+ myconf="${myconf} `use_with debug debugging`"
+ # Where to put our files
+ myconf="${myconf} --localstatedir=${AMANDA_USER_HOMEDIR}"
+
+ # Samba support
+ use samba && myconf="${myconf} --with-smbclient=/usr/bin/smbclient" || myconf="${myconf} --without-smbclient"
+
+ # Force the correct TAR
+ myconf="${myconf} --with-gnutar=/bin/tar"
+
+ # Client only, as requested in bug #127725
+ use minimal && myconf="${myconf} --without-server"
+
+ econf ${myconf} || die "econf failed!"
+ emake -j1 || die "emake failed!"
+
+ # Compile the tapetype program too
+ # This is deprecated, use amtapetype instead!
+ # cd tape-src
+ # emake tapetype || die "emake tapetype failed!"
+
+ # Only needed if you we do versioning
+ #dosed "s,/usr/local/bin/perl,/usr/bin/perl," ${S}/contrib/set_prod_link.pl
+ #perl ${S}/contrib/set_prod_link.pl
+
+}
+
+src_install() {
+ [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
+ source ${TMPENVFILE}
+
+ einfo "Doing stock install"
+ make DESTDIR=${D} install || die
+
+ # Prepare our custom files
+ einfo "Building custom configuration files"
+ cp ${FILESDIR}/amanda-* ${MYFILESDIR}
+ local i # our iterator
+ local sedexpr # var for sed expr
+ sedexpr=''
+ for i in AMANDA_GROUP_GID AMANDA_GROUP_NAME AMANDA_USER_NAME AMANDA_USER_UID AMANDA_USER_SH AMANDA_USER_HOMEDIR AMANDA_USER_GROUPS AMANDA_SERVER AMANDA_SERVER_TAPE AMANDA_SERVER_INDEX AMANDA_TAR_LISTDIR AMANDA_CONFIG_NAME AMANDA_TMPDIR AMANDA_PORTS_UDP AMANDA_PORTS_TCP AMANDA_PORTS_BOTH AMANDA_PORTS; do
+ local val
+ eval "val=\"\${${i}}\""
+ sedexpr="${sedexpr}s|__${i}__|${val}|g;"
+ done
+ #einfo "Compiled SED expression: '${sedexpr}'"
+
+ # now apply the sed expr
+ for i in "${FILESDIR}"/amanda-* ; do
+ local filename
+ filename=`basename ${i}`
+ #einfo "Applying compiled SED expression to ${filename}"
+ sed -re "${sedexpr}" <${i} >"${MYFILESDIR}/${filename}"
+ done
+
+
+
+ # Build the envdir file
+ # Don't forget this..
+ einfo "Building environment file"
+ echo "# These settings are what was present in the environment when this" >>${MYFILESDIR}/${ENVDFILE}
+ echo "# Amanda was compiled. Changing anything below this comment will" >>${MYFILESDIR}/${ENVDFILE}
+ echo "# have no effect on your application, but it merely exists to" >>${MYFILESDIR}/${ENVDFILE}
+ echo "# preserve them for your next emerge of Amanda" >>${MYFILESDIR}/${ENVDFILE}
+ cat ${TMPENVFILE} | sed "s,=\$,='',g" >>${MYFILESDIR}/${ENVDFILE}
+
+ into /usr
+
+ # Deprecated, use amtapetype instead
+ #einfo "Installing tapetype utility"
+ #newsbin tape-src/tapetype tapetype
+
+ # docs
+ einfo "Installing documentation"
+ dodoc AUTHORS C* INSTALL NEWS README
+ # Clean up some bits
+ dodoc /usr/share/amanda/*
+ rm -rf ${D}/usr/share/amanda
+ mkdir -p ${D}/${MYINSTTMPDIR} || die
+ cp ${TMPENVFILE} "${D}/${TMPINSTENVFILE}" || die
+ # our inetd sample
+ einfo "Installing standard inetd sample"
+ newdoc ${MYFILESDIR}/amanda-inetd.amanda.sample-2.5.1_p3-r1 amanda-inetd.amanda.sample
+ # Stock extra docs
+ docinto docs
+ dodoc ${S}/docs/*
+ # Labels
+ einfo "Installing labels"
+ docinto labels
+ dodoc ${S}/example/3hole.ps
+ dodoc ${S}/example/8.5x11.ps
+ dodoc ${S}/example/DIN-A4.ps
+ dodoc ${S}/example/DLT.ps
+ dodoc ${S}/example/EXB-8500.ps
+ dodoc ${S}/example/HP-DAT.ps
+ # Amanda example configs
+ einfo "Installing example configurations"
+ docinto example
+ dodoc ${S}/example/*
+ docinto example1
+ newdoc ${FILESDIR}/example_amanda.conf amanda.conf
+ newdoc ${FILESDIR}/example_disklist-2.5.1_p3-r1 disklist
+ newdoc ${FILESDIR}/example_global.conf global.conf
+ docinto example2
+ newdoc ${S}/example/amanda.conf amanda.conf
+ newdoc ${S}/example/disklist disklist
+ # Compress it all
+ prepalldocs
+
+ # Just make sure it exists for XFS to work...
+ use !sparc && use xfs && keepdir /var/xfsdump/inventory
+
+ insinto /etc/amanda
+ einfo "Installing .amandahosts File for ${AMANDA_USER_NAME} user"
+
+ cat ${FILESDIR}/amanda-amandahosts-client-2.5.1_p3-r1 >>${D}/etc/amanda/amandahosts
+ use minimal \
+ || cat ${FILESDIR}/amanda-amandahosts-server2.5.1_p3-r1 >>${D}/etc/amanda/amandahosts
+
+ dosym /etc/amanda/amandahosts ${AMANDA_USER_HOMEDIR}/.amandahosts
+ insinto ${AMANDA_USER_HOMEDIR}
+ einfo "Installing .profile for ${AMANDA_USER_NAME} user"
+ newins ${MYFILESDIR}/amanda-profile .profile
+
+ einfo "Installing Sample Daily Cron Job for Amanda"
+ CRONDIR=/etc/cron.daily/
+ exeinto ${CRONDIR}
+ newexe ${MYFILESDIR}/amanda-cron amanda
+ # Not excetuable by default
+ fperms 644 ${CRONDIR}/amanda
+
+ insinto /etc/amanda/${AMANDA_CONFIG_NAME}
+ keepdir /etc/amanda
+ keepdir /etc/amanda/${AMANDA_CONFIG_NAME}
+
+ local i
+ for i in ${AMANDA_USER_HOMEDIR} ${AMANDA_TAR_LISTDIR} ${AMANDA_TMPDIR} ${AMANDA_TMPDIR}/dumps ${AMANDA_USER_HOMEDIR}/${AMANDA_CONFIG_NAME} /etc/amanda /etc/amanda/${AMANDA_CONFIG_NAME}; do
+ einfo "Securing directory (${i})"
+ dodir ${i}
+ keepdir ${i}
+ fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${i}
+ fperms 700 ${i}
+ done
+
+ # DevFS
+ einfo "Installing DevFS config file"
+ insinto /etc/devfs.d
+ newins ${MYFILESDIR}/amanda-devfs amanda
+
+ # Env.d
+ einfo "Installing environment config file"
+ insinto /etc/env.d
+ doins ${MYFILESDIR}/${ENVDFILE}
+
+ # Installing Amanda Xinetd Services Definition
+ einfo "Installing xinetd service file"
+ insinto /etc/xinetd.d
+ newins ${MYFILESDIR}/amanda-xinetd-2.5.1_p3-r1 amanda
+
+}
+
+pkg_postinst() {
+ local aux="${ROOT}/${TMPINSTENVFILE}"
+ [ ! -f "${aux}" ] && die "Variable setting file (${aux}) should exist!"
+ source "${aux}"
+ rm "${aux}"
+ rmdir ${ROOT}/${MYINSTTMPDIR} 2>/dev/null # ignore error
+
+ local i
+ for i in amandates dumpdates; do
+ einfo "Creating inital Amanda file (${i})"
+ touch ${ROOT}/etc/${i}
+ chown ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${ROOT}/etc/${i}
+ chmod 600 ${ROOT}/etc/${i}
+ done
+
+ # If USE=minimal, give out a warning, if AMANDA_SERVER is not set to
+ # another host than HOSTNAME.
+ if use minimal; then
+ if [[ "${AMANDA_SERVER}" = "${HOSTNAME}" ]]; then
+ echo
+ ewarn "You are installing a client-only version of Amanda."
+ ewarn "You should set the variable $AMANDA_SERVER to point at your"
+ ewarn "Amanda-tape-server, otherwise you will have to specify its name"
+ ewarn "when using amrecover on the client."
+ ewarn "For example: Use something like"
+ ewarn "AMANDA_SERVER=\"myserver\" emerge amanda"
+ echo
+ fi
+ fi
+
+
+ elog "You should configure Amanda in /etc/amanda now."
+ elog
+ elog "If you use xinetd, Don't forget to check /etc/xinetd.d/amanda"
+ elog "and restart xinetd afterwards!"
+ elog
+ elog "Otherwise, please look at /usr/share/doc/${P}/inetd.amanda.sample"
+ elog "as an example of how to configure your inetd."
+ elog
+ elog "NOTICE: If you need raw access to partitions you need to add the"
+ elog "amanda user to the 'disk' group and uncomment following lines in"
+ elog "your /etc/devfs.d/amanda:"
+ elog "SCSI:"
+ elog "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
+ elog "IDE:"
+ elog "REGISTER ^ide/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
+ elog
+ elog "NOTICE: If you have a tape changer, also uncomment the following"
+ elog "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/generic PERMISSIONS root.disk 660"
+ elog
+ elog "If you use localhost in your disklist your restores may break."
+ elog "You should replace it with the actual hostname!"
+ elog "Please also see the syntax changes to amandahosts."
+}
diff --git a/app-backup/amanda/files/amanda-2.5.1_p3-displayunit.patch b/app-backup/amanda/files/amanda-2.5.1_p3-displayunit.patch
new file mode 100644
index 000000000000..92c8fb5e6e2c
--- /dev/null
+++ b/app-backup/amanda/files/amanda-2.5.1_p3-displayunit.patch
@@ -0,0 +1,17 @@
+diff -u -r --show-c-function --new-file --exclude-from=/home/martinea/src.orig/amanda.diff --ignore-matching-lines='$Id:' amanda-2.5.1p3.new/server-src/amstatus.pl.in amanda-2.5.1p3.new.amstatus/server-src/amstatus.pl.in
+--- amanda-2.5.1p3.new/server-src/amstatus.pl.in 2007-02-01 14:17:01.000000000 -0500
++++ amanda-2.5.1p3.new.amstatus/server-src/amstatus.pl.in 2007-02-12 18:35:11.000000000 -0500
+@@ -763,9 +763,9 @@ while(<AMDUMP>) {
+ }
+ elsif(/splitting chunk that started at \d*kb after (\d*)kb/) {
+ $ntchunk{$nb_tape}++;
+- $ntsize{$nb_tape} += $1;
+- $ntesize{$nb_tape} += $1;
+- $ntchunk_size += $1;
++ $ntsize{$nb_tape} += $1 / $unitdivisor;
++ $ntesize{$nb_tape} += $1 / $unitdivisor;
++ $ntchunk_size += $1 / $unitdivisor;
+ }
+ elsif(/driver: FINISHED/) {
+ $driver_finished = 1;
+Binary files amanda-2.5.1p3.new/server-src/.amstatus.pl.in.swp and amanda-2.5.1p3.new.amstatus/server-src/.amstatus.pl.in.swp differ
diff --git a/app-backup/amanda/files/amanda-amandahosts-client-2.5.1_p3-r1 b/app-backup/amanda/files/amanda-amandahosts-client-2.5.1_p3-r1
new file mode 100644
index 000000000000..570a71056b47
--- /dev/null
+++ b/app-backup/amanda/files/amanda-amandahosts-client-2.5.1_p3-r1
@@ -0,0 +1,8 @@
+# vim: ts=4 sts=4 sw=4 noexpandtab:
+# Machine-name for those hosts which are permitted to back up (fully-qualified
+# is best). An entry in /etc/hosts adds fail-safe against DNS death :-)
+# |
+# | permitted user-name
+# | |
+
+__AMANDA_SERVER__ __AMANDA_USER_NAME__ amdump
diff --git a/app-backup/amanda/files/amanda-amandahosts-server-2.5.1_p3-r1 b/app-backup/amanda/files/amanda-amandahosts-server-2.5.1_p3-r1
new file mode 100644
index 000000000000..4951d4a9bf7d
--- /dev/null
+++ b/app-backup/amanda/files/amanda-amandahosts-server-2.5.1_p3-r1
@@ -0,0 +1,8 @@
+# vim: ts=4 sts=4 sw=4 noexpandtab:
+# Machine-name for those hosts which are permitted to back up (fully-qualified
+# is best). An entry in /etc/hosts adds fail-safe against DNS death :-)
+# |
+# | permitted user-name
+# | |
+
+__AMANDA_SERVER__ root amindexd amidxtaped
diff --git a/app-backup/amanda/files/amanda-inetd.amanda.sample-2.5.1_p3-r1 b/app-backup/amanda/files/amanda-inetd.amanda.sample-2.5.1_p3-r1
new file mode 100644
index 000000000000..902613254518
--- /dev/null
+++ b/app-backup/amanda/files/amanda-inetd.amanda.sample-2.5.1_p3-r1
@@ -0,0 +1,3 @@
+amanda dgram udp wait amanda /usr/libexec/amandad amandad -auth=bsd amdump amindexd amidxtaped
+amandaidx stream tcp nowait amanda /usr/libexec/amindexd amindexd -auth=bsd amdump amindexd amidxtaped
+amidxtape stream tcp nowait amanda /usr/libexec/amidxtaped amidxtaped -auth=bsd amdump amindexd amidxtaped
diff --git a/app-backup/amanda/files/amanda-xinetd-2.5.1_p3-r1 b/app-backup/amanda/files/amanda-xinetd-2.5.1_p3-r1
new file mode 100644
index 000000000000..801006096e8a
--- /dev/null
+++ b/app-backup/amanda/files/amanda-xinetd-2.5.1_p3-r1
@@ -0,0 +1,49 @@
+# These are the services needed for amanda.
+# Default is to talk to localhost only unless
+# AMANDA_SERVER was specified at build time.
+
+service amanda
+{
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = __AMANDA_USER_NAME__
+ group = __AMANDA_GROUP_NAME__
+ groups = yes
+ server = /usr/libexec/amandad
+ server_args = -auth=bsd amdump amindexd amidxtaped
+ # You need to ensure this points to your Amanda server!
+ # Don't just remove it!
+ only_from = __AMANDA_SERVER__
+ disable = yes
+}
+
+service amandaidx
+{
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = __AMANDA_USER_NAME__
+ group = __AMANDA_GROUP_NAME__
+ groups = yes
+ server = /usr/libexec/amindexd
+ # You need to ensure this points to your Amanda server!
+ # Don't just remove it!
+ only_from = __AMANDA_SERVER__
+ disable = yes
+}
+
+service amidxtape
+{
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = __AMANDA_USER_NAME__
+ group = __AMANDA_GROUP_NAME__
+ groups = yes
+ server = /usr/libexec/amidxtaped
+ # You need to ensure this points to your Amanda server!
+ # Don't just remove it!
+ only_from = __AMANDA_SERVER__
+ disable = yes
+}
diff --git a/app-backup/amanda/files/digest-amanda-2.5.1_p3-r1 b/app-backup/amanda/files/digest-amanda-2.5.1_p3-r1
new file mode 100644
index 000000000000..9c0687c0c6d0
--- /dev/null
+++ b/app-backup/amanda/files/digest-amanda-2.5.1_p3-r1
@@ -0,0 +1,3 @@
+MD5 7232da6d43543f2c7dac2ded21c65ee9 amanda-2.5.1p3.tar.gz 1905664
+RMD160 90462c7d65736c5920bc2782e8666a34b3f32026 amanda-2.5.1p3.tar.gz 1905664
+SHA256 64e60f323a89a8a064936334335cfde6cf41e6127f7f8b1c9b6de2d393de3f72 amanda-2.5.1p3.tar.gz 1905664
diff --git a/app-backup/amanda/files/example_disklist-2.5.1_p3-r1 b/app-backup/amanda/files/example_disklist-2.5.1_p3-r1
new file mode 100644
index 000000000000..73bf0174ee23
--- /dev/null
+++ b/app-backup/amanda/files/example_disklist-2.5.1_p3-r1
@@ -0,0 +1,4 @@
+# Substitute <HOSTNAME> with the FQDN of your Amanda-client here.
+# The usage of localhost will *break* your restores.
+<HOSTNAME> hda1 normal local
+<HOSTNAME> hda3 normal local