summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xmlcopyeditor/ChangeLog9
-rw-r--r--app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.0.6-gcc-4.8.patch13
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild9
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild9
4 files changed, 32 insertions, 8 deletions
diff --git a/app-editors/xmlcopyeditor/ChangeLog b/app-editors/xmlcopyeditor/ChangeLog
index 82afad44c2c0..215f490da4ca 100644
--- a/app-editors/xmlcopyeditor/ChangeLog
+++ b/app-editors/xmlcopyeditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xmlcopyeditor
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.25 2012/12/03 19:55:30 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.26 2013/04/05 09:27:25 pinkbyte Exp $
+
+ 05 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> xmlcopyeditor-1.2.0.6.ebuild,
+ +files/xmlcopyeditor-1.2.0.6-gcc-4.8.patch, xmlcopyeditor-1.2.0.9.ebuild:
+ Fix building with gcc 4.8, wrt bug #464280. Thanks to Patrick Lauer for
+ discovering this issue and David Abbott for providing patch
*xmlcopyeditor-1.2.0.9 (03 Dec 2012)
diff --git a/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.0.6-gcc-4.8.patch b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.0.6-gcc-4.8.patch
new file mode 100644
index 000000000000..4367cee1fa0a
--- /dev/null
+++ b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.2.0.6-gcc-4.8.patch
@@ -0,0 +1,13 @@
+--- a/xmlcopyeditor-1.2.0.9/src/housestyle.h 2012-10-07 09:19:52.000000000 -0400
++++ b/xmlcopyeditor-1.2.0.9/src/housestyle.h 2013-04-03 10:27:46.784455182 -0400
+@@ -68,8 +68,9 @@
+ filterDirectory,
+ filterFile,
+ pathSeparator,
+- error,
++ error
+ #ifdef __WXMSW__
++ ,
+ aspellDataPath,
+ aspellDictPath
+ #endif
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
index 1588ff082ff8..41f64eef8079 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild,v 1.6 2012/11/27 10:13:16 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.6.ebuild,v 1.7 2013/04/05 09:27:26 pinkbyte Exp $
EAPI="4"
WX_GTK_VER="2.8"
MY_P=${P}-2
-inherit autotools wxwidgets
+inherit autotools eutils wxwidgets
DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
@@ -40,6 +40,9 @@ src_prepare() {
sed -i -e 's/ -Wall -g -fexceptions//g' \
-e '/CXXFLAGS/s/CPPFLAGS/CXXFLAGS/' \
configure.in || die 'sed on configure.in failed'
+ # bug #464280
+ epatch "${FILESDIR}/${P}-gcc-4.8.patch"
+
eautoreconf
}
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild
index 6c6e3ea9d731..3dd53d3611c1 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild,v 1.1 2012/12/03 19:55:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild,v 1.2 2013/04/05 09:27:26 pinkbyte Exp $
EAPI="4"
WX_GTK_VER="2.8"
-inherit autotools wxwidgets
+inherit autotools eutils wxwidgets
DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
@@ -38,6 +38,9 @@ src_prepare() {
sed -i -e 's/ -Wall -g -fexceptions//g' \
-e '/CXXFLAGS/s/CPPFLAGS/CXXFLAGS/' \
configure.in || die 'sed on configure.in failed'
+ # bug #464280
+ epatch "${FILESDIR}/${PN}-1.2.0.6-gcc-4.8.patch"
+
eautoreconf
}