summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/tramp/ChangeLog8
-rw-r--r--app-emacs/tramp/files/digest-tramp-2.0.563
-rw-r--r--app-emacs/tramp/files/tramp-2.0.56-configure.patch28
-rw-r--r--app-emacs/tramp/metadata.xml4
-rw-r--r--app-emacs/tramp/tramp-2.0.56.ebuild50
5 files changed, 90 insertions, 3 deletions
diff --git a/app-emacs/tramp/ChangeLog b/app-emacs/tramp/ChangeLog
index 570757777324..9a9564978e51 100644
--- a/app-emacs/tramp/ChangeLog
+++ b/app-emacs/tramp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/tramp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/tramp/ChangeLog,v 1.38 2007/08/17 22:15:40 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tramp/ChangeLog,v 1.39 2007/08/18 16:37:25 ulm Exp $
+
+*tramp-2.0.56 (18 Aug 2007)
+
+ 18 Aug 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/tramp-2.0.56-configure.patch, metadata.xml, +tramp-2.0.56.ebuild:
+ Version bump. Fix spelling of longdescription.
*tramp-2.1.10 (17 Aug 2007)
*tramp-2.0.55 (17 Aug 2007)
diff --git a/app-emacs/tramp/files/digest-tramp-2.0.56 b/app-emacs/tramp/files/digest-tramp-2.0.56
new file mode 100644
index 000000000000..5fe41c35a2b3
--- /dev/null
+++ b/app-emacs/tramp/files/digest-tramp-2.0.56
@@ -0,0 +1,3 @@
+MD5 e171d923dfe2d41f1ba7057d0bc5d6e1 tramp-2.0.56.tar.gz 290941
+RMD160 d081d018f532cbe4353147989646fb714b6eb625 tramp-2.0.56.tar.gz 290941
+SHA256 c70cae3992bababf6270842360da7786b2aa5224f481bad578f1b3a156e5fd1e tramp-2.0.56.tar.gz 290941
diff --git a/app-emacs/tramp/files/tramp-2.0.56-configure.patch b/app-emacs/tramp/files/tramp-2.0.56-configure.patch
new file mode 100644
index 000000000000..f17b3bb798ee
--- /dev/null
+++ b/app-emacs/tramp/files/tramp-2.0.56-configure.patch
@@ -0,0 +1,28 @@
+--- tramp-2.0.56.orig/configure 2007-05-28 10:36:38.000000000 +0200
++++ tramp-2.0.56/configure 2007-08-18 18:18:49.003204055 +0200
+@@ -3973,4 +3973,23 @@
+
+
+ # configure is writing to config.log, and then calls config.status.
+-# config.status does its own redirection, appendi
+\ No newline at end of file
++# config.status does its own redirection, appending to config.log.
++# Unfortunately, on DOS this fails, as config.log is still kept open
++# by configure, so config.status won't be able to write to it; its
++# output is simply discarded. So we exec the FD to /dev/null,
++# effectively closing config.log, so it can be properly (re)opened and
++# appended to by config.status. When coming back to configure, we
++# need to make the FD available again.
++if test "$no_create" != yes; then
++ ac_cs_success=:
++ ac_config_status_args=
++ test "$silent" = yes &&
++ ac_config_status_args="$ac_config_status_args --quiet"
++ exec 5>/dev/null
++ $SHELL $CONFIG_STATUS $ac_config_status_args || ac_cs_success=false
++ exec 5>>config.log
++ # Use ||, not &&, to avoid exiting from the if with $? = 1, which
++ # would make configure fail if this is the last instruction.
++ $ac_cs_success || { (exit 1); exit 1; }
++fi
++
diff --git a/app-emacs/tramp/metadata.xml b/app-emacs/tramp/metadata.xml
index 84f5dd124ef9..eecd206ac044 100644
--- a/app-emacs/tramp/metadata.xml
+++ b/app-emacs/tramp/metadata.xml
@@ -5,7 +5,7 @@
<longdescription>
TRAMP (Transparent Remote Access, Multiple Protocols) is a package for
editing remote files, similar to ange-ftp. Whereas ange-ftp uses FTP
-to conn ect to the remote host and to transfer the files, TRAMP uses a
-remote shell conn ection (rlogin, telnet, ssh)
+to connect to the remote host and to transfer the files, TRAMP uses a
+remote shell connection (rlogin, telnet, ssh)
</longdescription>
</pkgmetadata>
diff --git a/app-emacs/tramp/tramp-2.0.56.ebuild b/app-emacs/tramp/tramp-2.0.56.ebuild
new file mode 100644
index 000000000000..58c9fcc54c6c
--- /dev/null
+++ b/app-emacs/tramp/tramp-2.0.56.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tramp/tramp-2.0.56.ebuild,v 1.1 2007/08/18 16:37:25 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Edit remote files like ange-ftp but with rlogin, telnet and/or ssh"
+HOMEPAGE="http://savannah.gnu.org/projects/tramp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~amd64 ~ppc"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ # the 2.0.56 tarball contains a truncated "configure" file
+ epatch "${FILESDIR}/${P}-configure.patch"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ elisp-make-autoload-file lisp/${PN}-autoloads.el lisp \
+ || die "elisp-make-autoload-file failed"
+}
+
+src_install() {
+ dodir /usr/share/info
+ dodir /usr/share/emacs/etc
+ dodir /usr/share/emacs/site-lisp/tramp
+
+ einstall lispdir="${D}/usr/share/emacs/site-lisp/tramp" || die
+
+ mv "${D}/usr/share/info/tramp" "${D}/usr/share/info/tramp-info"
+
+ dohtml texi/*.html
+ if [ -f texi/tramp.dvi ]; then
+ insinto /usr/share/doc/${PF}
+ doins texi/tramp.dvi
+ fi
+
+ elisp-install ${PN} lisp/${PN}-autoloads.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc README ChangeLog CONTRIBUTORS || die "dodoc failed"
+}