summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemu-softmmu/files')
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.02
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0-r12
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.13
-rw-r--r--app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-hacks.patch126
-rw-r--r--app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-opts.patch41
-rw-r--r--app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch12
-rw-r--r--app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch18
7 files changed, 7 insertions, 197 deletions
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0
new file mode 100644
index 000000000000..8a94b0c124b3
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0
@@ -0,0 +1,2 @@
+RMD160 4296542b6da18a6ac93d20787330d3c1c2ac0a19 qemu-0.9.0.tar.gz 1901741
+SHA256 491facf9335654967ee53d8fb3540a274bfcbdcc225506bd38c4ee8e9ab405c1 qemu-0.9.0.tar.gz 1901741
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0-r1 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0-r1
new file mode 100644
index 000000000000..8a94b0c124b3
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0-r1
@@ -0,0 +1,2 @@
+RMD160 4296542b6da18a6ac93d20787330d3c1c2ac0a19 qemu-0.9.0.tar.gz 1901741
+SHA256 491facf9335654967ee53d8fb3540a274bfcbdcc225506bd38c4ee8e9ab405c1 qemu-0.9.0.tar.gz 1901741
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.1 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.1
new file mode 100644
index 000000000000..8e50cf7424be
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.1
@@ -0,0 +1,3 @@
+MD5 6591df8e9270eb358c881de4ebea1262 qemu-0.9.1.tar.gz 2804104
+RMD160 ee7bdb55a4540df2082d4bde9ebfd2f4e6f201a5 qemu-0.9.1.tar.gz 2804104
+SHA256 4756d0b4a4dc7dd88354bc6b37d381e4462dd328d0feef94803e90c0455835a5 qemu-0.9.1.tar.gz 2804104
diff --git a/app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-hacks.patch b/app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-hacks.patch
deleted file mode 100644
index b5aa0fd36873..000000000000
--- a/app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-hacks.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-2005-10-28 Gwenole Beauchesne <gbeauchesne@mandriva.com>
-
- * Various additional hacks for GCC4.
-
-Index: qemu-0.8.1/cpu-all.h
-===================================================================
---- qemu-0.8.1.orig/cpu-all.h
-+++ qemu-0.8.1/cpu-all.h
-@@ -339,7 +339,13 @@ static inline void stl_le_p(void *ptr, i
-
- static inline void stq_le_p(void *ptr, uint64_t v)
- {
-+#if defined(__i386__) && __GNUC__ >= 4
-+ const union { uint64_t v; uint32_t p[2]; } x = { .v = v };
-+ ((uint32_t *)ptr)[0] = x.p[0];
-+ ((uint32_t *)ptr)[1] = x.p[1];
-+#else
- *(uint64_t *)ptr = v;
-+#endif
- }
-
- /* float access */
-Index: qemu-0.8.1/softmmu_header.h
-===================================================================
---- qemu-0.8.1.orig/softmmu_header.h
-+++ qemu-0.8.1/softmmu_header.h
-@@ -108,7 +108,7 @@ DATA_TYPE REGPARM(1) glue(glue(__ld, SUF
- void REGPARM(2) glue(glue(__st, SUFFIX), MMUSUFFIX)(target_ulong addr, DATA_TYPE v, int is_user);
-
- #if (DATA_SIZE <= 4) && (TARGET_LONG_BITS == 32) && defined(__i386__) && \
-- (ACCESS_TYPE <= 1) && defined(ASM_SOFTMMU)
-+ (ACCESS_TYPE <= 1) && defined(ASM_SOFTMMU) && (__GNUC__ < 4)
-
- #define CPU_TLB_ENTRY_BITS 4
-
-@@ -150,7 +150,7 @@ static inline RES_TYPE glue(glue(ld, USU
- "m" (*(uint32_t *)offsetof(CPUState, tlb_table[CPU_MEM_INDEX][0].addr_read)),
- "i" (CPU_MEM_INDEX),
- "m" (*(uint8_t *)&glue(glue(__ld, SUFFIX), MMUSUFFIX))
-- : "%eax", "%ecx", "%edx", "memory", "cc");
-+ : "%eax", "%edx", "memory", "cc");
- return res;
- }
-
-@@ -197,13 +197,14 @@ static inline int glue(glue(lds, SUFFIX)
- "m" (*(uint32_t *)offsetof(CPUState, tlb_table[CPU_MEM_INDEX][0].addr_read)),
- "i" (CPU_MEM_INDEX),
- "m" (*(uint8_t *)&glue(glue(__ld, SUFFIX), MMUSUFFIX))
-- : "%eax", "%ecx", "%edx", "memory", "cc");
-+ : "%eax", "%edx", "memory", "cc");
- return res;
- }
- #endif
-
--static inline void glue(glue(st, SUFFIX), MEMSUFFIX)(target_ulong ptr, RES_TYPE v)
-+static inline void glue(glue(st, SUFFIX), MEMSUFFIX)(target_ulong ptr, RES_TYPE val)
- {
-+ RES_TYPE v = val;
- asm volatile ("movl %0, %%edx\n"
- "movl %0, %%eax\n"
- "shrl %3, %%edx\n"
-@@ -240,16 +241,14 @@ static inline void glue(glue(st, SUFFIX)
- "2:\n"
- :
- : "r" (ptr),
--/* NOTE: 'q' would be needed as constraint, but we could not use it
-- with T1 ! */
-- "r" (v),
-+ "q" (v),
- "i" ((CPU_TLB_SIZE - 1) << CPU_TLB_ENTRY_BITS),
- "i" (TARGET_PAGE_BITS - CPU_TLB_ENTRY_BITS),
- "i" (TARGET_PAGE_MASK | (DATA_SIZE - 1)),
- "m" (*(uint32_t *)offsetof(CPUState, tlb_table[CPU_MEM_INDEX][0].addr_write)),
- "i" (CPU_MEM_INDEX),
- "m" (*(uint8_t *)&glue(glue(__st, SUFFIX), MMUSUFFIX))
-- : "%eax", "%ecx", "%edx", "memory", "cc");
-+ : "%eax", "%edx", "memory", "cc");
- }
-
- #else
-Index: qemu-0.8.1/target-i386/helper.c
-===================================================================
---- qemu-0.8.1.orig/target-i386/helper.c
-+++ qemu-0.8.1/target-i386/helper.c
-@@ -3145,8 +3145,15 @@ void helper_fxrstor(target_ulong ptr, in
- nb_xmm_regs = 8 << data64;
- addr = ptr + 0xa0;
- for(i = 0; i < nb_xmm_regs; i++) {
-+#if defined(__i386__) && __GNUC__ >= 4
-+ env->xmm_regs[i].XMM_L(0) = ldl(addr);
-+ env->xmm_regs[i].XMM_L(1) = ldl(addr + 4);
-+ env->xmm_regs[i].XMM_L(2) = ldl(addr + 8);
-+ env->xmm_regs[i].XMM_L(3) = ldl(addr + 12);
-+#else
- env->xmm_regs[i].XMM_Q(0) = ldq(addr);
- env->xmm_regs[i].XMM_Q(1) = ldq(addr + 8);
-+#endif
- addr += 16;
- }
- }
-Index: qemu-0.8.1/target-i386/ops_sse.h
-===================================================================
---- qemu-0.8.1.orig/target-i386/ops_sse.h
-+++ qemu-0.8.1/target-i386/ops_sse.h
-@@ -34,6 +34,12 @@
- #define Q(n) XMM_Q(n)
- #define SUFFIX _xmm
- #endif
-+#if defined(__i386__) && __GNUC__ >= 4
-+#define RegCopy(d, s) __builtin_memcpy(&(d), &(s), sizeof(d))
-+#endif
-+#ifndef RegCopy
-+#define RegCopy(d, s) d = s
-+#endif
-
- void OPPROTO glue(op_psrlw, SUFFIX)(void)
- {
-@@ -570,7 +576,7 @@ void OPPROTO glue(op_pshufw, SUFFIX) (vo
- r.W(1) = s->W((order >> 2) & 3);
- r.W(2) = s->W((order >> 4) & 3);
- r.W(3) = s->W((order >> 6) & 3);
-- *d = r;
-+ RegCopy(*d, r);
- }
- #else
- void OPPROTO op_shufps(void)
diff --git a/app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-opts.patch b/app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-opts.patch
deleted file mode 100644
index 4819dfb7f2a2..000000000000
--- a/app-emulation/qemu-softmmu/files/qemu-0.8.0-gcc4-opts.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-2005-11-11 Gwenole Beauchesne <gbeauchesne@mandriva.com>
-
- * Globaaly save %ebx, %esi, %edi on entry to generated
- function. This avoids some register spills in synthetic opcodes.
- NOTE: this also easily fixes gcc4 compiled qemu-system-x86_64 on x86.
-
-Index: qemu-0.8.1/Makefile.target
-===================================================================
---- qemu-0.8.1.orig/Makefile.target
-+++ qemu-0.8.1/Makefile.target
-@@ -68,6 +68,10 @@ OP_CFLAGS+= -falign-functions=0 -fno-gcs
- else
- OP_CFLAGS+= -malign-functions=0
- endif
-+ifeq ($(TARGET_ARCH), x86_64)
-+# XXX globally save %ebx, %esi, %edi on entry to generated function
-+OP_CFLAGS+= -fcall-used-ebx -fcall-used-esi -fcall-used-edi
-+endif
-
- ifdef TARGET_GPROF
- USE_I386_LD=y
-Index: qemu-0.8.1/cpu-exec.c
-===================================================================
---- qemu-0.8.1.orig/cpu-exec.c
-+++ qemu-0.8.1/cpu-exec.c
-@@ -677,6 +677,15 @@ int cpu_exec(CPUState *env1)
- : /* no outputs */
- : "r" (gen_func)
- : "r1", "r2", "r3", "r8", "r9", "r10", "r12", "r14");
-+#elif defined(TARGET_X86_64) && defined(__i386__)
-+ asm volatile ("push %%ebx\n"
-+ "push %%esi\n"
-+ "push %%edi\n"
-+ "call *%0\n"
-+ "pop %%edi\n"
-+ "pop %%esi\n"
-+ "pop %%ebx\n"
-+ : : "r" (gen_func) : "ebx", "esi", "edi");
- #elif defined(TARGET_I386) && defined(USE_CODE_COPY)
- {
- if (!(tb->cflags & CF_CODE_COPY)) {
diff --git a/app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch b/app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch
deleted file mode 100644
index 6307f6b32591..000000000000
--- a/app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-don't actually need linux/compiler.h and sanitized headers dont include it
-
---- qemu-0.8.2/usb-linux.c
-+++ qemu-0.8.2/usb-linux.c
-@@ -26,7 +26,6 @@
- #if defined(__linux__)
- #include <dirent.h>
- #include <sys/ioctl.h>
--#include <linux/compiler.h>
- #include <linux/usbdevice_fs.h>
- #include <linux/version.h>
-
diff --git a/app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch b/app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch
deleted file mode 100644
index f190f66d4ec5..000000000000
--- a/app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -urN qemu-0.8.2.old/target-sparc/op_helper.c qemu-0.8.2/target-sparc/op_helper.c
---- qemu-0.8.2.old/target-sparc/op_helper.c 2006-07-22 19:23:34.000000000 +0200
-+++ qemu-0.8.2/target-sparc/op_helper.c 2006-08-01 09:46:34.000000000 +0200
-@@ -12,12 +12,12 @@
- #ifdef USE_INT_TO_FLOAT_HELPERS
- void do_fitos(void)
- {
-- FT0 = int32_to_float32(*((int32_t *)&FT1));
-+ FT0 = int32_to_float32(*((int32_t *)&FT1), &env->fp_status);
- }
-
- void do_fitod(void)
- {
-- DT0 = int32_to_float64(*((int32_t *)&FT1));
-+ DT0 = int32_to_float64(*((int32_t *)&FT1), &env->fp_status);
- }
- #endif
-