summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/wine-1.3.0.ebuild9
-rw-r--r--app-emulation/wine/wine-1.3.1.ebuild9
-rw-r--r--app-emulation/wine/wine-1.3.2.ebuild9
-rw-r--r--app-emulation/wine/wine-9999.ebuild9
5 files changed, 25 insertions, 17 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 920372b6658d..fe5a03405f95 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.324 2010/09/06 20:38:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.325 2010/09/07 17:10:15 vapier Exp $
+
+ 07 Sep 2010; Mike Frysinger <vapier@gentoo.org> wine-1.3.0.ebuild,
+ wine-1.3.1.ebuild, wine-1.3.2.ebuild, wine-9999.ebuild:
+ Drop amd64 check with USE=win64 now that it is in x86 use.mask.
*wine-1.3.2 (06 Sep 2010)
diff --git a/app-emulation/wine/wine-1.3.0.ebuild b/app-emulation/wine/wine-1.3.0.ebuild
index e04de1f56f2b..f8206a82d7fe 100644
--- a/app-emulation/wine/wine-1.3.0.ebuild
+++ b/app-emulation/wine/wine-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.0.ebuild,v 1.3 2010/08/06 20:54:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.0.ebuild,v 1.4 2010/09/07 17:10:15 vapier Exp $
EAPI="2"
@@ -94,8 +94,9 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_unpack() {
- if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
- use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
fi
if [[ ${PV} == "9999" ]] ; then
@@ -165,7 +166,7 @@ src_configure() {
export LDCONFIG=/bin/true
use custom-cflags || strip-flags
- if use win64 && use amd64 ; then
+ if use win64 ; then
do_configure 64 --enable-win64
use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
else
diff --git a/app-emulation/wine/wine-1.3.1.ebuild b/app-emulation/wine/wine-1.3.1.ebuild
index 9700638b8740..587b832356c1 100644
--- a/app-emulation/wine/wine-1.3.1.ebuild
+++ b/app-emulation/wine/wine-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.1.ebuild,v 1.1 2010/08/30 05:20:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.1.ebuild,v 1.2 2010/09/07 17:10:15 vapier Exp $
EAPI="2"
@@ -94,8 +94,9 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_unpack() {
- if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
- use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
fi
if [[ ${PV} == "9999" ]] ; then
@@ -165,7 +166,7 @@ src_configure() {
export LDCONFIG=/bin/true
use custom-cflags || strip-flags
- if use win64 && use amd64 ; then
+ if use win64 ; then
do_configure 64 --enable-win64
use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
else
diff --git a/app-emulation/wine/wine-1.3.2.ebuild b/app-emulation/wine/wine-1.3.2.ebuild
index 2f208f5e21b0..29c0b96142ba 100644
--- a/app-emulation/wine/wine-1.3.2.ebuild
+++ b/app-emulation/wine/wine-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.2.ebuild,v 1.1 2010/09/06 20:38:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.2.ebuild,v 1.2 2010/09/07 17:10:15 vapier Exp $
EAPI="2"
@@ -94,8 +94,9 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_unpack() {
- if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
- use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
fi
if [[ ${PV} == "9999" ]] ; then
@@ -165,7 +166,7 @@ src_configure() {
export LDCONFIG=/bin/true
use custom-cflags || strip-flags
- if use win64 && use amd64 ; then
+ if use win64 ; then
do_configure 64 --enable-win64
use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
else
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 58add8808dac..e08ee80ce65a 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.58 2010/08/06 20:54:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.59 2010/09/07 17:10:15 vapier Exp $
EAPI="2"
@@ -94,8 +94,9 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_unpack() {
- if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
- use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
fi
if [[ ${PV} == "9999" ]] ; then
@@ -165,7 +166,7 @@ src_configure() {
export LDCONFIG=/bin/true
use custom-cflags || strip-flags
- if use win64 && use amd64 ; then
+ if use win64 ; then
do_configure 64 --enable-win64
use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
else