summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/files/wine-0.9.11-winegcc-short-libnames.patch33
-rw-r--r--app-emulation/wine/wine-0.9.11.ebuild5
3 files changed, 41 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index f092a4357776..0319a92638b8 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.137 2006/04/02 20:11:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.138 2006/04/14 23:31:23 vapier Exp $
+
+ 14 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/wine-0.9.11-winegcc-short-libnames.patch, wine-0.9.11.ebuild:
+ Grab patch from upstream for amd64 build fix #129557 by Andrew Dorney.
02 Apr 2006; Mike Frysinger <vapier@gentoo.org> wine-0.9.ebuild,
wine-0.9.1.ebuild, wine-0.9.2.ebuild, wine-0.9.3.ebuild,
diff --git a/app-emulation/wine/files/wine-0.9.11-winegcc-short-libnames.patch b/app-emulation/wine/files/wine-0.9.11-winegcc-short-libnames.patch
new file mode 100644
index 000000000000..290264925bbd
--- /dev/null
+++ b/app-emulation/wine/files/wine-0.9.11-winegcc-short-libnames.patch
@@ -0,0 +1,33 @@
+2006-04-04 Alexandre Julliard <julliard@winehq.org>
+
+ * tools/winegcc/winegcc.c:
+ winegcc: Don't use the library full name for .so libs.
+
+Index: tools/winegcc/winegcc.c
+===================================================================
+RCS file: /home/wine/wine/tools/winegcc/winegcc.c,v
+retrieving revision 1.50
+retrieving revision 1.51
+diff -u -p -r1.50 -r1.51
+--- tools/winegcc/winegcc.c 16 Mar 2006 20:41:40 -0000 1.50
++++ tools/winegcc/winegcc.c 4 Apr 2006 21:16:14 -0000 1.51
+@@ -401,8 +401,6 @@ static void add_library( strarray *lib_d
+ }
+ break;
+ case file_so:
+- strarray_add(files, strmake("-s%s", fullname));
+- break;
+ default:
+ /* keep it anyway, the linker may know what to do with it */
+ strarray_add(files, strmake("-l%s", library));
+@@ -628,9 +626,9 @@ static void build(struct options* opts)
+ switch(files->base[j][1])
+ {
+ case 'l':
++ case 's':
+ strarray_add(link_args, strmake("-l%s", name));
+ break;
+- case 's':
+ case 'a':
+ case 'o':
+ strarray_add(link_args, name);
diff --git a/app-emulation/wine/wine-0.9.11.ebuild b/app-emulation/wine/wine-0.9.11.ebuild
index 1947e3a85a33..99efd3902519 100644
--- a/app-emulation/wine/wine-0.9.11.ebuild
+++ b/app-emulation/wine/wine-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.11.ebuild,v 1.5 2006/04/11 21:58:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.11.ebuild,v 1.6 2006/04/14 23:31:23 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* -amd64 ~x86"
+KEYWORDS="-* ~amd64 ~x86"
IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner truetype xml X"
RESTRICT="test" #72375
@@ -70,6 +70,7 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+ epatch "${FILESDIR}"/${P}-winegcc-short-libnames.patch #129557
}
config_cache() {