summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/ChangeLog8
-rw-r--r--app-misc/gnote/gnote-3.8.0.ebuild50
2 files changed, 56 insertions, 2 deletions
diff --git a/app-misc/gnote/ChangeLog b/app-misc/gnote/ChangeLog
index 23454ac42928..46064ef30128 100644
--- a/app-misc/gnote/ChangeLog
+++ b/app-misc/gnote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gnote
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.29 2013/03/05 22:58:09 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.30 2013/03/28 15:53:22 pacho Exp $
+
+*gnote-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gnote-3.8.0.ebuild:
+ Version bump
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> -gnote-3.6.1.ebuild:
Clean up old revision.
@@ -141,4 +146,3 @@
+files/gnote-0.6.1-dbus-switch.patch, +metadata.xml:
Initial ebuild by Gilles Dartiguelongue <eva@gentoo.org>, copied and bumped
from gnome overlay, closes bug #268015.
-
diff --git a/app-misc/gnote/gnote-3.8.0.ebuild b/app-misc/gnote/gnote-3.8.0.ebuild
new file mode 100644
index 000000000000..b66e275b63db
--- /dev/null
+++ b/app-misc/gnote/gnote-3.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-3.8.0.ebuild,v 1.1 2013/03/28 15:53:22 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.28:2
+ >=dev-cpp/gtkmm-3.6:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable debug)
+ ITSTOOL=$(type -P true)"
+
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+}