summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/taxbird')
-rw-r--r--app-office/taxbird/ChangeLog9
-rw-r--r--app-office/taxbird/taxbird-0.18.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-office/taxbird/ChangeLog b/app-office/taxbird/ChangeLog
index a98d8ab131b8..4ab53f8c46a2 100644
--- a/app-office/taxbird/ChangeLog
+++ b/app-office/taxbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taxbird
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.27 2011/03/21 21:45:52 nirbheek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.28 2012/01/13 01:07:39 xmw Exp $
+
+*taxbird-0.18 (13 Jan 2012)
+
+ 13 Jan 2012; Michael Weber <xmw@gentoo.org> +taxbird-0.18.ebuild:
+ version bump (bug 398235, thanks Hannan Sadar)
21 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> taxbird-0.15.ebuild,
taxbird-0.16.ebuild:
diff --git a/app-office/taxbird/taxbird-0.18.ebuild b/app-office/taxbird/taxbird-0.18.ebuild
new file mode 100644
index 000000000000..5e8606eae730
--- /dev/null
+++ b/app-office/taxbird/taxbird-0.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.18.ebuild,v 1.1 2012/01/13 01:07:39 xmw Exp $
+
+EAPI="2"
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Taxbird provides a GUI to submit tax forms to the german digital tax project ELSTER."
+HOMEPAGE="http://www.taxbird.de/"
+SRC_URI="http://www.taxbird.de/download/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libgeier-0.13
+ >=gnome-extra/gtkhtml-3.8:3.14
+ gnome-base/libgnomeui
+ sys-devel/gettext
+ >=dev-scheme/guile-1.8.0[regex,deprecated]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodoc README* || die "dodoc failed"
+
+ einstall || die "Installation failed!"
+
+ # clean out the installed mime files, those get recreated in the pkg_postinst function
+ einfo "Deleting mime files in ${D}/usr/share/mime"
+ find "${D}/usr/share/mime/" -maxdepth 1 -type f -delete
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}