summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/llpp')
-rw-r--r--app-text/llpp/files/llpp-9999-fz_drop_display_list.patch13
-rw-r--r--app-text/llpp/files/llpp-9999-mupdf-split-headers.patch19
-rw-r--r--app-text/llpp/llpp-9999.ebuild6
3 files changed, 36 insertions, 2 deletions
diff --git a/app-text/llpp/files/llpp-9999-fz_drop_display_list.patch b/app-text/llpp/files/llpp-9999-fz_drop_display_list.patch
new file mode 100644
index 000000000000..ad2634537411
--- /dev/null
+++ b/app-text/llpp/files/llpp-9999-fz_drop_display_list.patch
@@ -0,0 +1,13 @@
+Required by http://git.ghostscript.com/?p=mupdf.git;a=commit;f=fitz/dev_list.c;h=f85653219a85a9f91cb14471485611ca5f6b25ba
+
+--- llpp-9999/link.c
++++ llpp-9999/link.c
+@@ -571,7 +571,7 @@
+ free (page->slinks);
+ }
+ page->freepage (page->u.ptr);
+- fz_free_display_list (state.ctx, page->dlist);
++ fz_drop_display_list (state.ctx, page->dlist);
+ free (page);
+ }
+
diff --git a/app-text/llpp/files/llpp-9999-mupdf-split-headers.patch b/app-text/llpp/files/llpp-9999-mupdf-split-headers.patch
new file mode 100644
index 000000000000..c62a58b48ad0
--- /dev/null
+++ b/app-text/llpp/files/llpp-9999-mupdf-split-headers.patch
@@ -0,0 +1,19 @@
+--- llpp-9999/work/llpp-9999/link.c
++++ llpp-9999/work/llpp-9999/link.c
+@@ -30,12 +30,10 @@
+ #include <caml/memory.h>
+ #include <caml/unixsupport.h>
+
+-#include <fitz.h>
+-#include <mupdf.h>
+-#include <mupdf-internal.h>
+-#include <muxps.h>
+-#include <muxps-internal.h>
+-#include <mucbz.h>
++#include <mupdf/cbz.h>
++#include <mupdf/fitz.h>
++#include <mupdf/pdf.h>
++#include <mupdf/xps.h>
+
+ #include FT_FREETYPE_H
+
diff --git a/app-text/llpp/llpp-9999.ebuild b/app-text/llpp/llpp-9999.ebuild
index 2d3a41911934..71e2f61e83be 100644
--- a/app-text/llpp/llpp-9999.ebuild
+++ b/app-text/llpp/llpp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-9999.ebuild,v 1.24 2013/06/16 22:26:39 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-9999.ebuild,v 1.25 2013/06/26 19:55:51 xmw Exp $
EAPI=5
@@ -39,7 +39,9 @@ RESTRICT="!ocamlopt? ( strip )"
src_prepare() {
epatch "${FILESDIR}"/${PN}-11-WM_CLASS.patch \
"${FILESDIR}"/${P}-mupdf_trailer.patch \
- "${FILESDIR}"/${P}-fz_new_text_page.patch
+ "${FILESDIR}"/${P}-fz_new_text_page.patch \
+ "${FILESDIR}"/${P}-mupdf-split-headers.patch \
+ "${FILESDIR}"/${P}-fz_drop_display_list.patch
}
src_compile() {