summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/opensp/ChangeLog8
-rw-r--r--app-text/opensp/files/digest-opensp-1.5.12
-rw-r--r--app-text/opensp/files/digest-opensp-1.5.23
-rw-r--r--app-text/opensp/opensp-1.5.2.ebuild69
4 files changed, 81 insertions, 1 deletions
diff --git a/app-text/opensp/ChangeLog b/app-text/opensp/ChangeLog
index 75a60e5bad88..5e1573fd9bb7 100644
--- a/app-text/opensp/ChangeLog
+++ b/app-text/opensp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/opensp
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/ChangeLog,v 1.29 2006/04/05 20:02:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/ChangeLog,v 1.30 2006/05/23 21:29:27 leonardop Exp $
+
+*opensp-1.5.2 (23 May 2006)
+
+ 23 May 2006; Leonardo Boshell <leonardop@gentoo.org> +opensp-1.5.2.ebuild:
+ New release. Install a few files with dodoc. Set the correct license.
+ Dropped PDEPEND since older versions of openjade are no longer available.
05 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> opensp-1.5.1.ebuild:
Add ~x86-fbsd keyword.
diff --git a/app-text/opensp/files/digest-opensp-1.5.1 b/app-text/opensp/files/digest-opensp-1.5.1
index 867f9dca9ec6..b2abadc01d23 100644
--- a/app-text/opensp/files/digest-opensp-1.5.1
+++ b/app-text/opensp/files/digest-opensp-1.5.1
@@ -1 +1,3 @@
MD5 f46fe0a04b76a4454ec27b7fcc84ec54 OpenSP-1.5.1.tar.gz 1418784
+RMD160 42731fff1e5a1529037c2398de6efe5d9c608a74 OpenSP-1.5.1.tar.gz 1418784
+SHA256 3f0649840dc3d6ec432e3c8d933b178208f3feccb6db111d22c8995ad07c736b OpenSP-1.5.1.tar.gz 1418784
diff --git a/app-text/opensp/files/digest-opensp-1.5.2 b/app-text/opensp/files/digest-opensp-1.5.2
new file mode 100644
index 000000000000..dfed13d2899a
--- /dev/null
+++ b/app-text/opensp/files/digest-opensp-1.5.2
@@ -0,0 +1,3 @@
+MD5 670b223c5d12cee40c9137be86b6c39b OpenSP-1.5.2.tar.gz 1521390
+RMD160 6e671a267562c5b9283e7e6504e8339cb1d86850 OpenSP-1.5.2.tar.gz 1521390
+SHA256 57f4898498a368918b0d49c826aa434bb5b703d2c3b169beb348016ab25617ce OpenSP-1.5.2.tar.gz 1521390
diff --git a/app-text/opensp/opensp-1.5.2.ebuild b/app-text/opensp/opensp-1.5.2.ebuild
new file mode 100644
index 000000000000..d306a8efa834
--- /dev/null
+++ b/app-text/opensp/opensp-1.5.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.2.ebuild,v 1.1 2006/05/23 21:29:27 leonardop Exp $
+
+inherit eutils flag-o-matic
+
+MY_P=${P/opensp/OpenSP}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
+HOMEPAGE="http://openjade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
+
+LICENSE="JamesClark"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="nls? ( >=sys-devel/gettext-0.14.5 )"
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5-gcc34.patch
+}
+
+
+src_compile() {
+ #
+ # The following filters are taken from openjade's ebuild. See bug #100828.
+ #
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ # Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
+ # on hppa. Using -O1 works fine. So I force it here.
+ use hppa && replace-flags -O2 -O1
+
+ local myconf="--enable-http \
+ --enable-default-catalog=/etc/sgml/catalog \
+ --enable-default-search-path=/usr/share/sgml \
+ --datadir=/usr/share/sgml/${P} \
+ $(use_enable nls)"
+
+ econf ${myconf} || die "econf failed"
+ emake pkgdocdir=/usr/share/doc/${PF} || die "Compilation failed"
+}
+
+
+src_install() {
+ make DESTDIR="${D}" \
+ pkgdocdir=/usr/share/doc/${PF} install || die "Installation failed"
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}
+
+
+pkg_postinst() {
+ ewarn "Please note that the soname of the library changed."
+ ewarn "If you are upgrading from a previous version you need"
+ ewarn "to fix dynamic linking inconsistencies by executing:"
+ ewarn
+ ewarn " revdep-rebuild --library='libosp.so.*'"
+}