summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/hnb/ChangeLog9
-rw-r--r--app-text/hnb/files/hnb-1.9.18-flags.patch106
-rw-r--r--app-text/hnb/hnb-1.9.18-r1.ebuild37
3 files changed, 151 insertions, 1 deletions
diff --git a/app-text/hnb/ChangeLog b/app-text/hnb/ChangeLog
index 8e0fffa55510..b7acc350ea22 100644
--- a/app-text/hnb/ChangeLog
+++ b/app-text/hnb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/hnb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hnb/ChangeLog,v 1.19 2009/07/23 22:31:07 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hnb/ChangeLog,v 1.20 2009/10/23 12:31:50 jer Exp $
+
+*hnb-1.9.18-r1 (23 Oct 2009)
+
+ 23 Oct 2009; Jeroen Roovers <jer@gentoo.org> +hnb-1.9.18-r1.ebuild,
+ +files/hnb-1.9.18-flags.patch:
+ Respect CFLAGS, LDFLAGS (bug #240132), build parallel, separate CFLAGS and
+ CPPFLAGS.
23 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> hnb-1.9.17.ebuild,
hnb-1.9.18.ebuild:
diff --git a/app-text/hnb/files/hnb-1.9.18-flags.patch b/app-text/hnb/files/hnb-1.9.18-flags.patch
new file mode 100644
index 000000000000..325ec1187103
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-flags.patch
@@ -0,0 +1,106 @@
+--- ./hnb-1.9.18/Makefile.orig 2003-08-27 04:50:58.000000000 +0200
++++ ./hnb-1.9.18/Makefile 2009-10-23 14:23:16.000000000 +0200
+@@ -1,19 +1,19 @@
+
+ src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
+- (cd src;make)
++ (cd src;$(MAKE))
+ install: src/hnb
+ install -D src/hnb /usr/local/bin/hnb
+ install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
+ clean:
+- (cd src;make clean)
+- (cd util;make clean)
++ (cd src;$(MAKE) clean)
++ (cd util;$(MAKE) clean)
+ rm -f *~
+
+ rcupdate: updaterc
+ updaterc: src/hnbrc.inc
+
+ src/hnbrc.inc: doc/hnbrc
+- (cd util;make)
++ (cd util;$(MAKE))
+ echo -n "\"">src/hnbrc.inc
+ cat doc/hnbrc | util/asc2c >> src/hnbrc.inc
+ echo "\"">>src/hnbrc.inc
+--- ./hnb-1.9.18/hnb-1.9.18/Makefile.orig 2003-08-27 04:50:58.000000000 +0200
++++ ./hnb-1.9.18/hnb-1.9.18/Makefile 2009-10-23 14:23:16.000000000 +0200
+@@ -1,19 +1,19 @@
+
+ src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
+- (cd src;make)
++ (cd src;$(MAKE))
+ install: src/hnb
+ install -D src/hnb /usr/local/bin/hnb
+ install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
+ clean:
+- (cd src;make clean)
+- (cd util;make clean)
++ (cd src;$(MAKE) clean)
++ (cd util;$(MAKE) clean)
+ rm -f *~
+
+ rcupdate: updaterc
+ updaterc: src/hnbrc.inc
+
+ src/hnbrc.inc: doc/hnbrc
+- (cd util;make)
++ (cd util;$(MAKE))
+ echo -n "\"">src/hnbrc.inc
+ cat doc/hnbrc | util/asc2c >> src/hnbrc.inc
+ echo "\"">>src/hnbrc.inc
+--- ./hnb-1.9.18/src/Makefile.orig 2003-08-27 04:50:58.000000000 +0200
++++ ./hnb-1.9.18/src/Makefile 2009-10-23 14:23:16.000000000 +0200
+@@ -1,5 +1,6 @@
+ LIBS=-lncurses libcli/libcli.a
+-CFLAGS=-I.. -Ilibcli -DHAVE_CONFIG_H -Wall -pedantic -g
++CFLAGS+=-Wall -pedantic
++CPPFLAGS+=-I.. -Ilibcli -DHAVE_CONFIG_H
+
+ CFILES=$(wildcard *.c)
+ OBJS=$(patsubst %.c,%.o,$(CFILES))
+@@ -8,12 +9,12 @@
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+
+ hnb: libcli/libcli.a Makefile $(OBJS) init_subsystems.c *.h *.inc
+- $(CC) -o hnb $(OBJS) $(LIBS) $(CFLAGS)
++ $(CC) -o hnb $(OBJS) $(LIBS) $(CFLAGS) $(LDFLAGS)
+ # strip hnb
+ libcli/libcli.a: libcli/*.c
+- (cd libcli;make libcli.a)
++ (cd libcli;$(MAKE) libcli.a)
+ libcli/libcli_p.a: libcli/*.c
+- (cd libcli;make libcli_p.a)
++ (cd libcli;$(MAKE) libcli_p.a)
+ init_subsystems.c: *.c
+ echo "/* this file is autogenerated, do not edit */">init_subsystems.c
+ cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
+@@ -23,7 +24,7 @@
+ echo "}">>init_subsystems.c
+ clean:
+ rm -f xml_debug hnb $(OBJS) *~ cli_*.inc
+- (cd libcli;make clean)
++ (cd libcli;$(MAKE) clean)
+ hnb_p: *.c libcli/libcli_p.a init_subsystems.c
+ $(CC) -o hnb_p *.c -pg -lncurses_p libcli/libcli_p.a -I.. -Ilibcli -DHAVE_CONFIG_H
+
+--- ./hnb-1.9.18/src/libcli/Makefile.orig 2003-08-27 04:50:59.000000000 +0200
++++ ./hnb-1.9.18/src/libcli/Makefile 2009-10-23 14:25:37.000000000 +0200
+@@ -1,5 +1,3 @@
+-CFLAGS = -Wall
+-
+ OBJS = cli.o cli_history.o cli_tokenize.o
+
+ all: libcli.a libcli.so test-static test-shared
+@@ -9,8 +7,8 @@
+ libcli.a: $(OBJS)
+ ar rc libcli.a cli*.o
+ libcli_p.a:
+- $(CC) -pg -c cli.c
+- $(CC) -pg -c cli_history.c
++ $(CC) -pg -c cli.c $(CFLAGS)
++ $(CC) -pg -c cli_history.c $(CFLAGS)
+ ar rcs libcli_p.a cli*.o
+ libcli.so: $(OBJS)
+ $(CC) -shared cli*.o -o libcli.so $(CFLAGS) $(LIBS)
diff --git a/app-text/hnb/hnb-1.9.18-r1.ebuild b/app-text/hnb/hnb-1.9.18-r1.ebuild
new file mode 100644
index 000000000000..b20a85e21cde
--- /dev/null
+++ b/app-text/hnb/hnb-1.9.18-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hnb/hnb-1.9.18-r1.ebuild,v 1.1 2009/10/23 12:31:50 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A program to organize many kinds of data in one place."
+SRC_URI="http://hnb.sourceforge.net/.files/${P}.tar.gz"
+HOMEPAGE="http://hnb.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ for i in $(find . -name Makefile); do
+ cp -av "${i}"{,.orig}
+ done
+ epatch "${FILESDIR}/${P}-flags.patch"
+}
+
+src_compile() {
+ tc-export CC
+ default_src_compile
+}
+
+src_install() {
+ dodoc README doc/hnbrc
+ doman doc/hnb.1
+ dobin src/hnb
+}