summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/tcomment')
-rw-r--r--app-vim/tcomment/ChangeLog10
-rw-r--r--app-vim/tcomment/Manifest4
-rw-r--r--app-vim/tcomment/metadata.xml5
-rw-r--r--app-vim/tcomment/tcomment-2.08.ebuild22
4 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/tcomment/ChangeLog b/app-vim/tcomment/ChangeLog
new file mode 100644
index 000000000000..6732aee7ff47
--- /dev/null
+++ b/app-vim/tcomment/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/tcomment
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/tcomment/ChangeLog,v 1.1 2013/09/26 07:56:34 radhermit Exp $
+
+*tcomment-2.08 (26 Sep 2013)
+
+ 26 Sep 2013; Tim Harder <radhermit@gentoo.org> +tcomment-2.08.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/tcomment/Manifest b/app-vim/tcomment/Manifest
new file mode 100644
index 000000000000..4deef585b951
--- /dev/null
+++ b/app-vim/tcomment/Manifest
@@ -0,0 +1,4 @@
+DIST tcomment-2.08.tar.gz 23070 SHA256 d34a7fd2736ca63752cc90f9749dd4897150fdef490f3841c38d0f95272ec769 SHA512 f3067aab71684e3b6f1ace5b2472e312f517545760e7e0a9f350a1b0756d529b6c4184197b61aacf22bfed6bef06839ff9ef839c28702d6fd0c02101659d64c8 WHIRLPOOL 0c8f6b421ffd45d0d26de618d4fcebbc534e316fead7e0fb87d8701dcd0e005aeaad151f9c5abb21cd6cd82292ce40f9c65f5c7e1494f08f052c30a715cc4c81
+EBUILD tcomment-2.08.ebuild 584 SHA256 0e3d3e247a335292611ea0d7e47601f4d60cc2bfe8de6a1aba110c56b6fc1347 SHA512 4de535e899d6e85f305f0a9768c19ddba9bdd5f1f1f59b08b44b916b1e91d56b2f06dea076bcde6fdd8b7322bf84396e1eb2d8040f9de9966db14f50171dd0b5 WHIRLPOOL 5156be4de97aa8253114593f0af0b7545402c97d701772c5cc281fad23df80ee09b642b2608b86f4b3dc21d2be6439342b56b3eb8d94ef70df5294e4bc659212
+MISC ChangeLog 255 SHA256 12ee5a058610c7842871c40ad1e8fcf150f17f5cd75b045dd267345327e34617 SHA512 9d38a225d1af215a9f1f74daa8f6c86b623ad7bcb1a6ad6563e5b132f90597c7d47ab992cb61e1353be8bd0188782a777fac8bbe892465514efe4dd6649405c5 WHIRLPOOL fe6ce44e8b3aa0fb4b6f3aa56aeea0310b7bac52354b0c27ef3ee049f568b8a372bba75f25aa02c2d648b7c6297bc2f47c3e8e4b12db5e8f1d0d4c208065f8ba
+MISC metadata.xml 156 SHA256 64d20c782589b423a6e75ba6fff7edead1ec8fbae742d27dd57f5299e8328500 SHA512 7dc1d902106e794e1a12bde5dcacb8b7143584cba9c61e72ac5728dd952663144c1b0efc949fbbc9fcec03b396b5e060e8263eaad7d70cd82d6d5b350c62f0c1 WHIRLPOOL 4381a5d144e783e5979d394720b32f7d95818a8571f748e72c5ece965c4e0375b1aec0c34f6f506a9f9fc255f1b69a220fdb74d1dbb8aabc92ec48afa44ab883
diff --git a/app-vim/tcomment/metadata.xml b/app-vim/tcomment/metadata.xml
new file mode 100644
index 000000000000..5fcb67350f69
--- /dev/null
+++ b/app-vim/tcomment/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/tcomment/tcomment-2.08.ebuild b/app-vim/tcomment/tcomment-2.08.ebuild
new file mode 100644
index 000000000000..346860ef7b0f
--- /dev/null
+++ b/app-vim/tcomment/tcomment-2.08.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/tcomment/tcomment-2.08.ebuild,v 1.1 2013/09/26 07:56:34 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ rm -r README spec ${PN}-addon* || die
+}