summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgmecab/pgmecab-1.1-r3.ebuild')
-rw-r--r--dev-db/pgmecab/pgmecab-1.1-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-db/pgmecab/pgmecab-1.1-r3.ebuild b/dev-db/pgmecab/pgmecab-1.1-r3.ebuild
new file mode 100644
index 000000000000..c4ec361f7b6d
--- /dev/null
+++ b/dev-db/pgmecab/pgmecab-1.1-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/pgmecab-1.1-r3.ebuild,v 1.1 2008/11/15 00:03:50 matsuu Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="PostgreSQL function to Wakachigaki for Japanese words"
+HOMEPAGE="http://www.emaki.minidns.net/Programming/postgres/index.html"
+SRC_URI="http://www.emaki.minidns.net/Programming/postgres/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/mecab
+ >=virtual/postgresql-server-7.4"
+DEPEND="${RDEPEND}
+ app-admin/eselect-postgresql"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ # Bug #239594
+ PGVER=( $(get_version_components $(eselect postgresql show)) )
+ PGMAJOR="${PGVER[0]}"
+ PGMINOR="${PGVER[1]}"
+ if [ ${PGMAJOR} -eq 8 -a ${PGMINOR} -gt 2 -o ${PGMAJOR} -gt 8 ] ; then
+ epatch "${FILESDIR}/${PF}-postgres83.patch"
+ fi
+}
+
+src_compile() {
+ emake USE_PGXS=1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install || die
+
+ dodoc README.pgmecab
+}