summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/wfmath/ChangeLog8
-rw-r--r--dev-games/wfmath/files/wfmath-0.3.11-gcc47.patch21
-rw-r--r--dev-games/wfmath/wfmath-0.3.10.ebuild41
-rw-r--r--dev-games/wfmath/wfmath-0.3.11.ebuild11
-rw-r--r--dev-games/wfmath/wfmath-1.0.0.ebuild12
5 files changed, 42 insertions, 51 deletions
diff --git a/dev-games/wfmath/ChangeLog b/dev-games/wfmath/ChangeLog
index 4eb40135a03d..6320cbbb4eed 100644
--- a/dev-games/wfmath/ChangeLog
+++ b/dev-games/wfmath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/wfmath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.20 2012/07/10 16:50:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.21 2012/10/31 09:25:13 tupone Exp $
+
+ 31 Oct 2012; Tupone Alfredo <tupone@gentoo.org> -wfmath-0.3.10.ebuild,
+ wfmath-0.3.11.ebuild, +files/wfmath-0.3.11-gcc47.patch, wfmath-1.0.0.ebuild:
+ Remove old affected by Bug #362731 from Diego
+ Migrating to EAPI 4 the 1.0.0 version
+ Fix build with gcc-4.7 Bug #425706 by Diego
*wfmath-1.0.0 (10 Jul 2012)
diff --git a/dev-games/wfmath/files/wfmath-0.3.11-gcc47.patch b/dev-games/wfmath/files/wfmath-0.3.11-gcc47.patch
new file mode 100644
index 000000000000..c475ccb1ddad
--- /dev/null
+++ b/dev-games/wfmath/files/wfmath-0.3.11-gcc47.patch
@@ -0,0 +1,21 @@
+--- wfmath/vector.h.old 2012-10-31 08:39:38.033547273 +0100
++++ wfmath/vector.h 2012-10-31 08:40:12.200097132 +0100
+@@ -34,6 +34,7 @@
+ #include <wfmath/zero.h>
+
+ #include <iosfwd>
++#include <cmath>
+
+ namespace WFMath {
+
+--- wfmath/point.h.old 2012-10-31 08:41:00.226654036 +0100
++++ wfmath/point.h 2012-10-31 08:41:52.353918234 +0100
+@@ -32,6 +32,8 @@
+ #include <memory>
+ #include <iosfwd>
+
++#include <cmath>
++
+ namespace WFMath {
+
+ template<const int dim>
diff --git a/dev-games/wfmath/wfmath-0.3.10.ebuild b/dev-games/wfmath/wfmath-0.3.10.ebuild
deleted file mode 100644
index 052040812c9a..000000000000
--- a/dev-games/wfmath/wfmath-0.3.10.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.10.ebuild,v 1.5 2011/01/16 04:11:53 mr_bones_ Exp $
-
-EAPI=2
-DESCRIPTION="Worldforge math library"
-HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
-SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc static-libs"
-
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- emake -C doc docs || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
- if use doc; then
- dohtml doc/html/*
- fi
- if ! use static-libs ; then
- find "${D}" -type f -name '*.la' -exec rm {} + \
- || die "la removal failed"
- fi
-}
diff --git a/dev-games/wfmath/wfmath-0.3.11.ebuild b/dev-games/wfmath/wfmath-0.3.11.ebuild
index 7372cbac97c2..ba2d63899648 100644
--- a/dev-games/wfmath/wfmath-0.3.11.ebuild
+++ b/dev-games/wfmath/wfmath-0.3.11.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.11.ebuild,v 1.3 2011/11/11 09:18:33 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.11.ebuild,v 1.4 2012/10/31 09:25:13 tupone Exp $
EAPI=2
+
+inherit eutils
+
DESCRIPTION="Worldforge math library"
HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
@@ -15,6 +18,10 @@ IUSE="doc static-libs"
RDEPEND=""
DEPEND="doc? ( app-doc/doxygen )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
src_configure() {
econf \
--disable-dependency-tracking \
diff --git a/dev-games/wfmath/wfmath-1.0.0.ebuild b/dev-games/wfmath/wfmath-1.0.0.ebuild
index 4e35e98fde1d..9acbbc4c664e 100644
--- a/dev-games/wfmath/wfmath-1.0.0.ebuild
+++ b/dev-games/wfmath/wfmath-1.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-1.0.0.ebuild,v 1.1 2012/07/10 16:50:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-1.0.0.ebuild,v 1.2 2012/10/31 09:25:13 tupone Exp $
-EAPI=2
+EAPI=4
DESCRIPTION="Worldforge math library"
HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
@@ -18,20 +18,18 @@ DEPEND="doc? ( app-doc/doxygen )
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static)
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc; then
- emake -C doc docs || die "emake doc failed"
+ emake -C doc docs
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ default
if use doc; then
dohtml doc/html/*
fi