summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/xss-sanitize/ChangeLog9
-rw-r--r--dev-haskell/xss-sanitize/xss-sanitize-0.3.5.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-haskell/xss-sanitize/ChangeLog b/dev-haskell/xss-sanitize/ChangeLog
index e19f868d0105..0e5b97e38158 100644
--- a/dev-haskell/xss-sanitize/ChangeLog
+++ b/dev-haskell/xss-sanitize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/xss-sanitize
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xss-sanitize/ChangeLog,v 1.2 2013/09/13 06:44:35 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xss-sanitize/ChangeLog,v 1.3 2014/03/09 05:18:03 gienah Exp $
+
+*xss-sanitize-0.3.5 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +xss-sanitize-0.3.5.ebuild:
+ Bump xss-sanitize to 0.3.5
*xss-sanitize-0.3.4 (13 Sep 2013)
diff --git a/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.ebuild b/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.ebuild
new file mode 100644
index 000000000000..51df81b9cb06
--- /dev/null
+++ b/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xss-sanitize/xss-sanitize-0.3.5.ebuild,v 1.1 2014/03/09 05:18:03 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
+HOMEPAGE="http://github.com/yesodweb/haskell-xss-sanitize"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?]
+ >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/hunit-1.2 )
+"